View Issue Details

IDProjectCategoryView StatusLast Update
0001740LazarusLCLpublic2011-04-07 14:16
Reporterstocki Assigned ToZeljan Rikalo  
PrioritynormalSeverityfeatureReproducibilityalways
Status closedResolutionduplicate 
PlatformWin32 
Product Version0.9.13 (SVN) 
Summary0001740: Merge Dialogs and PrintersDlgs
DescriptionPlease merge Dialogs and PrintersDlgs units. This can be done without to much effort and fixes one more compatibility issue.
TagsNo tags attached.
Fixed in Revision
LazTarget1.2
WidgetsetWin32/Win64
Attached Files

Relationships

duplicate of 0000939 closedJuha Manninen TPrinterSetupDialog is part of unit Dialogs 

Activities

Vincent Snijders

2006-02-19 08:48

manager   ~0002158

Can you provide a patch?

2006-02-19 10:19

 

dialogs.ZIP (4,586 bytes)

stocki

2006-02-19 10:20

reporter   ~0002159

Merged file. Maybe not compile clean and un-tested.

Vincent Snijders

2006-02-19 14:02

manager   ~0002161

It does not compile, because of errors in the uses clause:
It contains itself (Dialogs) and the LCL doesn't have OS printers, because that is provided by the Printers4Lazarus package.

More effort is needed.

I suggest you take approach C mentioned in issue 939. If you have questions about that, feel free to ask them on the mailing list.

This issue has target "post 1.0", which means the Lazarus developers think that a 1.0 release can be made with this issue unfixed. If you want this issue to be fixed before the 1.0 release, Lazarus users must provide a (working) patch.

Zeljan Rikalo

2011-04-07 14:15

developer   ~0047317

Resolved because it's duplicate of 0000939

Issue History

Date Modified Username Field Change
2006-02-19 07:52 stocki New Issue
2006-02-19 07:52 stocki Widgetset => Win32
2006-02-19 08:47 Vincent Snijders Target => post 1.0
2006-02-19 08:47 Vincent Snijders Status new => acknowledged
2006-02-19 08:48 Vincent Snijders Note Added: 0002158
2006-02-19 08:53 Vincent Snijders Relationship added duplicate of 0000939
2006-02-19 10:19 stocki File Added: dialogs.ZIP
2006-02-19 10:20 stocki Note Added: 0002159
2006-02-19 14:02 Vincent Snijders Note Added: 0002161
2008-09-30 23:35 Vincent Snijders LazTarget post 1.0 => -
2010-11-17 10:50 Zeljan Rikalo LazTarget - => 1.2
2011-04-07 14:15 Zeljan Rikalo Duplicate ID 0 => 939
2011-04-07 14:15 Zeljan Rikalo Status acknowledged => resolved
2011-04-07 14:15 Zeljan Rikalo Resolution open => duplicate
2011-04-07 14:15 Zeljan Rikalo Assigned To => Zeljan Rikalo
2011-04-07 14:15 Zeljan Rikalo Note Added: 0047317
2011-04-07 14:16 Zeljan Rikalo Status resolved => closed