View Issue Details

IDProjectCategoryView StatusLast Update
0017487LazarusIDEpublic2011-12-01 11:25
ReporterDavid Noriega Assigned ToVincent Snijders  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionno change required 
Product Version0.9.29 (SVN) 
Summary0017487: TAB in Object Inspector causes problem
DescriptionIf you hit TAB in the object inspector, it somehow skews the keyboard input in such a way that typing a character where a property name of starts with that character the cursor is set to that property's setting box. If you hit TAB again the error is fixed.
Additional InformationWindows XP

I find it natural to type TAB to move to the next property in the object inspector. It doesn't do it and instead causes that bug.
TagsNo tags attached.
Fixed in Revision
LazTarget-
Widgetset
Attached Files

Relationships

related to 0016259 closedPaul Ishenin Cannot Change Object Properties 
related to 0016213 resolvedJuha Manninen Data Controls properties key shortcut 
related to 0015464 closedZeljan Rikalo cannot change the name of an object in property editor 

Activities

Vincent Snijders

2010-09-24 22:15

manager   ~0041305

I don't know if I understand you correctly, I thought it was by design, so you switch properties quickly with the keyboard, one tab to select list of property names, another tab to enter a property value.

Juha Manninen

2010-09-25 10:50

developer   ~0041307

This was fixed somehow by Paul Ishenin with issue 0016259. His comment:

Now when you click on Object inspector or change selected components it switches to editing mode from navigation mode. If someone needs better notifications of that mode please create a patch and open another issue.

What kind of behaviour in object inspector would be the best?

David Noriega

2010-09-25 15:20

reporter   ~0041309

I suggest removing this feature for the benefit of those moving from Delphi. For those already used to this, make it an option in Environment>Object Inspector settings.

Vincent Snijders

2010-10-29 16:15

manager   ~0042347

The described behavior is by design. To turn this off, you may create a new feature request.

Issue History

Date Modified Username Field Change
2010-09-24 20:26 David Noriega New Issue
2010-09-24 22:15 Vincent Snijders Note Added: 0041305
2010-09-25 10:50 Juha Manninen LazTarget => -
2010-09-25 10:50 Juha Manninen Note Added: 0041307
2010-09-25 10:50 Juha Manninen Status new => feedback
2010-09-25 10:50 Juha Manninen Relationship added related to 0016259
2010-09-25 10:51 Juha Manninen Relationship added related to 0016213
2010-09-25 10:51 Juha Manninen Relationship added related to 0015464
2010-09-25 15:20 David Noriega Note Added: 0041309
2010-10-29 16:15 Vincent Snijders Status feedback => resolved
2010-10-29 16:15 Vincent Snijders Resolution open => no change required
2010-10-29 16:15 Vincent Snijders Assigned To => Vincent Snijders
2010-10-29 16:15 Vincent Snijders Note Added: 0042347
2011-12-01 11:25 Marc Weustink Status resolved => closed