View Issue Details

IDProjectCategoryView StatusLast Update
0017528LazarusDebuggerpublic2018-07-17 00:13
ReporterDenis Gottardello Assigned ToMartin Friebe  
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionnot fixable 
Product Version0.9.29 (SVN) 
Summary0017528: Gdb does not work if a project is saved in a subdirectory of Desktop or Documents (on Windows XP)
DescriptionIf you create and save a project in a new directory created on the Desktop or in a subdirectory of Documents, Lazarus compiles the program but if you try to run it with Lazarus you obtain an error. The program works if you run it by hand.
TagsNo tags attached.
Fixed in Revision
LazTarget-
WidgetsetWin32/Win64
Attached Files

Relationships

related to 0018457 closedMartin Friebe Debugger issues with NTFS Volume 
related to 0018238 resolvedMartin Friebe Debugger crashes after the project is saved 

Activities

DALOZ - DE LOS RIOS Christophe

2010-10-06 12:19

reporter   ~0041536

I have the same problem.
I used 0.9.28.2 version of Lazarus and it is not possible run compiled program with Lazarus, reported SIGSERV error.

Possible run compiled program only outside of Lazarus.

I used Win32 widgetset.

Martin Friebe

2010-11-26 14:24

manager   ~0043560

Issue seems to be resolved in the meantime. Works with latest version of lazarus.

Please test and confirm

Vincent Snijders

2010-12-31 10:21

manager   ~0044749

No feedback from reporter.

Denis Gottardello

2010-12-31 10:49

reporter   ~0044750

Using Lazarus from svn, 31.12.2010, the problem exists.

Martin Friebe

2010-12-31 19:26

manager   ~0044767

"Using Lazarus from svn" => Have you also update gdb? which gdb version do you have?

If you resume (F9) after the SigSegV, does the app start?

Does the issue also occur, if you disable your AntiVirus Software? (Which AV do you use?)

If the SigSegV occurs,and you open the stack window, what is the stack trace?

Martin Friebe

2010-12-31 19:29

manager   ~0044768

Last edited: 2010-12-31 19:29

In addition to the above questions:

Also verify that bot related to: 0018238 (see the link in notes, about paths with similar begin) http://www.technipages.com/error-193-1-is-not-a-valid-win32-application.html

Denis Gottardello

2011-01-03 09:36

reporter   ~0044819

Last edited: 2011-01-03 09:38

I'm using the daily snapshoot of Lazarus for win32 named "Lazarus-0.9.31-28842-fpc-2.4.2-20101231-win32.exe". With a older version of Lazarus I can create project everywhere and I can run it with Lazarus without any problem. With this version of Lazarus I can create a project in "C:\New Folder" and in its subfolders (if exists) and I can run it without any problem. I can create and compile a project place in a folder named "New Folder" place on the desktop but, when I run it with Lazarus I obtain this error: "Errore del debugger Ooops, il debugger รจ entrato in stato di errore. Salvate subito il vostro lavoro! Premere stop e sperate..."

Martin Friebe

2011-01-03 13:08

manager   ~0044829

Last edited: 2011-01-03 14:02

Please open the "Debug output" window (before running your app), then start your app. After the error copy the content of the window, zip it and attach it.

Please check: http://www.technipages.com/error-193-1-is-not-a-valid-win32-application.html
Do you have a folder (or file) called C:\Program\ ... ?

if it works in "C:\New Folder" but not on desktop, then it sounds as if it is the same issue as 0018238.

If it did work with earlier versions, it may be an issue in the latest gdb version. If you have a 32 bit CPU, you can always try and downgrade gdb (download from mingw, or use from older Lazarus install).

-- Edit:
For me 0018238 also happens with 0.9.28.2 and earlier gdb, so if it is 0018238, and for you works on earlier Lazarus/Gdb, please attach the debug-output of the working Laz/Gdb too.

Denis Gottardello

2011-01-04 11:21

reporter   ~0044860

I have just attached the output of gdb for now.

2011-01-04 11:21

 

gdb.out.zip (2,945 bytes)

Martin Friebe

2011-01-04 18:03

manager   ~0044878

Thanks, the output (err 193) points indeed to this being the same as 18238.

This would mean that you probably have a file or folder called:
"C:/Documents" or "C:/Documents and Settings/Prog001/Desktop/Nuova"
(or any folder or file which has a name that equals the one of your app, up to one of the spaces)

I have reproduced this issue on an XP system. All my tests point to the problem either being in gdb or in XP itself.
I have also tested this with 0.9.28.2. And the error already existed.

Unfortunately I found no way so far, how the IDE can fix this.

---

I understand you said the error was previously *not* present:

- maybe the error is not due to the Lazarus version, but because something created the additional folder?

- if all that is not the case, then please check that you can indeed still run the same project, in the same folder, debugging in the 0.9.28.2 IDE (or whatever version works).
If you get to run it in a previous version, please attach the output of the working debug session.

Denis Gottardello

2011-06-21 10:58

reporter   ~0049250

I have found the reason for the strange behaviour of gdb.
Please, create a directory called "abcd e" and place it in c:\
Now create a file called "abcd" and place it in c:\
Now place in the directory "abcd e" an executable called "a.exe".
Now run "gdb c:\abcd e\a.exe" and then "run". You obtain an error.
If you you delete the file "abcd" all works well.

I don't know why but in c:\ of my pc I have found a file called "documents" and this make gdb unusable on all c:\documents and settings" folder and subfolder.

Please close me.

Martin Friebe

2011-06-21 11:55

manager   ~0049253

Thanks, same as for related issue...

Will however keep the issue open, until at least the error prompt is improved.

Martin Friebe

2011-07-31 02:21

manager   ~0050297

Reviewed, the issue can not be fixed.

The IDE (SVN) now displays the OS error to the user. An explanation has been added on the wiki.

Otherwise no further fix is possible

Issue History

Date Modified Username Field Change
2010-10-01 16:27 Denis Gottardello New Issue
2010-10-01 16:27 Denis Gottardello Status new => assigned
2010-10-01 16:27 Denis Gottardello Assigned To => Marc Weustink
2010-10-01 16:27 Denis Gottardello Widgetset => GTK 2
2010-10-06 12:19 DALOZ - DE LOS RIOS Christophe Note Added: 0041536
2010-11-26 14:24 Martin Friebe LazTarget => -
2010-11-26 14:24 Martin Friebe Note Added: 0043560
2010-11-26 14:24 Martin Friebe Status assigned => feedback
2010-12-31 10:21 Vincent Snijders Status feedback => resolved
2010-12-31 10:21 Vincent Snijders Resolution open => fixed
2010-12-31 10:21 Vincent Snijders Note Added: 0044749
2010-12-31 10:49 Denis Gottardello Status resolved => assigned
2010-12-31 10:49 Denis Gottardello Resolution fixed => reopened
2010-12-31 10:49 Denis Gottardello Note Added: 0044750
2010-12-31 10:57 Vincent Snijders Resolution reopened => open
2010-12-31 19:26 Martin Friebe Note Added: 0044767
2010-12-31 19:29 Martin Friebe Note Added: 0044768
2010-12-31 19:29 Martin Friebe Assigned To Marc Weustink => Martin Friebe
2010-12-31 19:29 Martin Friebe Status assigned => feedback
2010-12-31 19:29 Martin Friebe Note Edited: 0044768
2011-01-03 09:36 Denis Gottardello Note Added: 0044819
2011-01-03 09:38 Denis Gottardello Note Edited: 0044819
2011-01-03 13:08 Martin Friebe Note Added: 0044829
2011-01-03 14:02 Martin Friebe Note Edited: 0044829
2011-01-03 14:02 Martin Friebe Note Edited: 0044829
2011-01-04 11:21 Denis Gottardello Note Added: 0044860
2011-01-04 11:21 Denis Gottardello File Added: gdb.out.zip
2011-01-04 18:03 Martin Friebe Note Added: 0044878
2011-06-20 13:58 Martin Friebe Relationship added related to 0018457
2011-06-20 13:59 Martin Friebe Relationship added related to 0018238
2011-06-21 10:58 Denis Gottardello Note Added: 0049250
2011-06-21 11:55 Martin Friebe Note Added: 0049253
2011-07-31 02:21 Martin Friebe Widgetset GTK 2 => Win32/Win64
2011-07-31 02:21 Martin Friebe Status feedback => resolved
2011-07-31 02:21 Martin Friebe Resolution open => not fixable
2011-07-31 02:21 Martin Friebe Note Added: 0050297