View Issue Details

IDProjectCategoryView StatusLast Update
0017542FPCUtilitiespublic2011-11-30 21:39
ReporterGraeme Geldenhuys Assigned ToMichael Van Canneyt  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionunable to reproduce 
Platformx86_64OSUbuntu Linux 
Product Version2.5.1 
Fixed in Version2.4.4 
Summary0017542: fpdoc HTML output is double spaced
DescriptionAll the code examples like a class definition is now double spaced, where 2.4.0 behaviour was not. By double spaced I mean there is a blank line between every source code line in the HTML output. This is specific to the HTML output writer.
TagsNo tags attached.
Fixed in Revision16370
FPCOldBugId0
FPCTarget
Attached Files

Activities

Marco van de Voort

2010-10-24 17:26

manager   ~0042057

I just checked, and can't duplicate this. (FF 3.6.10 on Fedora 13). I also don't see anything in the html code that could cause this.

Could you retest or provide more information?

2010-10-26 12:52

 

01_output_from_old.png (25,784 bytes)   
01_output_from_old.png (25,784 bytes)   

2010-10-26 12:52

 

02_output_from_new.png (19,337 bytes)   
02_output_from_new.png (19,337 bytes)   

2010-10-26 12:52

 

03_output_from_old.png (30,557 bytes)   
03_output_from_old.png (30,557 bytes)   

2010-10-26 12:53

 

04_output_from_new.png (26,632 bytes)   
04_output_from_new.png (26,632 bytes)   

Graeme Geldenhuys

2010-10-26 12:54

reporter   ~0042134

See attached screenshots. Images 01 and 03 are from an older fpdoc. Images 02 and 04 and from fpdoc 2.4.3 and 2.5.1 output.

The newer output shows the double spacing (extra blank lines in output). I view the output with Google Chrome, Opera, Firefox 3.6 and Firefox 4.0.

Graeme Geldenhuys

2010-10-26 12:57

reporter   ~0042135

It's also not caused by my css file, because the Lazarus CCR site has the same issue.

 http://lazarus-ccr.sourceforge.net/docs/lcl/index.html

Marco van de Voort

2010-10-26 21:00

manager   ~0042183

Thanks, I'll reinvestigate. I looked at "code examples", IOW pieces of pascal code

Graeme Geldenhuys

2010-10-27 09:06

reporter   ~0042193

Sorry if I was unclear. By code examples I meant the interface section class definition that gets displayed in each topic (if the topic was about a class type), not the "Example" section at the end of a topic.

Also as the screenshots shows, any listing of unit names are also double spaced.

Marco van de Voort

2010-10-30 18:03

manager   ~0042441

Last edited: 2010-10-30 18:30

Retested it, have the same problem without fpdoc.css, but if I copy fpdoc.css to the root of the generated fpdoc content, the problems solves itself (firefox 3.6.10)

Probably lazarus-ccr output has the same problem.

Marco van de Voort

2010-10-30 18:55

manager   ~0042446

To avoid this issue, I did the same as with chm, let fpdoc copy the css file for plain html too.

Graeme Geldenhuys

2010-11-01 07:48

reporter   ~0042528

Last edited: 2010-11-01 07:51

I don't understand how that resolves the issues. My fpdoc.css file is in the root of a fpdoc package (which is the root of the fpdoc html output from the scripts I run), as the generated HTML files indicate. I have always had it like this for years, and only recently did the HTML output start with the doublespace bug.

eg:
In tiOPF have have 3 fpdoc packages. "Core", "GUI" and "Options". The html output directory looks as follows.

/opt/programming/tiOPF2/Docs
   .
   |-html
   |---core
   |-----tiautomap
   |-----tibasemediator
   |-----tibaseobject
   |----- ...many more here...
   |---gui
   |-----tidialogs
   |-----tiguiini
   |----- ...many more here...
   |---options
   |-----tidatabuffer_bom
   |-----tidatabuffer_cli
   |-----tisingleinstanceapp
   |-----tixml
   |----- ...many more here...

The fpdoc.css file must (and always have been) located in the root of every package. That means the html/core/ directory in the above example. The generated html file indicate that as well.

fpdoc.css is located at: html/core/fpdoc.css

The index file of "Core":

---------[ html/core/index.html ]----------------
<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN" "http://www.w3.org/TR/html4/loose.dtd">
<html>
<head>
<meta content="text/html; charset=utf-8" http-equiv="Content-Type">
<title>Reference for package 'tiOPF2Core'</title>
<link rel="stylesheet" href="fpdoc.css" type="text/css">
...
-----------------------[ end ]-----------------

See the location of fpdoc.css.
...and now for a unit inside "Core"

---------------[ html/core/tiautomap.html ]------------------
<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN" "http://www.w3.org/TR/html4/loose.dtd">
<html>
<head>
<meta content="text/html; charset=utf-8" http-equiv="Content-Type">
<title>Reference for unit 'tiAutoMap'</title>
<link rel="stylesheet" href="../fpdoc.css" type="text/css">
...
-----------------------[ end ]-----------------

Again, the fpdoc.css location is pointing to the "core" directory.


So my fpdoc.css IS in the correct location, but the output is double spaced. Like I said, I have been using fpdoc for years and it always worked fine until recently, and I changed nothing on my side.

Below is fpdoc output generated for tiOPF in 2009, and if you browser that help you will see the output is NOT double spaced, but the fpdoc.css is in the exact locations as I described above. With the new fpdoc the css file is in the exact same locations as before, I get doublespacing. So there IS something wrong with the latest fpdoc and HTML output.


fpdoc output from 2009-05:

http://opensoft.homeip.net:8080/tiopf/core/index.html
http://opensoft.homeip.net:8080/tiopf/core/fpdoc.css
http://opensoft.homeip.net:8080/tiopf/core/tiautomap/index.html

2010-11-01 07:54

 

Selection_001.png (83,628 bytes)   
Selection_001.png (83,628 bytes)   

2010-11-01 07:55

 

Selection_002.png (64,845 bytes)   
Selection_002.png (64,845 bytes)   

2010-11-01 07:55

 

Selection_003.png (41,581 bytes)   
Selection_003.png (41,581 bytes)   

Graeme Geldenhuys

2010-11-01 07:57

reporter   ~0042529

@Marco
As for your comment about CHM file, that too has the doublespace bug by the way. I attached screenshots using your last released CHM help archive. I viewed it with LHelp, xCHM and ChmSee, and as you can see, in all cases the listing of units are doublespaced too, just like plain HTML output.

Marco van de Voort

2010-11-07 18:40

manager   ~0042856

Yes. But that is a defect in those viewers then. Probably css related. It seems the more advanced the browser is (provided the CSS file is there) the better it works, since IE (chm on windows) firefox and QWebbrowser are fine with it.

In kchmviewer it is particularly noticable, since there the khtmlpart viewer has the problem, and the QT QWebBrowser viewer not.

So I conclude there is no _BUG_ in fpdoc. One could argue about webdesign practices and/or the lowest common denomitor of what HTML should be generated or not, but I'm not HTML savy enough about that, and I think that discussion belongs on the maillist and not here.

Michael Van Canneyt

2010-11-07 19:10

administrator   ~0042857

Since we cannot reliably reproduce this, and the official docs on the FPC website are fine, I'm concluding that there is no bug in FPC.

This is supported by the fact that neither the fpdoc.css nor the HTML generating algorithms have changed in many years.

If reliable steps to reproduce it with the official docs can be provided, then
the bug may be reopened.

Issue History

Date Modified Username Field Change
2010-10-04 09:27 Graeme Geldenhuys New Issue
2010-10-04 13:41 Jonas Maebe Status new => assigned
2010-10-04 13:41 Jonas Maebe Assigned To => Michael Van Canneyt
2010-10-24 17:26 Marco van de Voort Note Added: 0042057
2010-10-24 17:26 Marco van de Voort Status assigned => feedback
2010-10-26 12:52 Graeme Geldenhuys File Added: 01_output_from_old.png
2010-10-26 12:52 Graeme Geldenhuys File Added: 02_output_from_new.png
2010-10-26 12:52 Graeme Geldenhuys File Added: 03_output_from_old.png
2010-10-26 12:53 Graeme Geldenhuys File Added: 04_output_from_new.png
2010-10-26 12:54 Graeme Geldenhuys Note Added: 0042134
2010-10-26 12:57 Graeme Geldenhuys Note Added: 0042135
2010-10-26 21:00 Marco van de Voort Note Added: 0042183
2010-10-27 09:06 Graeme Geldenhuys Note Added: 0042193
2010-10-30 18:03 Marco van de Voort Note Added: 0042441
2010-10-30 18:30 Marco van de Voort Note Edited: 0042441
2010-10-30 18:55 Marco van de Voort Fixed in Revision => 16266
2010-10-30 18:55 Marco van de Voort Status feedback => resolved
2010-10-30 18:55 Marco van de Voort Resolution open => fixed
2010-10-30 18:55 Marco van de Voort Note Added: 0042446
2010-11-01 07:48 Graeme Geldenhuys Status resolved => feedback
2010-11-01 07:48 Graeme Geldenhuys Resolution fixed => reopened
2010-11-01 07:48 Graeme Geldenhuys Note Added: 0042528
2010-11-01 07:51 Graeme Geldenhuys Note Edited: 0042528
2010-11-01 07:54 Graeme Geldenhuys File Added: Selection_001.png
2010-11-01 07:55 Graeme Geldenhuys File Added: Selection_002.png
2010-11-01 07:55 Graeme Geldenhuys File Added: Selection_003.png
2010-11-01 07:57 Graeme Geldenhuys Note Added: 0042529
2010-11-07 18:40 Marco van de Voort Note Added: 0042856
2010-11-07 19:10 Michael Van Canneyt Status feedback => resolved
2010-11-07 19:10 Michael Van Canneyt Resolution reopened => unable to reproduce
2010-11-07 19:10 Michael Van Canneyt Note Added: 0042857
2011-05-01 16:28 Marco van de Voort FPCOldBugId => 0
2011-05-01 16:28 Marco van de Voort Fixed in Version => 2.4.4
2011-05-01 18:24 Marco van de Voort Fixed in Revision 16266 => 16370
2011-05-01 18:24 Marco van de Voort Status resolved => closed
2011-05-02 17:32 Marco van de Voort Status closed => resolved
2011-11-30 21:39 Marco van de Voort Status resolved => closed