View Issue Details

IDProjectCategoryView StatusLast Update
0017595LazarusIDEpublic2010-10-17 19:09
ReporterBernd KreussAssigned ToPaul Ishenin 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version0.9.29 (SVN)Product Build 
Target Version0.9.30Fixed in Version0.9.29 (SVN) 
Summary0017595: Version info -> "other info" gets lost after closing the project options dialog.
DescriptionWhen enabling "Include Version info in executable" and then entering data into the the section "other info", all this information will be gone and not used.

After closing the Options dialog with "ok" and reopening it this section is completely empty, the only item left is the version number (which is auto-generated from the version number at the top of the form). All other information is lost. Also I could not locate it anywhere in the .lpi file and the generated executables also won't contain any information other than the version number.

Additional InformationThis must be a regression because I can remember having successfully used this already and not so long ago, but I cannot tell the exact version number when it stopped working. It is broken in current trunk and it was also broken in a approx. 2 weeks old snapshot that I have just uninstalled (because of this bug and now I can't remember the exact revision number).
TagsNo tags attached.
Fixed in Revision27650
LazTarget0.9.30
Widgetset
Attached Files

Activities

Paul Ishenin

2010-10-11 10:46

manager   ~0041718

Please test and close if ok.

Bernd Kreuss

2010-10-17 19:09

reporter   ~0041882

works now. Thanks for fixing.

Issue History

Date Modified Username Field Change
2010-10-10 17:13 Bernd Kreuss New Issue
2010-10-10 22:26 Maxim Ganetsky LazTarget => -
2010-10-10 22:26 Maxim Ganetsky Additional Information Updated
2010-10-11 10:46 Paul Ishenin Fixed in Revision => 27650
2010-10-11 10:46 Paul Ishenin LazTarget - => 0.9.30
2010-10-11 10:46 Paul Ishenin Status new => resolved
2010-10-11 10:46 Paul Ishenin Fixed in Version => 0.9.29 (SVN)
2010-10-11 10:46 Paul Ishenin Resolution open => fixed
2010-10-11 10:46 Paul Ishenin Assigned To => Paul Ishenin
2010-10-11 10:46 Paul Ishenin Note Added: 0041718
2010-10-11 10:46 Paul Ishenin Target Version => 0.9.30
2010-10-17 19:09 Bernd Kreuss Status resolved => closed
2010-10-17 19:09 Bernd Kreuss Note Added: 0041882