View Issue Details

IDProjectCategoryView StatusLast Update
0017621FPCFCLpublic2011-11-30 22:12
ReporterFelipe Monteiro de CarvalhoAssigned ToMarco van de Voort 
PrioritynormalSeverityfeatureReproducibilityalways
Status closedResolutionnot fixable 
PlatformIntel Pentium 4OSMicrosoft WindowsOS VersionXP
Product VersionProduct Build 
Target VersionFixed in Version 
Summary0017621: The PNG writer cannot write an image with too many colors
DescriptionThe attached fcl-image project will fail with the attached error message.
TagsNo tags attached.
Fixed in Revision
FPCOldBugId0
FPCTarget
Attached Files

Relationships

related to 0017466 feedback Lazarus One particular PNG image makes canvas drawing a mess 

Activities

2010-10-13 13:30

 

pngerrormsg.PNG (7,248 bytes)
pngerrormsg.PNG (7,248 bytes)

2010-10-13 13:31

 

zip.zip (102,548 bytes)

Marco van de Voort

2010-10-13 18:02

manager   ~0041776

The default of fpwriterpng is "indexed", and properties like this are autodetected nowhere.

Setting writer.indexed:=false after creation makes the example work fine.

One could discuss if that is a feature or bug.

Felipe Monteiro de Carvalho

2010-10-21 17:31

developer   ~0041971

Maybe it should default to not indexed then, if indexed doesn't work properly

Marco van de Voort

2010-10-21 20:29

manager   ~0041982

All stuff is writing fine. It just assumes that you make sure that you chose the format to write to match the data you want to write.

Marco van de Voort

2010-11-07 15:16

manager   ~0042854

Added a remark about this to the fcl-image wiki page.

http://wiki.freepascal.org/fcl-image#Known_Issues_and_limitations

Marco van de Voort

2011-03-05 18:10

manager   ~0046425

Fixing this would need a new layer on top on this to (re)determine the file type after modification. The problem is annotated in the wiki -> close.

Issue History

Date Modified Username Field Change
2010-10-13 13:30 Felipe Monteiro de Carvalho New Issue
2010-10-13 13:30 Felipe Monteiro de Carvalho FPCOldBugId => 0
2010-10-13 13:30 Felipe Monteiro de Carvalho Issue generated from: 0017466
2010-10-13 13:30 Felipe Monteiro de Carvalho File Added: pngerrormsg.PNG
2010-10-13 13:30 Felipe Monteiro de Carvalho Category IDE => FCL
2010-10-13 13:31 Felipe Monteiro de Carvalho File Added: zip.zip
2010-10-13 13:31 Felipe Monteiro de Carvalho Relationship added related to 0017466
2010-10-13 18:02 Marco van de Voort Note Added: 0041776
2010-10-21 17:31 Felipe Monteiro de Carvalho Note Added: 0041971
2010-10-21 20:29 Marco van de Voort Note Added: 0041982
2010-11-07 15:16 Marco van de Voort Note Added: 0042854
2010-11-28 16:46 Marco van de Voort Severity major => feature
2011-03-05 18:10 Marco van de Voort Status new => resolved
2011-03-05 18:10 Marco van de Voort Resolution open => not fixable
2011-03-05 18:10 Marco van de Voort Assigned To => Marco van de Voort
2011-03-05 18:10 Marco van de Voort Note Added: 0046425
2011-11-30 22:12 Marco van de Voort Status resolved => closed