View Issue Details

IDProjectCategoryView StatusLast Update
0017626LazarusIDEpublic2013-07-24 10:34
ReporterAnnaAssigned ToMattias Gaertner 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version0.9.29 (SVN)Product Build 
Target Version0.9.30Fixed in Version0.9.29 (SVN) 
Summary0017626: [regression] Fresh Lazarus installation fails to create events (e.g. OnClick)
DescriptionOS:
Platform=Windows XP
CSD=Service Pack 3
Laz:
ftp://ftp.hu.freepascal.org/pub/lazarus/snapshots/Lazarus-0.9.29-27658-fpc-2.4.0-20101012-win32.exe

Just open project & try to click a button: http://img266.imageshack.us/img266/5494/20768399.png
TagsNo tags attached.
Fixed in Revision28582
LazTarget0.9.30
Widgetset
Attached Files

Relationships

has duplicate 0017687 closedMaxim Ganetsky IDE unusable in the new SVN, no matter which version of FPC. 
has duplicate 0017843 closedMaxim Ganetsky TDefaultComponentEditor Unable to find metod 
has duplicate 0018142 closedVincent Snijders Problems selecting an event in IDE:Object Inspector 
related to 0017901 closedMattias Gaertner Lazbuild crashes if current drive letter is lowercase 
related to 0020142 closedVincent Snijders Don't complete instalation; Lazarus show some errors before starts; Comes back bug # 17626 
related to 0024777 closedJuha Manninen Bug # 17626 comes back (Fresh Lazarus installation fails to create events (e.g. OnClick)) 

Activities

2010-10-14 08:05

 

OnClickAutocreationfailure.zip (128,290 bytes)

Anna

2010-10-14 08:45

reporter   ~0041797

Last edited: 2010-10-14 10:06

Compilier writes it cannot find ALL units. Allllll!!!!!!!!!!!
Screenshot:
http://img820.imageshack.us/img820/2733/37086161.png

Anna

2010-10-14 10:29

reporter   ~0041804

Last edited: 2010-10-14 10:29

In last update (Lazarus-0.9.29-27699-fpc-2.4.0-20101014-win32.exe) this error present too. You can see this bug also if just create project and click on any of On-events' "..."-button.

But in old Lazarus-0.9.29-27550-fpc-2.4.0-20101003-win32.exe everything okey.

Maxim Ganetsky

2010-10-15 23:19

developer   ~0041842

Can't reproduce. Lazarus works correctly for me.

Make sure that you have set correct path to FPC sources in Environment->Options and then run Environment->Rescan FPC source directory. This should solve your problems.

Anna

2010-10-16 13:08

reporter   ~0041853

Last edited: 2010-10-16 16:27

2 Maxim Ganetsky

Are you using clean installation on clean system? Or did you uninstal-install lazarus?

Please, use clean system or better Virtual PC 2007( http://download.microsoft.com/download/3/0/e/30e87f07-d6b3-4ab3-a93d-a17814ed8b4b/32%20BIT/setup.exe ) with ready-made HDD Image ( http://download.microsoft.com/download/B/7/2/B72085AE-0F04-4C6F-9182-BF1EE90F5273/IE6-on-XPSP3.exe )
Admin password: Password1

Screenshot:
http://img198.imageshack.us/img198/6088/78707141.png

Anna

2010-10-16 16:37

reporter   ~0041858

Last edited: 2010-10-16 17:19

>>Make sure that you have set correct path to
>>FPC sources in Environment->Options and then
>> run Environment->Rescan FPC source directo
>>ry. This should solve your problems.

It's no use. Project is compiled with all this 'non-existent' units and there are no errors. But if I press on "..."-button http://img266.imageshack.us/img266/5494/20768399.png I see error. So it is fake error, this error don't have an influence on compilating, but this error forbids On-event handler autocreation.

Why checking errors swithed on at all? Clicking on "..."-button http://img266.imageshack.us/img266/5494/20768399.png don't cause compilating process. So error checking don't need. Error checking is needed when compilation is started.

2010-10-16 17:33

 

environmentoptions.xml (693 bytes)

Maxim Ganetsky

2010-10-16 17:45

developer   ~0041861

First, calm down. IDE needs FPC sources in order to create an event and cannot find them.

Second, I reproduced the bug.

It is reproduced with default environmentoptions.xml file (attached).

If I change the following line in this file:

<FPCSourceDirectory Value="h:\lazarus\fpc\2.4.3\source">

so that FPC source path begins with uppercase symbol, i.e.:

<FPCSourceDirectory Value="H:\lazarus\fpc\2.4.3\source">

it starts to work OK.

Until this bug is fixed you *MUST* set correct path to FPC sources in Environment->Options (with the help of according open file dialog or by hand by changing disk name to uppercase) and then run Environment->Rescan FPC source directory. This will fix your issue.

Anna

2010-10-16 18:00

reporter   ~0041862

Last edited: 2010-10-16 18:02

Yes! Thank you very much. (^_^) (^3^)

I would like to note, that installator prompt to use lower case install path by default. If use upper case manually , then no errors .

lainz

2010-10-23 15:48

reporter   ~0042023

Last edited: 2010-10-23 15:51

Yes installing with "C:\lazarus" instead "c:\lazarus" works.

EDIT: it can be "fixed" for windows: the installer created with inno setup set uppercase the installation drive letter.

Vincent Snijders

2010-11-03 09:24

manager   ~0042695

Maybe the fpc source cache doesn't work correctly with case insensitive file names in all cases?

Mattias Gaertner

2010-11-05 02:44

manager   ~0042784

Is there any RTL function having problems with lowercase drive letters?

Vincent Snijders

2010-11-05 08:55

manager   ~0042786

I am not aware of such a problem. Do you have any hint where I can start debugging?

Anna

2011-08-27 19:10

reporter   ~0051185

Last edited: 2011-08-27 19:24

In version 9.31 (Lazarus-0.9.31-32058-fpc-2.4.4-20110826-win32.exe) these problem appears again :(

Why you repeat your errors?

Now I've used large disk-drive letter "I:\"
Snapshot: http://img88.imageshack.us/img88/8361/71109772.png

Anna

2011-08-28 17:48

reporter   ~0051214

In snapshot Lazarus-0.9.31-32070-fpc-2.4.4-20110828-win32.exe problem is solved. Thank you very much.

Vincent Snijders

2011-08-28 18:32

manager   ~0051216

I have no idea, what broke it, and I cannot find a revision between 32058 and 32070, which might have fixed it. Anyway, since it is working now, I resolved the issue.

Bart Broersma

2011-08-28 18:35

developer   ~0051217

Last edited: 2011-08-28 18:37

I have seen this in Lazarus 0.9.31 r31810M, but it isn't consistent.
It mostly happens to me if I just opend a project or created a new one.
Saving the projectfile, or restarting lazarus makes it go away most of the times...

I cannot see anything between r32058 and r32070 explaining why it went away for you.

@Vincent: we were probably typing at the same time...

Anna

2011-10-25 04:18

reporter   ~0053393

http://www.youtube.com/watch?v=ISMATNDGzjc

Anna

2011-10-25 06:05

reporter   ~0053394

Last edited: 2011-10-25 06:06

In new snap (Lazarus-0.9.31-33075-fpc-2.5.1-20111025-win32.exe) all is ok .
Thank you very much.(^_^)
You may close issue [for the umpteenth time (n_n) ].

Vincent Snijders

2011-10-25 09:18

manager   ~0053396

Maybe next time open a new issue, instead of reopening this one.

Issue History

Date Modified Username Field Change
2010-10-14 08:05 Anna New Issue
2010-10-14 08:05 Anna File Added: OnClickAutocreationfailure.zip
2010-10-14 08:45 Anna Note Added: 0041797
2010-10-14 10:06 Anna Note Edited: 0041797
2010-10-14 10:29 Anna Note Added: 0041804
2010-10-14 10:29 Anna Note Edited: 0041804
2010-10-15 23:19 Maxim Ganetsky LazTarget => -
2010-10-15 23:19 Maxim Ganetsky Status new => resolved
2010-10-15 23:19 Maxim Ganetsky Resolution open => unable to reproduce
2010-10-15 23:19 Maxim Ganetsky Assigned To => Maxim Ganetsky
2010-10-15 23:19 Maxim Ganetsky Note Added: 0041842
2010-10-16 13:08 Anna Note Added: 0041853
2010-10-16 13:08 Anna Note Edited: 0041853
2010-10-16 13:08 Anna Note Edited: 0041853
2010-10-16 13:09 Anna Note Edited: 0041853
2010-10-16 15:04 Anna Status resolved => assigned
2010-10-16 15:04 Anna Resolution unable to reproduce => reopened
2010-10-16 15:05 Anna Note Edited: 0041853
2010-10-16 16:27 Anna Note Edited: 0041853
2010-10-16 16:37 Anna Note Added: 0041858
2010-10-16 17:08 Anna Note Edited: 0041858
2010-10-16 17:09 Anna Note Edited: 0041858
2010-10-16 17:09 Anna Note Edited: 0041858
2010-10-16 17:09 Anna Note Edited: 0041858
2010-10-16 17:13 Anna Note Edited: 0041858
2010-10-16 17:14 Anna Note Edited: 0041858
2010-10-16 17:19 Anna Note Edited: 0041858
2010-10-16 17:33 Maxim Ganetsky File Added: environmentoptions.xml
2010-10-16 17:45 Maxim Ganetsky LazTarget - => 0.9.30
2010-10-16 17:45 Maxim Ganetsky Note Added: 0041861
2010-10-16 17:45 Maxim Ganetsky Status assigned => confirmed
2010-10-16 17:45 Maxim Ganetsky Target Version => 0.9.30
2010-10-16 17:48 Maxim Ganetsky Assigned To Maxim Ganetsky =>
2010-10-16 17:48 Maxim Ganetsky Severity block => minor
2010-10-16 17:48 Maxim Ganetsky Category LCL => IDE
2010-10-16 17:48 Maxim Ganetsky Summary OnClick Autocreation failure => [regression] Fresh Lazarus installation fails to create events (e.g. OnClick)
2010-10-16 18:00 Anna Note Added: 0041862
2010-10-16 18:00 Anna Note Edited: 0041862
2010-10-16 18:01 Anna Note Edited: 0041862
2010-10-16 18:02 Anna Note Edited: 0041862
2010-10-16 18:02 Anna Note Edited: 0041862
2010-10-23 00:42 Maxim Ganetsky Relationship added has duplicate 0017687
2010-10-23 15:48 lainz Note Added: 0042023
2010-10-23 15:51 lainz Note Edited: 0042023
2010-11-03 09:24 Vincent Snijders Note Added: 0042695
2010-11-03 09:24 Vincent Snijders Assigned To => Mattias Gaertner
2010-11-03 09:24 Vincent Snijders Status confirmed => assigned
2010-11-05 02:44 Mattias Gaertner Note Added: 0042784
2010-11-05 08:55 Vincent Snijders Note Added: 0042786
2010-11-06 16:37 Vincent Snijders Relationship added related to 0017843
2010-11-11 01:15 Maxim Ganetsky Relationship added related to 0017901
2010-11-11 21:51 Maxim Ganetsky Relationship replaced has duplicate 0017843
2010-12-01 17:04 Vincent Snijders Fixed in Revision => 28582
2010-12-01 17:04 Vincent Snijders Status assigned => resolved
2010-12-01 17:04 Vincent Snijders Fixed in Version => 0.9.29 (SVN)
2010-12-01 17:04 Vincent Snijders Resolution reopened => fixed
2010-12-01 22:36 Maxim Ganetsky Description Updated
2010-12-03 11:00 Vincent Snijders Relationship added has duplicate 0018142
2011-08-27 19:10 Anna Status resolved => assigned
2011-08-27 19:10 Anna Resolution fixed => reopened
2011-08-27 19:10 Anna Note Added: 0051185
2011-08-27 19:14 Anna Note Edited: 0051185
2011-08-27 19:23 Anna Note Edited: 0051185
2011-08-27 19:24 Anna Note Edited: 0051185
2011-08-28 17:48 Anna Note Added: 0051214
2011-08-28 18:32 Vincent Snijders Status assigned => resolved
2011-08-28 18:32 Vincent Snijders Resolution reopened => fixed
2011-08-28 18:32 Vincent Snijders Note Added: 0051216
2011-08-28 18:35 Bart Broersma Note Added: 0051217
2011-08-28 18:37 Bart Broersma Note Edited: 0051217
2011-08-29 03:45 Anna Status resolved => closed
2011-09-03 07:57 Vincent Snijders Relationship added related to 0020142
2011-10-25 04:18 Anna Status closed => assigned
2011-10-25 04:18 Anna Resolution fixed => reopened
2011-10-25 04:18 Anna Note Added: 0053393
2011-10-25 06:05 Anna Note Added: 0053394
2011-10-25 06:06 Anna Note Edited: 0053394
2011-10-25 09:18 Vincent Snijders Note Added: 0053396
2011-10-25 09:19 Vincent Snijders Status assigned => resolved
2011-10-25 09:19 Vincent Snijders Resolution reopened => fixed
2011-10-25 09:20 Anna Status resolved => closed
2013-07-24 10:34 Juha Manninen Relationship added related to 0024777