View Issue Details

IDProjectCategoryView StatusLast Update
0017637LazarusIDEpublic2011-12-01 11:24
ReporterGerry K. Assigned ToMartin Friebe  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionno change required 
Product Version0.9.28.2 
Target Version0.9.30Fixed in Version0.9.29 (SVN) 
Summary0017637: Editor shortcut mixup
DescriptionThe editor picks the wrong shortcut when there is a partial match. Suppose we have the following two keyboard shortcuts:

ecLineEnd: Ctrl Q + Ctrl D
ecWordRight: Ctrl D

When pressing Ctrl Q + Ctrl D the editor execute the ecWordRight command.
TagsNo tags attached.
Fixed in Revision
LazTarget0.9.30
Widgetset
Attached Files

Relationships

duplicate of 0017152 closedMartin Friebe Regression: Multi-keys shortcuts conflict with single-key shortcut 

Activities

Martin Friebe

2010-10-15 12:57

manager   ~0041832

Can you please test with the daily snapshot?

A similar issue was fixed a while back 0017152

Gerry K.

2010-10-15 15:06

reporter   ~0041834

Martin, thanks for the quick feedback. Downloaded today’s build and it works just fine (…)!

By the way, Delphi support up to three shortcuts for the same action, Lazarus just two. For example, in Delphi classic keyboard mapping you can move the cursor to the end of the line by the following shortcuts:

Ctrl Q + D
Ctrl Q + Ctrl D
End

I personally use only the second and third shortcut but maybe someone uses all three. Thanks again and keep up the good work!

Martin Friebe

2010-10-15 17:10

manager   ~0041838

confirmed as fixed by reporter.

Issue History

Date Modified Username Field Change
2010-10-15 10:33 Gerry K. New Issue
2010-10-15 12:57 Martin Friebe LazTarget => -
2010-10-15 12:57 Martin Friebe Note Added: 0041832
2010-10-15 12:57 Martin Friebe Status new => feedback
2010-10-15 12:57 Martin Friebe Relationship added duplicate of 0017152
2010-10-15 15:06 Gerry K. Note Added: 0041834
2010-10-15 17:08 Martin Friebe Status feedback => assigned
2010-10-15 17:08 Martin Friebe Assigned To => Martin Friebe
2010-10-15 17:10 Martin Friebe LazTarget - => 0.9.30
2010-10-15 17:10 Martin Friebe Status assigned => resolved
2010-10-15 17:10 Martin Friebe Fixed in Version => 0.9.29 (SVN)
2010-10-15 17:10 Martin Friebe Resolution open => no change required
2010-10-15 17:10 Martin Friebe Note Added: 0041838
2010-10-15 17:10 Martin Friebe Target Version => 0.9.30
2011-12-01 11:24 Marc Weustink Status resolved => closed