View Issue Details

IDProjectCategoryView StatusLast Update
0017674LazarusIDEpublic2011-12-01 11:26
ReporterJörgen HägglundAssigned ToVincent Snijders 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version0.9.29 (SVN)Product Build 
Target VersionFixed in Version0.9.29 (SVN) 
Summary0017674: Compiler dialog does not display the correct thousands separator on Windows
DescriptionWhen using the compiler dialog (my preferred setting), it shows line count with an invalid thousands separator.
Lines count shows as: 1?532, instead of the (for my locale) correct: 1 532
Additional InformationRunning Lazarus 64-bit on Windows Vista x64, Swedish language pack.
TagsNo tags attached.
Fixed in Revision27774
LazTarget-
Widgetset
Attached Files

Activities

Vincent Snijders

2010-10-20 14:45

manager   ~0041937

This patch fixes this issue, I don't know if it is the correct way:
Index: infobuild.pp
===================================================================
--- infobuild.pp (revision 27773)
+++ infobuild.pp (working copy)
@@ -232,7 +232,7 @@
     
     NL := StrTointDef(S,0);
     NLines := NLines + NL;
- LNLines.Caption := FormatFloat('#,##0',NLines);
+ LNLines.Caption := AnsiToUTF8(FormatFloat('#,##0',NLines));
     Ok := false;
   end;
   If Ok then PCurrentStatus.Caption := SStatus;

rusty_robot

2011-04-29 00:04

reporter   ~0047892

The problem is still topical in Linux (r30496).

Issue History

Date Modified Username Field Change
2010-10-20 13:17 Jörgen Hägglund New Issue
2010-10-20 14:45 Vincent Snijders Note Added: 0041937
2010-10-20 15:07 Vincent Snijders Fixed in Revision => 27774
2010-10-20 15:07 Vincent Snijders LazTarget => -
2010-10-20 15:07 Vincent Snijders Status new => resolved
2010-10-20 15:07 Vincent Snijders Fixed in Version => 0.9.29 (SVN)
2010-10-20 15:07 Vincent Snijders Resolution open => fixed
2010-10-20 15:07 Vincent Snijders Assigned To => Vincent Snijders
2011-04-29 00:04 rusty_robot Note Added: 0047892
2011-12-01 11:26 Marc Weustink Status resolved => closed