View Issue Details

IDProjectCategoryView StatusLast Update
0017774LazarusWidgetsetpublic2010-11-24 16:22
ReporterMartin Friebe Assigned ToPaul Ishenin  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version0.9.29 (SVN) 
Target Version0.9.30Fixed in Version0.9.29 (SVN) 
Summary0017774: Regression: GTK2 reports wrong Monitor for windows
DescriptionGtk2 now seems to always report the primary monitor, even if the window is on the secondary.

this uesed to work in rev 27829

see issue 0017771
TagsNo tags attached.
Fixed in Revision28458
LazTarget0.9.30
WidgetsetGTK 2
Attached Files

Relationships

related to 0017771 closedMartin Friebe Solution in 0016835 is incomplete 
related to 0017906 closedZeljan Rikalo QT: wrong Monitor returned for pos [QT (w32) Rangecheck error on hint] 

Activities

Martin Friebe

2010-10-31 19:09

manager   ~0042503

once fixed, please also remove the following IFDEF
in
components\synedit\syncompletion.pas line 1210...

procedure TSynBaseCompletion.Execute(s: string; TokenRect: TRect);
....
begin
  {$IFnDEF LCLGTK2}
  Mon := Screen.MonitorFromPoint(TokenRect.TopLeft);
  if Mon <> nil then
    TokenRect.Left := Min(TokenRect.Left, Mon.Left + Mon.Width - Form.Width);
  {$ENDIF}

Henry Vermaak

2010-11-01 12:53

reporter   ~0042549

That ifndef breaks the code in that procedure, since you don't create mon for gtk2, but you still use it after the ifndef.

Zeljan Rikalo

2010-11-01 16:14

developer   ~0042558

hm..I don't see any changes against monitors in gtk2winapi, so wondering what can cause such regression ? More over, qt code is almost identical to gtk2 one.

Paul Ishenin

2010-11-24 15:42

manager   ~0043473

Please test and close if ok.

Martin Friebe

2010-11-24 16:22

manager   ~0043480

thanks, works

Issue History

Date Modified Username Field Change
2010-10-31 14:29 Martin Friebe New Issue
2010-10-31 14:29 Martin Friebe LazTarget => -
2010-10-31 14:29 Martin Friebe Widgetset => GTK 2
2010-10-31 14:30 Martin Friebe LazTarget - => 0.9.30
2010-10-31 14:30 Martin Friebe Build => 28009
2010-10-31 14:30 Martin Friebe Relationship added related to 0017771
2010-10-31 14:32 Vincent Snijders Status new => acknowledged
2010-10-31 14:32 Vincent Snijders Target Version => 0.9.30
2010-10-31 19:09 Martin Friebe Note Added: 0042503
2010-11-01 12:53 Henry Vermaak Note Added: 0042549
2010-11-01 16:14 Zeljan Rikalo Note Added: 0042558
2010-11-19 18:41 Martin Friebe Relationship added related to 0017906
2010-11-24 15:42 Paul Ishenin Fixed in Revision => 28458
2010-11-24 15:42 Paul Ishenin Status acknowledged => resolved
2010-11-24 15:42 Paul Ishenin Fixed in Version => 0.9.29 (SVN)
2010-11-24 15:42 Paul Ishenin Resolution open => fixed
2010-11-24 15:42 Paul Ishenin Assigned To => Paul Ishenin
2010-11-24 15:42 Paul Ishenin Note Added: 0043473
2010-11-24 16:22 Martin Friebe Status resolved => closed
2010-11-24 16:22 Martin Friebe Note Added: 0043480