View Issue Details

IDProjectCategoryView StatusLast Update
0017814PackagesTAChartpublic2010-12-10 13:39
Reporterraypro Assigned ToVincent Snijders  
PrioritynormalSeveritycrashReproducibilityalways
Status closedResolutionfixed 
Product Version0.9.28 
Target Version0.9.30Fixed in Version0.9.29 (SVN) 
Summary0017814: Using TAChart component in form causes mistakes in *.lfm file (Win64 only)
DescriptionUsing the TAChart component in a form will produce mistakes in *.lfm file of that form when saving the form unit. After re-opening the project file / unit the TAChart and all components included after that are not restored. An inspection of *.lfm file shows that they are not svaed into.

This behaviour is only under Win64 (Vista, W7) not under Win32. A relation to special GUI appearance (Aero) is assumed but cannot be confirmed.
TagsNo tags attached.
Fixed in Revision28428
LazTarget0.9.30
WidgetsetWin32/Win64
Attached Files

Relationships

related to 0016252 closedVincent Snijders Lazarus Foating point type error under win64 when reading/writing property file (was:Silently failing to record property in lfm) 

Activities

Vincent Snijders

2010-11-03 16:47

manager   ~0042726

Are any float properties of type extended streamed?

Alexander S. Klenin

2010-11-03 22:33

developer   ~0042737

No, but there are properties of type Double

raypro

2010-11-07 19:48

reporter   ~0042859

Just discovered: There is an alternative behaviour. Instead of ignoring TAChart in saving, the following box appears:

"Kann binären Komponentenstream von >FormVariable< von TFormVariable nicht in Text umwandeln. Division by zero"

in English:

"Could not transform binary component stream into text. Division by zero"

Any helpful?

Alexander S. Klenin

2010-11-08 09:44

developer   ~0042879

Can you get a stack trace?

raypro

2010-11-14 16:38

reporter   ~0043036

Sorry, don't know how (can you tell me?). But I discovered that this behaviour is also linked to other components using direct canvas methods (e.g. GLScene). I got them to work by disabling the manifest themes under Project Options. Maybe this is the reason for it since lazarus is compiled with the "Using manifest themes" options?

Alexander S. Klenin

2010-11-19 14:57

developer   ~0043258

http://wiki.lazarus.freepascal.org/Lazarus_Faq#How_can_I_see_debug_output.3F

Vincent Snijders

2010-11-19 18:31

manager   ~0043268

I think I know where I can fix this issue.

Vincent Snijders

2010-11-23 09:55

manager   ~0043402

Please, test and close if ok.

Issue History

Date Modified Username Field Change
2010-11-03 14:37 raypro New Issue
2010-11-03 14:37 raypro Status new => assigned
2010-11-03 14:37 raypro Assigned To => Alexander S. Klenin
2010-11-03 14:37 raypro Widgetset => Win32/Win64
2010-11-03 16:47 Vincent Snijders Note Added: 0042726
2010-11-03 22:33 Alexander S. Klenin Note Added: 0042737
2010-11-07 19:48 raypro Note Added: 0042859
2010-11-08 09:44 Alexander S. Klenin Note Added: 0042879
2010-11-14 16:38 raypro Note Added: 0043036
2010-11-19 14:57 Alexander S. Klenin Note Added: 0043258
2010-11-19 18:26 Vincent Snijders Assigned To Alexander S. Klenin => Vincent Snijders
2010-11-19 18:30 Vincent Snijders LazTarget => 0.9.30
2010-11-19 18:30 Vincent Snijders Target Version => 0.9.30
2010-11-19 18:31 Vincent Snijders Note Added: 0043268
2010-11-23 09:54 Vincent Snijders Relationship added related to 0016252
2010-11-23 09:55 Vincent Snijders Fixed in Revision => 28428
2010-11-23 09:55 Vincent Snijders Status assigned => resolved
2010-11-23 09:55 Vincent Snijders Fixed in Version => 0.9.29 (SVN)
2010-11-23 09:55 Vincent Snijders Resolution open => fixed
2010-11-23 09:55 Vincent Snijders Note Added: 0043402
2010-12-10 13:39 raypro Status resolved => closed