View Issue Details

IDProjectCategoryView StatusLast Update
0017826LazarusIDEpublic2010-12-18 22:00
ReporterSven BarthAssigned ToPaul Ishenin 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Platformi376OSWin32OS VersionNT 6.1 (7)
Product Version0.9.29 (SVN)Product Build27815 
Target Version0.9.30Fixed in Version0.9.29 (SVN) 
Summary0017826: Multiline tabs in search results windows aren't displayed correctly
DescriptionI'm often searching for many identifiers when I work in Lazarus and forget to close them. Thus it often happens that I've multiline tabs in the search results window.

This wasn't a problem in 0.9.28(.2), but with 0.9.29 I have the problem that one of the non visible pages is displayed above the second, third, etc. tab row. The selected page is displayed correctly below all the tabs and the part that is visible of the second tab row works correctly (I can select other tabs there).
Steps To ReproduceSearch for some identifiers in files (they don't even have to return something, but it's visible more clearly if some have results :) ). Then you might resize the window so that the tabs are forced to be displayed in multiple lines (it works without resizing as well, but you need to search more :P ).
Additional InformationAttached screenshot shows the problem.

It happens with and without enabled Aero.
TagsNo tags attached.
Fixed in Revision28677
LazTarget0.9.30
WidgetsetWin32/Win64
Attached Files

Relationships

duplicate of 0016526 closedFelipe Monteiro de Carvalho Regression: TNotebook paint incorrect 
related to 0017007 closedVincent Snijders Multiline TabView is not repainted on Resize 

Activities

2010-11-04 09:43

 

search-window.png (22,579 bytes)
search-window.png (22,579 bytes)

Paul Ishenin

2010-12-03 07:55

manager   ~0043912

This sometimes happens with the source editor. Looks like other pages are visible too together with the active page.

2010-12-08 15:32

 

17826.zip (2,632 bytes)

Vincent Snijders

2010-12-08 15:34

manager   ~0044099

Attached is an LCL application to reproduce this issue.

Run the application, add 2 pages, make the width smaller so that two lines of thabs are needed. The lower line of tabs is not visible.

Paul Ishenin

2010-12-11 07:25

manager   ~0044164

Please test and close if ok.

Sven Barth

2010-12-18 22:00

manager   ~0044360

Works now, thank you.

Regards,
Sven

Issue History

Date Modified Username Field Change
2010-11-04 09:43 Sven Barth New Issue
2010-11-04 09:43 Sven Barth File Added: search-window.png
2010-11-04 09:43 Sven Barth Widgetset => Win32/Win64
2010-11-04 16:46 Vincent Snijders Relationship added duplicate of 0016526
2010-11-16 10:39 Vincent Snijders LazTarget => 1.0
2010-11-16 10:39 Vincent Snijders Status new => acknowledged
2010-11-16 10:39 Vincent Snijders Target Version => 1.0.0
2010-11-25 10:54 Vincent Snijders LazTarget 1.0 => 0.9.30
2010-11-25 10:54 Vincent Snijders Target Version 1.0.0 => 0.9.30
2010-12-03 07:54 Paul Ishenin Relationship added related to 0017007
2010-12-03 07:55 Paul Ishenin Note Added: 0043912
2010-12-08 15:32 Vincent Snijders File Added: 17826.zip
2010-12-08 15:34 Vincent Snijders Note Added: 0044099
2010-12-11 07:25 Paul Ishenin Fixed in Revision => 28677
2010-12-11 07:25 Paul Ishenin Status acknowledged => resolved
2010-12-11 07:25 Paul Ishenin Fixed in Version => 0.9.29 (SVN)
2010-12-11 07:25 Paul Ishenin Resolution open => fixed
2010-12-11 07:25 Paul Ishenin Assigned To => Paul Ishenin
2010-12-11 07:25 Paul Ishenin Note Added: 0044164
2010-12-18 22:00 Sven Barth Status resolved => closed
2010-12-18 22:00 Sven Barth Note Added: 0044360