View Issue Details

IDProjectCategoryView StatusLast Update
0017850LazarusIDEpublic2016-03-14 23:30
ReporterPhilAssigned ToJuha Manninen 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformMacOS10.6OS Version10.6
Product Version0.9.29 (SVN)Product Build28107 
Target VersionFixed in Version0.9.29 (SVN) 
Summary0017850: Inconsistent position and location of buttons in IDE dialogs with Carbon
DescriptionSome dialogs in IDE appear to position buttons properly per Mac convention - e.g., in File | New, Cancel is left of OK. But many others are not positioned like that - e.g., in Search | Find, Cancel is right of Find button.

Also, many buttons are chopped off at the bottom or right, where they apparently collide with the form frame.

TagsNo tags attached.
Fixed in Revision28335
LazTarget-
WidgetsetCarbon
Attached Files

Relationships

related to 0017791 closedMattias Gaertner Incorrect show button in Edit Build Lazarus Prifiles 

Activities

Paul Ishenin

2010-11-19 05:29

manager   ~0043218

Duplicate. Fixed. Please test and close if ok.

Phil

2010-11-24 02:24

reporter   ~0043450

Search | Find and Tools | Configure still have Cancel at far right.

Vincent Snijders

2010-11-24 08:36

manager   ~0043455

Reopened because of position of Cancel button.

Juha Manninen

2016-03-14 23:30

developer   ~0091047

Fixed in the meantime.

Issue History

Date Modified Username Field Change
2010-11-07 00:54 Phil New Issue
2010-11-07 00:54 Phil Widgetset => Carbon
2010-11-16 11:32 Vincent Snijders LazTarget => 0.9.30
2010-11-16 11:32 Vincent Snijders Status new => acknowledged
2010-11-16 11:32 Vincent Snijders Target Version => 0.9.30
2010-11-16 11:34 Vincent Snijders Relationship added related to 0017791
2010-11-19 05:29 Paul Ishenin Fixed in Revision => 28335
2010-11-19 05:29 Paul Ishenin Status acknowledged => resolved
2010-11-19 05:29 Paul Ishenin Fixed in Version => 0.9.29 (SVN)
2010-11-19 05:29 Paul Ishenin Resolution open => fixed
2010-11-19 05:29 Paul Ishenin Assigned To => Paul Ishenin
2010-11-19 05:29 Paul Ishenin Note Added: 0043218
2010-11-24 02:24 Phil Note Added: 0043450
2010-11-24 08:36 Vincent Snijders LazTarget 0.9.30 => -
2010-11-24 08:36 Vincent Snijders Assigned To Paul Ishenin =>
2010-11-24 08:36 Vincent Snijders Status resolved => assigned
2010-11-24 08:36 Vincent Snijders Resolution fixed => reopened
2010-11-24 08:36 Vincent Snijders Note Added: 0043455
2010-11-24 08:36 Vincent Snijders Target Version 0.9.30 =>
2010-11-24 08:36 Vincent Snijders Status assigned => acknowledged
2016-03-14 23:30 Juha Manninen Note Added: 0091047
2016-03-14 23:30 Juha Manninen Status acknowledged => resolved
2016-03-14 23:30 Juha Manninen Resolution reopened => fixed
2016-03-14 23:30 Juha Manninen Assigned To => Juha Manninen