View Issue Details

IDProjectCategoryView StatusLast Update
0017854LazarusIDEpublic2011-10-08 19:06
ReporterPhil Assigned ToVincent Snijders  
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionnot fixable 
PlatformMacOSOS X 
Product Version0.9.29 (SVN) 
Target Version1.0.0 
Summary0017854: IDE won't let me manage resources myself
DescriptionLazarus wants to rule the program file and strips out resources it doesn't like.

See attached project.

Note that no manifest or icon is selected in this project, so IDE won't be creating a .res/.ico. Yet it just deletes my {$R} when it saves the project.

TagsNo tags attached.
Fixed in Revision
LazTarget1.0
Widgetset
Attached Files

Activities

2010-11-07 01:41

 

TestLazSave.zip (2,009 bytes)

Paul Ishenin

2010-11-19 05:38

manager   ~0043219

Thats because you want to have a resource which has the same name as project. If you add {$R my_unique_resource_name.res} it will not remove it.

How you suggest to distinct IDE created resources and manualy created resource?

Phil

2010-11-24 02:26

reporter   ~0043451

Delphi has no trouble with that.

Vincent Snijders

2010-11-24 07:38

manager   ~0043452

Since it is not clear how it can be implemented, I think it is best to postpone this issue.

Paul Ishenin

2010-11-24 11:17

manager   ~0043465

I think so too.

Vincent Snijders

2010-12-27 12:33

manager   ~0044626

If we cannot figure out a way to distinct IDE created resources and manually created resources, we should close this as "not fixable". Phil, do you have an idea?

Issue History

Date Modified Username Field Change
2010-11-07 01:41 Phil New Issue
2010-11-07 01:41 Phil File Added: TestLazSave.zip
2010-11-07 01:41 Phil Widgetset => Carbon
2010-11-16 12:31 Vincent Snijders LazTarget => 0.9.30
2010-11-16 12:31 Vincent Snijders Status new => acknowledged
2010-11-16 12:31 Vincent Snijders Target Version => 0.9.30
2010-11-19 05:38 Paul Ishenin Note Added: 0043219
2010-11-19 05:38 Paul Ishenin Status acknowledged => feedback
2010-11-24 02:26 Phil Note Added: 0043451
2010-11-24 07:38 Vincent Snijders Note Added: 0043452
2010-11-24 11:17 Paul Ishenin LazTarget 0.9.30 => 1.0
2010-11-24 11:17 Paul Ishenin Widgetset Carbon =>
2010-11-24 11:17 Paul Ishenin Note Added: 0043465
2010-11-24 11:17 Paul Ishenin Target Version 0.9.30 => 1.0.0
2010-12-27 12:33 Vincent Snijders Note Added: 0044626
2011-10-08 19:06 Vincent Snijders Status feedback => resolved
2011-10-08 19:06 Vincent Snijders Resolution open => not fixable
2011-10-08 19:06 Vincent Snijders Assigned To => Vincent Snijders