View Issue Details

IDProjectCategoryView StatusLast Update
0017859LazarusIDEpublic2017-01-15 19:23
ReporterPhil Assigned ToMattias Gaertner  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformMacOSOS X 
Product Version0.9.29 (SVN) 
Summary0017859: Not enough vertical space for items on Verbosity tab
DescriptionItems like Show Hints for unused units... that require two lines are chopped off on top and bottom on Verbosity tab.

Same issue with Code generation and Verbosity tabs in Compiler Options dialog accessible from Package dialog.

Also, I only see Install under More menu in Package dialog rather than next to Compile.
TagsNo tags attached.
Fixed in Revision
LazTarget-
WidgetsetCarbon
Attached Files

Relationships

duplicate of 0018611 closedMattias Gaertner Project Options - Verbosity: Labels of checkboxes not displayed correctly 

Activities

Maxim Ganetsky

2010-11-08 00:09

developer   ~0042872

Screenshots, please?

Zeljan Rikalo

2011-07-03 15:44

developer   ~0049612

@Maxim, no need for screenshoots, this is valid issue. Seem that under mac we must forbid two lined checkbox/radioboxes, or there's something wrong with height calculation of such controls.

Zeljan Rikalo

2011-07-04 14:50

developer   ~0049649

I'm not sure that this is easy fixable under 10.4, but for 10.5 (I have 10.4.11 only), someone can test this in
CarbonButtons.pas, TCarbonCheckBox.CreateWidget, after Widget := Control
add line:
HIViewSetTextTruncation(Control, kHIViewEntireView, kHIThemeTextTruncationEnd);

if it does not work, probably another HIViewPartCode should be setted instead of kHIViewEntireView ... but haven't mac 10.5 so cannot play with it.

CudaText man

2017-01-15 18:23

reporter   ~0097499

Fixed already, dupl of some today closed issue

Issue History

Date Modified Username Field Change
2010-11-07 03:10 Phil New Issue
2010-11-07 03:10 Phil Widgetset => Carbon
2010-11-08 00:09 Maxim Ganetsky Note Added: 0042872
2010-11-16 12:38 Vincent Snijders LazTarget => 1.0
2010-11-16 12:38 Vincent Snijders Status new => acknowledged
2010-11-16 12:38 Vincent Snijders Target Version => 1.0.0
2011-07-03 15:44 Zeljan Rikalo Note Added: 0049612
2011-07-04 14:50 Zeljan Rikalo Note Added: 0049649
2011-10-10 12:24 Vincent Snijders LazTarget 1.0 => 1.2
2011-10-10 12:24 Vincent Snijders Target Version 1.0.0 => 1.2.0
2014-01-14 15:10 Martin Friebe LazTarget 1.2 => 1.4
2014-01-14 15:12 Martin Friebe Target Version 1.2.0 => 1.4
2014-09-10 12:16 Juha Manninen LazTarget 1.4 => -
2014-09-10 12:16 Juha Manninen Target Version 1.4 =>
2014-09-20 16:49 Juha Manninen Relationship added related to 0018611
2017-01-15 18:23 CudaText man Note Added: 0097499
2017-01-15 19:23 Bart Broersma Relationship replaced duplicate of 0018611
2017-01-15 19:23 Bart Broersma Status acknowledged => resolved
2017-01-15 19:23 Bart Broersma Resolution open => fixed
2017-01-15 19:23 Bart Broersma Assigned To => Mattias Gaertner