View Issue Details

IDProjectCategoryView StatusLast Update
0017896LazarusConverterpublic2010-11-19 02:38
ReporterChristian Budde Assigned ToJuha Manninen  
PrioritynormalSeverityfeatureReproducibilityalways
Status closedResolutionno change required 
Product Version0.9.28.3 (SVN) 
Summary0017896: Special handling for libraries
DescriptionI'm mass-converting several libraries and I am constantly facing one problem, that shouldn't be there IMHO.

In case of a library an icon is added to the project, which is not needed (e.g. never displayed in any of the platforms I checked).
TagsNo tags attached.
Fixed in Revision
LazTarget-
WidgetsetWin32/Win64
Attached Files

Relationships

related to 0017965 closedPaul Ishenin Patches Hide task bar handler for libraries 
related to 0017974 closedJuha Manninen Lazarus Lazarus lets you run a library 

Activities

Juha Manninen

2010-11-16 22:25

developer   ~0043115

Can you please explain "In case of a library an icon is added to the project". Which project? You are converting a library, right?

Christian Budde

2010-11-17 16:42

reporter   ~0043146

Yes, I'm converting dozens of libraries (*.dll in Windows). Each of these are plugins and thus have only little todo with each other.

I noticed that such libraries are not well supported by Lazarus. In fact these are rather treated as executables (which they are more or less). Thus using the libraries as plugins (with LCL forms) will create a task bar handler containing an icon.

IMO an icon for a library does not make sense nor will does it make sense to show the task bar handler, but that's another story.

Juha Manninen

2010-11-17 21:34

developer   ~0043152

Last edited: 2010-11-17 21:34

Ok, it looks like this is not a converter bug but applies to any such library made with Lazarus. Can you please verify it by creating a new test package (instead of converting an existing package). Then we can classify this issue better.

When do you see the icon on taskbar? Is it always when calling the lib from you program?

I made a test library project and clicked "Run". Lazarus really tried to run it which is a bug for sure. Then:
"Ooops, the debugger entered the error state..."

Christian Budde

2010-11-18 01:23

reporter   ~0043161

I also found out once that it is possible to run a library which might indeed be a bug.

In regards of this problem I also created another bug report with the ID 17965, which you might want to check. It also presents a patch to omit the use of icons for a library. In general this needs to be discussed whether libraries do need an icon at all (and on all platforms), but IMHO they do not and I can't imagine a reason for this right now.

So maybe this is the wrong report (or simply the wrong time to report this issue, but it was the first I ran into).

Juha Manninen

2010-11-18 10:24

developer   ~0043172

I created a new issue 0017974 about running a library.
Your 0017965 covers the icon issue.
Is there anything left that relates to converter? If not, I will close this issue.

Christian Budde

2010-11-18 13:17

reporter   ~0043180

There are some issues left, but they do not belong in this bug report. I will create some new bug reports for each and every issue I found.

Juha Manninen

2010-11-18 13:50

developer   ~0043182

Thanks.
The problems were not related to converter and are reported as separate issues.

Christian Budde

2010-11-19 02:38

reporter   ~0043211

One of these other issue I mentioned is reported under the ID 17982.

Furthermore, I am getting sporadic problems converting some of the dfm files, but these problems are not reproducable.

Issue History

Date Modified Username Field Change
2010-11-10 12:56 Christian Budde New Issue
2010-11-10 12:56 Christian Budde Widgetset => Win32/Win64
2010-11-16 12:44 Vincent Snijders LazTarget => -
2010-11-16 12:44 Vincent Snijders Assigned To => Juha Manninen
2010-11-16 12:44 Vincent Snijders Status new => assigned
2010-11-16 22:25 Juha Manninen Note Added: 0043115
2010-11-16 22:25 Juha Manninen Status assigned => feedback
2010-11-17 16:42 Christian Budde Note Added: 0043146
2010-11-17 21:34 Juha Manninen Note Added: 0043152
2010-11-17 21:34 Juha Manninen Note Edited: 0043152
2010-11-18 01:23 Christian Budde Note Added: 0043161
2010-11-18 10:07 Juha Manninen Relationship added related to 0017965
2010-11-18 10:17 Juha Manninen Relationship added related to 0017974
2010-11-18 10:24 Juha Manninen Note Added: 0043172
2010-11-18 13:17 Christian Budde Note Added: 0043180
2010-11-18 13:50 Juha Manninen Status feedback => resolved
2010-11-18 13:50 Juha Manninen Resolution open => no change required
2010-11-18 13:50 Juha Manninen Note Added: 0043182
2010-11-19 02:38 Christian Budde Status resolved => closed
2010-11-19 02:38 Christian Budde Note Added: 0043211