View Issue Details

IDProjectCategoryView StatusLast Update
0017908LazarusIDEpublic2019-04-22 19:33
ReporterMartin Friebe Assigned ToJuha Manninen  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version0.9.29 (SVN) 
Summary0017908: WindowSate not saved for object inspector / messages
DescriptionThe IDE remembers if a window was opened or closed and restores this, if restarted.

At least this is true for windows that are closed by default 9like debug windows, additional source editors, ...)

It does not do so for windows that are open by default. Like object inspector and msg-view

The setting for object-inspector in my case is: "Restore Window geometry"

IMHO the IDE should remember if they were closed.
TagsNo tags attached.
Fixed in RevisionMany, including r51105
LazTarget-
WidgetsetWin32/Win64
Attached Files

Relationships

related to 0018538 closedJuha Manninen Under certain configurations docked windows, lower window arbitrarily increasing its height 
related to 0029477 resolvedJuha Manninen OI and messages window missing after starting IDE 

Activities

Zeljan Rikalo

2012-02-04 13:32

developer   ~0056397

Not blocker, postponed.

Juha Manninen

2014-09-10 12:13

developer   ~0077036

OI state is now remembered but messages window state is not.

Juha Manninen

2015-12-29 17:32

developer   ~0088405

Last edited: 2015-12-29 22:59

View 2 revisions

The messages window is treated as a special case layout-wise but it should not.
The related issue is somehow caused by this special treatment.

[Edit] Actually messages window state is now remembered, too, after r51081.

Juha Manninen

2016-01-04 22:54

developer   ~0088629

Works now, please test.

Issue History

Date Modified Username Field Change
2010-11-11 22:19 Martin Friebe New Issue
2010-11-11 22:19 Martin Friebe LazTarget => -
2010-11-11 22:19 Martin Friebe Widgetset => Win32/Win64
2010-11-16 12:47 Vincent Snijders LazTarget - => 1.0
2010-11-16 12:47 Vincent Snijders Status new => acknowledged
2010-11-16 12:47 Vincent Snijders Target Version => 1.0.0
2012-02-04 13:32 Zeljan Rikalo LazTarget 1.0 => 1.2
2012-02-04 13:32 Zeljan Rikalo Note Added: 0056397
2012-03-13 07:50 Vincent Snijders Target Version 1.0.0 => 1.2.0
2014-01-14 15:10 Martin Friebe LazTarget 1.2 => 1.4
2014-01-14 15:12 Martin Friebe Target Version 1.2.0 => 1.4
2014-09-10 12:13 Juha Manninen Note Added: 0077036
2015-04-27 21:59 Juha Manninen LazTarget 1.4 => -
2015-04-27 22:02 Juha Manninen Target Version 1.4 =>
2015-12-17 17:48 Juha Manninen Assigned To => Juha Manninen
2015-12-17 17:48 Juha Manninen Status acknowledged => assigned
2015-12-29 17:30 Juha Manninen Relationship added related to 0018538
2015-12-29 17:32 Juha Manninen Note Added: 0088405
2015-12-29 22:59 Juha Manninen Note Edited: 0088405 View Revisions
2016-01-04 22:54 Juha Manninen Fixed in Revision => Many, including r51105
2016-01-04 22:54 Juha Manninen Note Added: 0088629
2016-01-04 22:54 Juha Manninen Status assigned => resolved
2016-01-04 22:54 Juha Manninen Resolution open => fixed
2016-01-22 21:41 Juha Manninen Relationship added related to 0029477
2019-04-22 19:33 Martin Friebe Status resolved => closed