View Issue Details

IDProjectCategoryView StatusLast Update
0017939LazarusIDEpublic2010-11-15 13:46
ReporterZoran VučenovićAssigned ToMartin Friebe 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version0.9.29 (SVN)Product Build 
Target VersionFixed in Version0.9.29 (SVN) 
Summary0017939: Lazarus 0.9.29 does not compile with FPC 2.4.2 since rev. 28238
Descriptionwith new stable fpc 2.4.2 Lazarus from trunk compiled well up to rev. 28237. Since 28238 it does not.
Additional InformationThis is the revision that brakes the compilation with fpc 2.4.2 --
martin
debugger: disassembler, Allow copy to clipboard
http://svn.freepascal.org/cgi-bin/viewvc.cgi?view=rev&root=lazarus&sortby=date&revision=28238

These are the last lines of the output (from "make clean all"):

...
Compiling D:\lazarus\debugger\assemblerdlg.pp
assemblerdlg.pp(159,54) Error: Identifier not found "lisDbgAsmCopyToClipboard"
assemblerdlg.pp(735) Fatal: There were 1 errors compiling module, stopping
Fatal: Compilation aborted
make[2]: *** [lazarus.exe] Error 1
make[2]: Leaving directory `D:/lazarus/ide'
make[1]: *** [ide] Error 2
make[1]: Leaving directory `D:/lazarus/ide'
make: *** [ide] Error 2
TagsNo tags attached.
Fixed in Revision28242
LazTarget-
WidgetsetWin32/Win64
Attached Files

Activities

Vincent Snijders

2010-11-15 11:50

manager   ~0043063

Already fixed.

Zoran Vučenović

2010-11-15 12:10

developer   ~0043064

The IDE still does not compile. Now I get:

D:\lazarus\lcl\interfaces\win32\win32wsdialogs.pp(867,15) Error: Incompatible type for arg no. 2: Got "IFileDialog", expected "TObject"

Zoran Vučenović

2010-11-15 12:15

developer   ~0043065

The file win32wsdialogs.pp is changed in rev. 28239, so another problem seems to be there.

Vincent Snijders

2010-11-15 12:34

manager   ~0043066

Please, open new issue for another problem, which needs another fix.

Zoran Vučenović

2010-11-15 13:33

developer   ~0043069

Okay, here it is: http://bugs.freepascal.org/view.php?id=17941

Issue History

Date Modified Username Field Change
2010-11-15 11:36 Zoran Vučenović New Issue
2010-11-15 11:36 Zoran Vučenović Widgetset => Win32/Win64
2010-11-15 11:50 Vincent Snijders Fixed in Revision => 28242
2010-11-15 11:50 Vincent Snijders LazTarget => -
2010-11-15 11:50 Vincent Snijders Status new => resolved
2010-11-15 11:50 Vincent Snijders Fixed in Version => 0.9.29 (SVN)
2010-11-15 11:50 Vincent Snijders Resolution open => fixed
2010-11-15 11:50 Vincent Snijders Assigned To => Vincent Snijders
2010-11-15 11:50 Vincent Snijders Note Added: 0043063
2010-11-15 11:50 Martin Friebe Status resolved => assigned
2010-11-15 11:50 Martin Friebe Assigned To Vincent Snijders => Martin Friebe
2010-11-15 11:55 Martin Friebe Status assigned => resolved
2010-11-15 12:10 Zoran Vučenović Note Added: 0043064
2010-11-15 12:15 Zoran Vučenović Note Added: 0043065
2010-11-15 12:34 Vincent Snijders Note Added: 0043066
2010-11-15 13:33 Zoran Vučenović Note Added: 0043069
2010-11-15 13:46 Zoran Vučenović Status resolved => closed