View Issue Details

IDProjectCategoryView StatusLast Update
0017942LazarusLCLpublic2015-07-10 09:51
ReporterKim PedersenAssigned ToBart Broersma 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionunable to reproduce 
Product Version0.9.29 (SVN)Product Build 
Target Version1.4Fixed in Version1.4.2 
Summary0017942: TMaskEdit selection
DescriptionPut a TEdit and a TMaskEdit (EditMask = '99\-99\-9999;1;_') on a form. Set the Form1.ActiveControl property to Edit1. When the form is showing the first character/field in MaskEdit1 is selected and afterwards unselected. It happens very quickly but it catches my eye, especially when having a lot of TMaskEdit on the form.
How can this be? It would be nice if the character wasn't selected at all.

Thanks.
TagsNo tags attached.
Fixed in Revision49301
LazTarget1.4
WidgetsetGTK 2, QT
Attached Files

Relationships

related to 0024311 resolvedBart Broersma Cannot set text selection in TDateEdit if DateOrder is anything other than doNone 

Activities

Zeljan Rikalo

2010-11-15 16:31

developer   ~0043075

I don't think that this is qt only problem. Maybe U use oxygen theme which have paint animations so it's visible.

Kim Pedersen

2010-11-16 09:40

reporter   ~0043083

I'm using XFCE 4 and the theme is Wallis. There are no animations.
But you're right; it's not only a qt problem. The problem also exist with GTK2. It looks like the first character is selected with the mouse and afterwards unselected. Aren't you able to reproduce?

Zeljan Rikalo

2010-11-16 11:08

developer   ~0043085

No I cannot reproduce (but haven't tried under xfce yet).

Bart Broersma

2010-11-18 15:52

developer   ~0043189

> It looks like the first character is selected with the mouse ...

@Kim: This is what happens in the DoEnter procedure of TMaskEdit.
Can you seen OnEnter events being fired?

Kim Pedersen

2010-11-26 14:51

reporter   ~0043562

No, the OnEnter event is not fired. I'm unable to reproduce in GTK2.

Bart Broersma

2010-12-26 00:04

developer   ~0044590

Last edited: 2010-12-26 00:27

I cannot reproduce on GTK2 (using KDE, JWM or IceWM as windowmanager)(I have 36 TMaskEdits on 1 form, 1 TEdit which is ActiveControl, and my computer is rather slow, so I should be able to see the flickering).

Zeljan Rikalo

2012-02-04 13:33

developer   ~0056398

Not blocker, postponed.

Zeljan Rikalo

2012-05-26 21:31

developer   ~0059981

I've removed relation to 0022079 since this problem have nothing with it.

Bart Broersma

2013-11-01 20:05

developer   ~0071082

Not a showstopper, postponed.

Bart Broersma

2013-11-01 20:06

developer   ~0071083

B.t.w. I don't quite see the relation to 0024311.

Bart Broersma

2014-01-07 12:52

developer   ~0072279

Is this issue still active?

Bart Broersma

2014-05-01 14:42

developer   ~0074713

No feedback within a reasonable time.
Please re-open if you can reproduce the item with current trunk.

Zeljan Rikalo

2015-06-09 10:22

developer   ~0084321

Issue still exists.

Zeljan Rikalo

2015-06-09 10:23

developer   ~0084322

Now it does not show selection if TCustomMaskEdit isn't focused. Pls, close if ok.
@Bart, this should be merged to 1.4.2 ?

Issue History

Date Modified Username Field Change
2010-11-15 16:27 Kim Pedersen New Issue
2010-11-15 16:27 Kim Pedersen Widgetset => QT
2010-11-15 16:31 Zeljan Rikalo Note Added: 0043075
2010-11-16 09:40 Kim Pedersen Note Added: 0043083
2010-11-16 11:07 Zeljan Rikalo LazTarget => -
2010-11-16 11:07 Zeljan Rikalo Widgetset QT => GTK 2, QT
2010-11-16 11:08 Zeljan Rikalo Note Added: 0043085
2010-11-16 12:57 Vincent Snijders LazTarget - => 1.0
2010-11-16 12:57 Vincent Snijders Status new => acknowledged
2010-11-16 12:57 Vincent Snijders Target Version => 1.0.0
2010-11-18 15:52 Bart Broersma Note Added: 0043189
2010-11-26 14:51 Kim Pedersen Note Added: 0043562
2010-12-26 00:04 Bart Broersma Note Added: 0044590
2010-12-26 00:27 Bart Broersma Note Edited: 0044590
2012-02-04 13:33 Zeljan Rikalo LazTarget 1.0 => 1.2
2012-02-04 13:33 Zeljan Rikalo Note Added: 0056398
2012-03-13 07:50 Vincent Snijders Target Version 1.0.0 => 1.2.0
2012-05-19 15:45 Juha Manninen Relationship added related to 0022079
2012-05-26 21:30 Zeljan Rikalo Relationship deleted related to 0022079
2012-05-26 21:31 Zeljan Rikalo Note Added: 0059981
2013-04-27 15:26 Zeljan Rikalo Relationship added related to 0024311
2013-11-01 20:05 Bart Broersma LazTarget 1.2 => 1.4
2013-11-01 20:05 Bart Broersma Note Added: 0071082
2013-11-01 20:05 Bart Broersma Target Version 1.2.0 => 1.4
2013-11-01 20:06 Bart Broersma Note Added: 0071083
2014-01-07 12:52 Bart Broersma Note Added: 0072279
2014-01-07 12:52 Bart Broersma Status acknowledged => feedback
2014-05-01 14:42 Bart Broersma Note Added: 0074713
2014-05-01 14:42 Bart Broersma Status feedback => resolved
2014-05-01 14:42 Bart Broersma Resolution open => unable to reproduce
2014-05-01 14:42 Bart Broersma Assigned To => Bart Broersma
2015-06-09 10:22 Zeljan Rikalo Note Added: 0084321
2015-06-09 10:22 Zeljan Rikalo Status resolved => feedback
2015-06-09 10:23 Zeljan Rikalo Fixed in Revision => 49301
2015-06-09 10:23 Zeljan Rikalo Note Added: 0084322
2015-06-09 10:23 Zeljan Rikalo Status feedback => resolved
2015-07-10 09:51 Zeljan Rikalo Fixed in Version => 1.4.2