View Issue Details

IDProjectCategoryView StatusLast Update
0017979FPCCompilerpublic2010-11-21 13:06
Reporterhinst Assigned ToJonas Maebe  
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionduplicate 
PlatformWin32OSWindows 
Product Version2.5.1 
Summary0017979: Compiling generics with overloaded methods fails
DescriptionCompiling generics with overloaded methods fails, compiler returns syntax error
like this:
C:\Users\hinst\Documents\programming\EPCL\exList.pas(173,14) Error: function header doesn't match the previous declaration "TGenericList.Add(const <undefined type>):LongInt;"
C:\Users\hinst\Documents\programming\EPCL\exList.pas(166,14) Hint: Found declaration: TGenericList.Add(const <undefined type>):LongInt;
Steps To ReproduceJust write a generic with overloaded method
TagsNo tags attached.
Fixed in Revision
FPCOldBugId
FPCTarget
Attached Files

Relationships

duplicate of 0017938 resolvedFlorian overloading doesn't works in generic declarations 

Activities

hinst

2010-11-18 17:39

reporter   ~0043192

Note: in previous versions of the FPC this worked properly.

Jonas Maebe

2010-11-18 18:06

manager   ~0043194

Last edited: 2010-11-18 18:08

Please provide a compilable example (an example that should compile) that demonstrates the problem.

impfp

2010-11-21 00:33

reporter   ~0043318

Last edited: 2010-11-21 00:36

This issue is present not only in 2.5.1 but in 2.4.2 also
(see: http://bugs.freepascal.org/view.php?id=17938 )
Compilable example - in the advanced view
The non-compilable (with the same error message) sample with an issue is attached as a file there.

Issue History

Date Modified Username Field Change
2010-11-18 17:37 hinst New Issue
2010-11-18 17:39 hinst Note Added: 0043192
2010-11-18 18:06 Jonas Maebe Note Added: 0043194
2010-11-18 18:06 Jonas Maebe Status new => feedback
2010-11-18 18:08 Jonas Maebe Note Edited: 0043194
2010-11-21 00:33 impfp Note Added: 0043318
2010-11-21 00:34 impfp Note Edited: 0043318
2010-11-21 00:36 impfp Note Edited: 0043318
2010-11-21 13:06 Jonas Maebe Relationship added duplicate of 0017938
2010-11-21 13:06 Jonas Maebe Duplicate ID 0 => 17938
2010-11-21 13:06 Jonas Maebe Status feedback => resolved
2010-11-21 13:06 Jonas Maebe Resolution open => duplicate
2010-11-21 13:06 Jonas Maebe Assigned To => Jonas Maebe