View Issue Details

IDProjectCategoryView StatusLast Update
0018006LazarusIDEpublic2010-11-25 23:01
ReporterTeemu ValoAssigned ToPaul Ishenin 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version0.9.29 (SVN)Product Build 
Target VersionFixed in Version0.9.29 (SVN) 
Summary0018006: TPanel bevels are not working properly
DescriptionMainly panel with bevel properties look different than in Delphi (7). I much prefer the Delphi way that makes panel borders actually thicker with these properties:
-BevelWidth
-BorderWidth
Which are in drawing phase using also:
-BevelInner
-BevelOuter
Additional InformationUsing daily build (20.11.2010) Lazarus + fpc 2.4.3 for Win32, SVN 27016.

Screenshot provided for more details.
TagsNo tags attached.
Fixed in Revision28391
LazTarget-
WidgetsetWin32/Win64
Attached Files

Activities

2010-11-20 22:09

 

border_style.png (12,930 bytes)
border_style.png (12,930 bytes)

Paul Ishenin

2010-11-22 04:25

manager   ~0043344

Please test and close if ok.

Teemu Valo

2010-11-22 14:14

reporter   ~0043364

Last edited: 2010-11-22 14:56

I think Lazarus didn't update itself with the Win32 installer. Just now realised i'm using who knows how old version because it needs to be built too... And then it ended up with errors and i had to uninstall the thing and wipe directory clean.

But now (without even building) its showing SVN 28388 and the Panels didn't change better.

And the OS i'm using is Windows 7.

Teemu Valo

2010-11-22 14:59

reporter   ~0043365

Also adding link:
http://www.responsive.co.nz/source/Controls.txt

This seems to be where panel is drawn:
procedure TWinControl.WMNCPaint(var Message: TMessage);

And i'm aware it may be i have to wait till tomorrow for getting build that includes latest SVN...

stocki

2010-11-22 16:29

reporter   ~0043371

Is this one also fixed?
http://bugs.freepascal.org/view.php?id=10756

Zeljan Rikalo

2010-11-22 16:41

developer   ~0043372

I don't think so.

Teemu Valo

2010-11-22 16:42

reporter   ~0043373

No, if i create new application in Lazarus and add TMemo it doesn't have Bevelinner or outer properties. Delphi does have.

Teemu Valo

2010-11-25 23:00

reporter   ~0043528

This bug is fixed.

Issue History

Date Modified Username Field Change
2010-11-20 22:09 Teemu Valo New Issue
2010-11-20 22:09 Teemu Valo File Added: border_style.png
2010-11-20 22:09 Teemu Valo Widgetset => Win32/Win64
2010-11-22 04:25 Paul Ishenin Fixed in Revision => 28391
2010-11-22 04:25 Paul Ishenin LazTarget => -
2010-11-22 04:25 Paul Ishenin Status new => resolved
2010-11-22 04:25 Paul Ishenin Fixed in Version => 0.9.29 (SVN)
2010-11-22 04:25 Paul Ishenin Resolution open => fixed
2010-11-22 04:25 Paul Ishenin Assigned To => Paul Ishenin
2010-11-22 04:25 Paul Ishenin Note Added: 0043344
2010-11-22 14:14 Teemu Valo Note Added: 0043364
2010-11-22 14:17 Teemu Valo Note Edited: 0043364
2010-11-22 14:56 Teemu Valo Note Edited: 0043364
2010-11-22 14:59 Teemu Valo Note Added: 0043365
2010-11-22 16:29 stocki Note Added: 0043371
2010-11-22 16:41 Zeljan Rikalo Note Added: 0043372
2010-11-22 16:42 Teemu Valo Note Added: 0043373
2010-11-25 23:00 Teemu Valo Note Added: 0043528
2010-11-25 23:01 Teemu Valo Status resolved => closed