View Issue Details

IDProjectCategoryView StatusLast Update
0018017LazarusIDEpublic2011-12-01 11:25
ReporterDenis GottardelloAssigned ToAbou Al Montacir 
PrioritynormalSeverityblockReproducibilityalways
Status closedResolutionfixed 
Product Version0.9.29 (SVN)Product Build 
Target Version0.9.30Fixed in Version0.9.29 (SVN) 
Summary0018017: project1.lpr(17,1) Error: Error while compiling resources
DescriptionOn Linux, with Lazarus svn 20101122, fpc 20101122 is impossible to compile everything. In the lpr file there isn't any .res or .rc link.
TagsNo tags attached.
Fixed in Revision28460,28467,28748
LazTarget0.9.30
Widgetset
Attached Files

Relationships

has duplicate 0015699 closedAbou Al Montacir Error while compiling resources, missing (?) ../lcl/units/x86_64-linux/finddlgunit.lfm 
related to 0018111 closedAbou Al Montacir When executing 'make deb' is not installed some of the items 

Activities

Vincent Snijders

2010-11-23 15:07

manager   ~0043418

I cannot reproduce this issue with fpc 2.5.1 r16004 and lazarus 0.9.29 r28435.

What is the output in the console during the compilation?
What is the output of "which fpcres" and "fpcres"?
Can you compile the test project with the "-va" compiler parameter, to show the command line used to compile the resources?

Denis Gottardello

2010-11-24 08:38

reporter   ~0043456

For reproduce this behaviour you must download Fpc and Lazarus for Debian from the Lazarus's snapshots repository (now is unavailable). You'll see that is impossible to rebuild Lazarus and compile something.
Now, to work on Debian, I use fpc from official Freepascal website and Lazarus from snapshots (dated 30.09.2010)

Vincent Snijders

2010-11-24 09:43

manager   ~0043460

I downloaded ftp://ftp.hu.freepascal.org/pub/lazarus/snapshots/lazarus-0.9.29.28437-20101124.i386.deb.tar from http://www.hu.freepascal.org/lazarus/ and installed all debs with sudo dpkg -i *.deb.

I already had fpc 2.4.2 debs installed.

Created a new project and successfully compiled it.

Denis Gottardello

2010-11-24 12:38

reporter   ~0043467

I have just downloaded lazarus (ftp://ftp.hu.freepascal.org/pub/lazarus/snapshots/lazarus-0.9.29.28437-20101124.i386.deb.tar) some minutes ago. Using fpc from the official Freepascal repository is impossible compile something or rebuild lazarus or install components like sqlite3 or lazreport. Using lazarus from snapshots (30.09.2010) all works well.
(On Debian Squeeze)

Vincent Snijders

2010-11-24 12:51

manager   ~0043468

Dennis, by "is impossible" you mean "I cannot".

Please, read note 43418 again and attach the extra information.

What fpc version did you use for the snapshot, that worked?

Denis Gottardello

2010-11-24 14:21

reporter   ~0043469

Last edited: 2010-11-25 14:14

I don't know what happens. Now I have installed lazarus from a clear configuration. I have start lazarus -> package -> .lpk -> components -> sqlite3 -> install.
Lazarus starts rebuild till this error:
...
removed

Paul Ishenin

2010-11-24 15:16

manager   ~0043471

Please execute the next command in the console:
/usr/bin/fpc -B -MObjFPC -Scghi -O1 -gl -WG -vewnhi -l -Fi/root/aaaa/lib/i386-linux -Fu/usr/lib/lazarus/0.9.29/lcl/units/i386-linux -Fu/usr/lib/lazarus/0.9.29/lcl/units/i386-linux/gtk2 -Fu/usr/lib/lazarus/0.9.29/packager/units/i386-linux -Fu/root/aaaa/ -Fu. -FU/root/aaaa/lib/i386-linux/ -oproject1 -dLCL -dLCLgtk2 project1.lpr

Hope we will get more informative output regards the resources problem.

Denis Gottardello

2010-11-24 15:37

reporter   ~0043472

Last edited: 2010-11-24 15:40

root@debian01:~/aaaa# /usr/bin/fpc -B -MObjFPC -Scghi -O1 -gl -WG -vewnhi -l -Fi/root/aaaa/lib/i386-linux -Fu/usr/lib/lazarus/0.9.29/lcl/units/i386-linux -Fu/usr/lib/lazarus/0.9.29/lcl/units/i386-linux/gtk2 -Fu/usr/lib/lazarus/0.9.29/packager/units/i386-linux -Fu/root/aaaa/ -Fu. -FU/root/aaaa/lib/i386-linux/ -oproject1 -dLCL -dLCLgtk2 project1.lpr
Hint: Start of reading config file /etc/fpc.cfg
Hint: End of reading config file /etc/fpc.cfg
Free Pascal Compiler version 2.4.2-0 [2010/11/11] for i386
Copyright (c) 1993-2010 by Florian Klaempfl
Target OS: Linux for i386
Compiling project1.lpr
Compiling unit1.pas
Compiling resource /root/aaaa/lib/i386-linux/project1.or
Error: Can't open file '/usr/lib/lazarus/0.9.29/lcl/units/i386-linux/finddlgunit.lfm'
project1.lpr(19,1) Error: Error while compiling resources
project1.lpr(19,1) Fatal: There were 1 errors compiling module, stopping
Fatal: Compilation aborted
Error: /usr/bin/ppc386 returned an error exitcode (normal if you did not specify a source file to be compiled)
root@debian01:~/aaaa#

The file '/usr/lib/lazarus/0.9.29/lcl/units/i386-linux/finddlgunit.lfm' is in this site: '/usr/lib/lazarus/0.9.29/lcl/forms/', package lazarus-src_0.9.29-0-20101124_all.deb

Vincent Snijders

2010-11-24 15:48

manager   ~0043476

Let me take a look at this issue.

Denis Gottardello

2010-11-25 08:58

reporter   ~0043504

Last edited: 2010-11-25 14:14

Sorry but I can't rebuild lazarus for install sqlite3 component. I obtain this error:

...
removed

Denis Gottardello

2010-11-25 09:02

reporter   ~0043505

I can't rebuild lazarus for install components but now I can compile a project.

Paul Ishenin

2010-11-25 10:10

manager   ~0043506

I see no erros in your output

Vincent Snijders

2010-11-25 10:41

manager   ~0043509

The output got truncated in the note.

Please attach the output as zipped text to the bug report. And edit the note, no need to leave such a long text in the bug report to be loaded and sent each time.

2010-11-25 14:11

 

LazarusRebuild.txt.zip (9,536 bytes)

Denis Gottardello

2010-11-25 14:13

reporter   ~0043515

I have just uploaded two file, one on rebuild of lazarus and one on installation behavior of sqlite component.

Vincent Snijders

2010-11-25 14:18

manager   ~0043516

In /usr/lib/lazarus/0.9.29/ide execute:
/usr/bin/fpc -gl -dlclgtk2 -Fu../lcl/units/i386-linux -Fu../lcl/units/i386-linux/gtk2 -Fu../components/codetools/units/i386-linux -Fu../components/synedit/units/i386-linux -Fu../components/lazcontrols/lib/i386-linux -Fu../components/custom -Fu../components/mpaslex -Fu../ideintf/units/i386-linux -Fu../designer -Fu../debugger -Fu../debugger/frames -Fu../converter -Fu../packager -Fu../packager/frames -Fu../packager/units/i386-linux -Fu../units/i386-linux -Fuframes -Fu. -Fu/usr/lib/fpc/2.4.2/units/i386-linux/rtl -Fu/usr/lib/fpc/2.4.2/units/i386-linux/regexpr -Fiinclude -Fiinclude/linux -Fi../images -FE.. -FU../units/i386-linux -Fl/usr/lib/gcc/i486-linux-gnu/4.4.5 -Flinclude -Fl/etc/ld.so.conf.d/*.conf @/root/.lazarus/idemake.cfg -di386 -vd lazarus.pp

If that doesn't give more information about the error, replace -vd with -va.

Please, zip and attach the output.

2010-11-25 15:01

 

bbb.txt.zip (6,771 bytes)

Denis Gottardello

2010-11-25 15:02

reporter   ~0043517

See at bbb.txt.zip

Vincent Snijders

2010-11-25 15:22

manager   ~0043518

Hmm, maybe this is a different error. Can you verify you have the file /root/.lazarus/idemake.cfg before you execute the compiler?

2010-11-25 16:01

 

Output.zip.rar (1,865,884 bytes)

Denis Gottardello

2010-11-25 16:03

reporter   ~0043520

This file does not exists on my pc. I see that this file exists in the directory of a older version of lazarus. I have copied it from the older backup to the right directory and then I have tried to rebuild lazarus but does not work. I have attached the output.
See Output.zip.rar

root@debian01:/usr/lib/lazarus/0.9.29/ide# /usr/bin/fpc -gl -dlclgtk2 -Fu../lcl/units/i386-linux -Fu../lcl/units/i386-linux/gtk2 -Fu../components/codetools/units/i386-linux -Fu../components/synedit/units/i386-linux -Fu../components/lazcontrols/lib/i386-linux -Fu../components/custom -Fu../components/mpaslex -Fu../ideintf/units/i386-linux -Fu../designer -Fu../debugger -Fu../debugger/frames -Fu../converter -Fu../packager -Fu../packager/frames -Fu../packager/units/i386-linux -Fu../units/i386-linux -Fuframes -Fu. -Fu/usr/lib/fpc/2.4.2/units/i386-linux/rtl -Fu/usr/lib/fpc/2.4.2/units/i386-linux/regexpr -Fiinclude -Fiinclude/linux -Fi../images -FE.. -FU../units/i386-linux -Fl/usr/lib/gcc/i486-linux-gnu/4.4.5 -Flinclude -Fl/etc/ld.so.conf.d/*.conf @/root/.lazarus/idemake.cfg -di386 -vd lazarus.pp > aaa.txt
Error: Can't open file '/usr/lib/lazarus/0.9.29/ideintf/units/i386-linux/frmselectprops.lfm'
root@debian01:/usr/lib/lazarus/0.9.29/ide#

root@debian01:/usr/lib/lazarus/0.9.29/ide# /usr/bin/fpc -gl -dlclgtk2 -Fu../lcl/units/i386-linux -Fu../lcl/units/i386-linux/gtk2 -Fu../components/codetools/units/i386-linux -Fu../components/synedit/units/i386-linux -Fu../components/lazcontrols/lib/i386-linux -Fu../components/custom -Fu../components/mpaslex -Fu../ideintf/units/i386-linux -Fu../designer -Fu../debugger -Fu../debugger/frames -Fu../converter -Fu../packager -Fu../packager/frames -Fu../packager/units/i386-linux -Fu../units/i386-linux -Fuframes -Fu. -Fu/usr/lib/fpc/2.4.2/units/i386-linux/rtl -Fu/usr/lib/fpc/2.4.2/units/i386-linux/regexpr -Fiinclude -Fiinclude/linux -Fi../images -FE.. -FU../units/i386-linux -Fl/usr/lib/gcc/i486-linux-gnu/4.4.5 -Flinclude -Fl/etc/ld.so.conf.d/*.conf @/root/.lazarus/idemake.cfg -di386 -va lazarus.pp > bbb.txt
Error: Can't open file '/usr/lib/lazarus/0.9.29/ideintf/units/i386-linux/frmselectprops.lfm'
root@debian01:/usr/lib/lazarus/0.9.29/ide#

Vincent Snijders

2010-11-25 16:11

manager   ~0043522

That is an error message I can handle.

Denis Gottardello

2010-12-02 11:11

reporter   ~0043880

I think the right way to build debian packages is convert the rpm package to deb with alien --to-deb --script. Then the only thing to do is to insert in debian package the right dependencies. I have tryed and works.

Abou Al Montacir

2010-12-18 01:03

developer   ~0044313

Now output directories are installed with all genrated files including *.lfm and *.or

Issue History

Date Modified Username Field Change
2010-11-22 14:22 Denis Gottardello New Issue
2010-11-23 15:07 Vincent Snijders LazTarget => 0.9.30
2010-11-23 15:07 Vincent Snijders Note Added: 0043418
2010-11-23 15:07 Vincent Snijders Status new => feedback
2010-11-23 15:07 Vincent Snijders Target Version => 0.9.30
2010-11-24 08:38 Denis Gottardello Note Added: 0043456
2010-11-24 09:43 Vincent Snijders Note Added: 0043460
2010-11-24 12:38 Denis Gottardello Note Added: 0043467
2010-11-24 12:51 Vincent Snijders Note Added: 0043468
2010-11-24 14:21 Denis Gottardello Note Added: 0043469
2010-11-24 15:16 Paul Ishenin Note Added: 0043471
2010-11-24 15:37 Denis Gottardello Note Added: 0043472
2010-11-24 15:40 Denis Gottardello Note Edited: 0043472
2010-11-24 15:48 Vincent Snijders Note Added: 0043476
2010-11-24 15:48 Vincent Snijders Status feedback => assigned
2010-11-24 15:59 Vincent Snijders Assigned To => Vincent Snijders
2010-11-24 21:11 Vincent Snijders Fixed in Revision => 28460,28467
2010-11-24 21:11 Vincent Snijders Status assigned => resolved
2010-11-24 21:11 Vincent Snijders Fixed in Version => 0.9.29 (SVN)
2010-11-24 21:11 Vincent Snijders Resolution open => fixed
2010-11-25 08:58 Denis Gottardello Note Added: 0043504
2010-11-25 09:02 Denis Gottardello Status resolved => assigned
2010-11-25 09:02 Denis Gottardello Resolution fixed => reopened
2010-11-25 09:02 Denis Gottardello Note Added: 0043505
2010-11-25 10:10 Paul Ishenin Note Added: 0043506
2010-11-25 10:41 Vincent Snijders Note Added: 0043509
2010-11-25 10:41 Vincent Snijders Status assigned => feedback
2010-11-25 14:11 Denis Gottardello File Added: LazarusRebuild.txt.zip
2010-11-25 14:13 Denis Gottardello Note Added: 0043515
2010-11-25 14:14 Denis Gottardello Note Edited: 0043504
2010-11-25 14:14 Denis Gottardello Note Edited: 0043469
2010-11-25 14:18 Vincent Snijders Note Added: 0043516
2010-11-25 15:01 Denis Gottardello File Added: bbb.txt.zip
2010-11-25 15:02 Denis Gottardello Note Added: 0043517
2010-11-25 15:22 Vincent Snijders Note Added: 0043518
2010-11-25 16:01 Denis Gottardello File Added: Output.zip.rar
2010-11-25 16:03 Denis Gottardello Note Added: 0043520
2010-11-25 16:11 Vincent Snijders Note Added: 0043522
2010-11-25 16:11 Vincent Snijders Status feedback => assigned
2010-11-26 16:25 Vincent Snijders Assigned To Vincent Snijders => Abou Al Montacir
2010-11-29 23:06 Vincent Snijders Relationship added related to 0018111
2010-11-30 11:21 Vincent Snijders Relationship added has duplicate 0015699
2010-12-02 11:11 Denis Gottardello Note Added: 0043880
2010-12-18 01:03 Abou Al Montacir Fixed in Revision 28460,28467 => 28460,28467,28748
2010-12-18 01:03 Abou Al Montacir Status assigned => resolved
2010-12-18 01:03 Abou Al Montacir Resolution reopened => fixed
2010-12-18 01:03 Abou Al Montacir Note Added: 0044313
2011-12-01 11:25 Marc Weustink Status resolved => closed