View Issue Details

IDProjectCategoryView StatusLast Update
0018024FPCCompilerpublic2010-11-23 10:51
ReporterTiml Assigned ToJonas Maebe  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionno change required 
PlatformX86OSLinux 
Product Version2.5.1 
Summary0018024: Oddity in valgrind output
DescriptionWhen a program is compiled with -gv and then run under valgrind 3.6.0, valgrind produces the following message


parse_type_DIE: confused by:
 <1><974e>: DW_TAG_subrange_type
     DW_AT_name : THELPCONTEXT
     DW_AT_lower_bound : -2147483647
     DW_AT_upper_bound : 2147483647
     DW_AT_type : 0x1608

--27520-- WARNING: Serious error when reading debug info


Steps To ReproduceRun an FPC or lazarus application compiled with valgrind code
Additional InformationThe DW_AT information changes with different programmes. The DW_TAG_subrange_type seems to be the constant factor
TagsNo tags attached.
Fixed in Revision
FPCOldBugId
FPCTarget
Attached Files

Activities

Jonas Maebe

2010-11-23 10:51

manager   ~0043406

Please report a bug against Valgrind, that type information is correct. Valgrind probably does not support it since C/C++ don't know subrange types.

Issue History

Date Modified Username Field Change
2010-11-23 07:53 Timl New Issue
2010-11-23 10:51 Jonas Maebe Status new => resolved
2010-11-23 10:51 Jonas Maebe Resolution open => no change required
2010-11-23 10:51 Jonas Maebe Assigned To => Jonas Maebe
2010-11-23 10:51 Jonas Maebe Note Added: 0043406