View Issue Details

IDProjectCategoryView StatusLast Update
0018032FPCRTLpublic2010-11-24 00:16
Reporterivan17 Assigned ToJonas Maebe  
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionno change required 
Platformwin32 
Product Version2.4.3 
Summary0018032: ShellExecuteEx: Can't determine which overloaded function to call
Descriptioni filed this under RTL, although it seems like a compiler issue to me - the compiler allows existence of unicode equivalents of the same name but doesn't differentiate them always.

code to try out:
ShellExecuteEx(@whatever);
TagsNo tags attached.
Fixed in Revision
FPCOldBugId
FPCTarget
Attached Files

Activities

ivan17

2010-11-23 21:51

reporter   ~0043435

for completeness, the problem can be circumvented by writing ShellExecuteEx(LPSHELLEXECUTEINFOA(@recordvariable)) but that viciously kills the point of having an alias for both A and W versions.

Jonas Maebe

2010-11-24 00:16

manager   ~0043445

The default is that typed pointers are off, which means that the result type of "@whatever" is always an untyped pointer. Add {$t+} to your source file if you want to make the address-operator return typed results.

Please include full examples when submitting bug reports in the future, because an uncompilable statement outside any context is not always enough to determine what the problem is (and one minute of work by you can easily save 15 minutes for us).

Issue History

Date Modified Username Field Change
2010-11-23 21:04 ivan17 New Issue
2010-11-23 21:51 ivan17 Note Added: 0043435
2010-11-24 00:16 Jonas Maebe Status new => resolved
2010-11-24 00:16 Jonas Maebe Resolution open => no change required
2010-11-24 00:16 Jonas Maebe Assigned To => Jonas Maebe
2010-11-24 00:16 Jonas Maebe Note Added: 0043445