View Issue Details

IDProjectCategoryView StatusLast Update
0018041LazarusIDEpublic2011-01-16 12:57
ReporterMartin FriebeAssigned ToMartin Friebe 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version0.9.29 (SVN)Product Build 
Target Version0.9.30Fixed in Version 
Summary0018041: Crash in TIDEMenu (SourceEditor context pop up
DescriptionStart IDE and open 3 source-edit windows, with files as follows

While doing this, and do not use the context menu.

- win1: file1, file2
- win2: file1
- win3: file1

Now open the context menu of the sourceditor on "win1 file1" (no need to perform any action)

And then on "win1 file" => crash
TagsNo tags attached.
Fixed in Revision28760
LazTarget0.9.30
WidgetsetWin32/Win64
Attached Files

Relationships

related to 0017109 closedMattias Gaertner Regression: MenuIntf causes index out of bounds exception 

Activities

Zeljan Rikalo

2010-11-29 11:02

developer   ~0043712

@Martin, I cannot reproduce this problem under linux/qt linux/gtk2.But maybe I misunderstood your way of "howto reproduce".
1.I've created kbd shortcut (Shift+Ctrl+N) to clone current unit (file1) into new se window.
2.Now pressed Shift+Ctrl+N (new SE window created with file1).
3.Click onto main SE (file 1) and repeated 2.
Now I have win1 (file1,file2,file3...) win2 (file1) win3 (file1).

Now right click in win1 (file1) -> context is shown and I can choose any action.
Tried few times and there's no crash.

Zeljan Rikalo

2010-11-29 12:23

developer   ~0043721

Just tested under Win7 (win32) and cannot reproduce.

Paul Ishenin

2010-11-30 10:07

manager   ~0043775

There is no "win1 file" in your intial files enumration. Is this "win1 file2" or what?

Martin Friebe

2010-12-02 15:15

manager   ~0043891

indeed "win1 file" should be "win1 file2"

So you first open the context menu, on the editor that is present in all 3 windows (using the window with tabs for the other editor too).

Then you change tab, and open the context menu for the editor that has only one instance.

ivan17

2010-12-13 14:45

reporter   ~0044203

List index (3) out of bounds.

lazarus 28702, windows xp

Martin Friebe

2010-12-18 14:11

manager   ~0044324

The problem was caused by TIDEMenuSection trying to create it's TMenuItems, while it's parent Section was invisible.
Pre-required TMenuItems from siblings would be missing.

Issue History

Date Modified Username Field Change
2010-11-24 16:29 Martin Friebe New Issue
2010-11-24 16:29 Martin Friebe LazTarget => -
2010-11-24 16:29 Martin Friebe Widgetset => Win32/Win64
2010-11-24 16:32 Martin Friebe Relationship added related to 0017109
2010-11-24 21:26 Vincent Snijders LazTarget - => 0.9.30
2010-11-24 21:26 Vincent Snijders Status new => acknowledged
2010-11-24 21:26 Vincent Snijders Target Version => 0.9.30
2010-11-29 11:02 Zeljan Rikalo Note Added: 0043712
2010-11-29 11:02 Zeljan Rikalo Status acknowledged => feedback
2010-11-29 12:23 Zeljan Rikalo Note Added: 0043721
2010-11-30 10:07 Paul Ishenin Note Added: 0043775
2010-12-02 15:15 Martin Friebe Note Added: 0043891
2010-12-12 21:37 Vincent Snijders Status feedback => acknowledged
2010-12-13 14:45 ivan17 Note Added: 0044203
2010-12-18 13:58 Martin Friebe Status acknowledged => assigned
2010-12-18 13:58 Martin Friebe Assigned To => Martin Friebe
2010-12-18 14:11 Martin Friebe Fixed in Revision => 28760
2010-12-18 14:11 Martin Friebe Status assigned => resolved
2010-12-18 14:11 Martin Friebe Resolution open => fixed
2010-12-18 14:11 Martin Friebe Note Added: 0044324
2011-01-16 12:57 Martin Friebe Status resolved => closed