View Issue Details

IDProjectCategoryView StatusLast Update
0018058FPCCompilerpublic2011-12-03 17:12
ReporterChristian Assigned ToSergei Gorelkin  
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Version2.4.3 
Fixed in Version2.6.0 
Summary0018058: "overriding" and delegated Implementation in interfaces dont work.
DescriptionSee attatched Example, "TObj.M2" should be called but TObjIntf2.M2 is called !
TagsNo tags attached.
Fixed in Revision18904
FPCOldBugId0
FPCTarget
Attached Files

Relationships

related to 0004842 assignedIvo Steinmann implements keyword in properties 

Activities

2010-11-26 15:03

 

project1.lpr (1,406 bytes)

Sergei Gorelkin

2010-11-26 16:09

developer   ~0043567

Delphi 7 does not compile this example, error is "Cannot have method resolutions for interface 'Intf2'".
We should probably do the same, because this is basically a case of duplicate identifier, not "overriding".

Sergei Gorelkin

2011-08-12 16:46

developer   ~0050778

Disallowed simultaneous use of method resolution and delegation for an interface within a class. Also disallowed delegating a single interface to multiple properties. Behavior is now Delphi compliant.

Issue History

Date Modified Username Field Change
2010-11-26 15:03 Christian New Issue
2010-11-26 15:03 Christian File Added: project1.lpr
2010-11-26 15:51 Jonas Maebe Relationship added related to 0004842
2010-11-26 16:09 Sergei Gorelkin Note Added: 0043567
2011-08-12 16:46 Sergei Gorelkin Fixed in Revision => 18179
2011-08-12 16:46 Sergei Gorelkin Status new => resolved
2011-08-12 16:46 Sergei Gorelkin Fixed in Version => 2.7.1
2011-08-12 16:46 Sergei Gorelkin Resolution open => fixed
2011-08-12 16:46 Sergei Gorelkin Assigned To => Sergei Gorelkin
2011-08-12 16:46 Sergei Gorelkin Note Added: 0050778
2011-12-03 14:19 Marco van de Voort FPCOldBugId => 0
2011-12-03 14:19 Marco van de Voort Fixed in Version 2.7.1 => 2.6.0
2011-12-03 17:12 Marco van de Voort Fixed in Revision 18179 => 18904