View Issue Details

IDProjectCategoryView StatusLast Update
0018097LazarusIDEpublic2010-11-29 09:34
ReporterAlexander S. KleninAssigned ToMartin Friebe 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product VersionProduct Build 
Target Version0.9.30Fixed in Version0.9.29 (SVN) 
Summary0018097: IDE opens .lpr file when running application
DescriptionThis regression was introduced in approximately the last week.
Steps To Reproduce1) Open any project
2) Press F9
=>
.lpr file of the project is opened and becomes current file in the editor
TagsNo tags attached.
Fixed in Revision28551
LazTarget0.9.30
Widgetset
Attached Files

Activities

Martin Friebe

2010-11-29 00:40

manager   ~0043691

Please test and close if ok.

This only was the case with some versions of gdb.
Some versions of gb do not report the reason "breakpoint hit" if the stop at a temporary breakpoint (which happens during startup, at the apps entry point (lpr file)).

In this case it was not checked, if the unknown reason was the expected temporary break, therefore a real breakpoint was assumed (even so the app was then continued).

Alexander S. Klenin

2010-11-29 09:34

developer   ~0043701

Thanks. FYI, I have gdb 7.0 under Windows.

Issue History

Date Modified Username Field Change
2010-11-28 20:51 Alexander S. Klenin New Issue
2010-11-28 20:51 Alexander S. Klenin LazTarget => -
2010-11-28 23:42 Martin Friebe Status new => assigned
2010-11-28 23:42 Martin Friebe Assigned To => Martin Friebe
2010-11-29 00:40 Martin Friebe Fixed in Revision => 28551
2010-11-29 00:40 Martin Friebe LazTarget - => 0.9.30
2010-11-29 00:40 Martin Friebe Status assigned => resolved
2010-11-29 00:40 Martin Friebe Fixed in Version => 0.9.29 (SVN)
2010-11-29 00:40 Martin Friebe Resolution open => fixed
2010-11-29 00:40 Martin Friebe Note Added: 0043691
2010-11-29 00:41 Martin Friebe Target Version => 0.9.30
2010-11-29 09:34 Alexander S. Klenin Status resolved => closed
2010-11-29 09:34 Alexander S. Klenin Note Added: 0043701