View Issue Details

IDProjectCategoryView StatusLast Update
0000181Lazaruspublic2004-02-01 19:48
ReporterBug Import Assigned To 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Summary0000181: TScrollBar align = right doesn't work right
DescriptionDrop a TScrollBar on a form, set to vertical, and set align=alright and it doesn't go to the right side of the container...
Additional InformationImported information
--------------------
Name: Tony Maro
Mail: tony (at) maro.net
TagsNo tags attached.
Fixed in Revision
LazTarget
WidgetsetGTK
Attached Files

Activities

Bug Import

2004-02-01 19:48

reporter   ~0000158

Not really a bug.

Vertical scrollbars can not be resized in width under gtk. And I think it does not make much sense in win32 neither.
Setting Anchors=[akLeft,akTop] and Align=alRight means, that the LCL tries to keep Left and expand Width, which does not work and so it does not give the wanted effect.

OTOH, because these combinations do not make much sense, TScrollBar should automatically set useful combinations. I implemented it.

MG

Issue History

Date Modified Username Field Change
2004-02-01 00:00 Bug Import New Issue
2004-02-01 19:48 Bug Import Widgetset => GTK
2004-02-01 19:48 Bug Import Note Added: 0000158
2004-02-01 19:48 Bug Import Status new => closed
2004-02-01 19:48 Bug Import Resolution open => fixed