View Issue Details

IDProjectCategoryView StatusLast Update
0018100LazarusWidgetsetpublic2010-12-06 09:08
ReporterH.HartlAssigned ToPaul Ishenin 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version0.9.29 (SVN)Product Build28552 
Target Version0.9.30Fixed in Version0.9.29 (SVN) 
Summary0018100: Memo / black background (clDefault) / on OSX
DescriptionMemo gets black background (clDefault) when parent is changed.
Steps To Reproduce1) New Project
2) Drop a panel and a memo beneath each other on the form.
3) Make a button:
procedure TForm1.Button1Click(Sender: TObject);
begin
  memo1.Parent := Panel1; memo1.Top:= 0 ;memo1.Left := 0;
end;
4) Run => Memo gets wrong black background color

The problem is also reproducable in the designer by changing the parent in the object inspector.
TagsNo tags attached.
Fixed in Revision28569
LazTarget0.9.30
WidgetsetCarbon
Attached Files

Activities

H.Hartl

2010-11-29 10:44

reporter   ~0043709

Another (related?) issue.

Drop a Memo on a form and change property Scrollbars to an other value then ssNone. => Memo goes black

Paul Ishenin

2010-11-30 13:52

manager   ~0043803

Please test and close if ok.

Issue History

Date Modified Username Field Change
2010-11-29 10:30 H.Hartl New Issue
2010-11-29 10:30 H.Hartl Widgetset => Carbon
2010-11-29 10:44 H.Hartl Note Added: 0043709
2010-11-29 10:46 Vincent Snijders LazTarget => 0.9.30
2010-11-29 10:46 Vincent Snijders Assigned To => Paul Ishenin
2010-11-29 10:46 Vincent Snijders Status new => assigned
2010-11-29 10:46 Vincent Snijders Target Version => 0.9.30
2010-11-30 13:52 Paul Ishenin Fixed in Revision => 28569
2010-11-30 13:52 Paul Ishenin Status assigned => resolved
2010-11-30 13:52 Paul Ishenin Fixed in Version => 0.9.29 (SVN)
2010-11-30 13:52 Paul Ishenin Resolution open => fixed
2010-11-30 13:52 Paul Ishenin Note Added: 0043803
2010-12-06 09:08 H.Hartl Status resolved => closed