View Issue Details

IDProjectCategoryView StatusLast Update
0018122LazarusOtherpublic2010-12-03 08:40
ReporterPatrick ChevalleyAssigned ToMattias Gaertner 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version0.9.29 (SVN)Product Build 
Target Version0.9.30Fixed in Version0.9.29 (SVN) 
Summary0018122: Lazbuild crash
DescriptionUsing Lazarus svn 28578, Lazbuild crash when trying to compile a project.
Lazarus itself compile this project without problem.
See following gdb trace and environmentoptions extract.
Additional Information$ gdb --args /home/pch/lazarus/lazbuild cdc.lpi
GNU gdb (GDB) 7.1-ubuntu
Copyright (C) 2010 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law. Type "show copying"
and "show warranty" for details.
This GDB was configured as "x86_64-linux-gnu".
For bug reporting instructions, please see:
<http://www.gnu.org/software/gdb/bugs/>...
Reading symbols from /home/pch/lazarus/lazbuild...done.
(gdb) run
Starting program: /home/pch/lazarus/lazbuild cdc.lpi

Program received signal SIGSEGV, Segmentation fault.
0x00000000006ffaea in GETCOMPILERFILENAME (this=0x7ffff7e0a050) at environmentopts.pp:1546
1546 GlobalMacroList.SubstituteStr(FCompilerFilenameParsed);
(gdb) bt
#0 0x00000000006ffaea in GETCOMPILERFILENAME (this=0x7ffff7e0a050) at environmentopts.pp:1546
0000001 0x00000000006d6bca in SETUPCOMPILERFILENAME (INTERACTIVESETUP=@0x7fffffffe090)
    at initialsetupdlgs.pas:61
0000002 0x00000000005ae51f in INIT (this=0x7ffff7806120) at lazbuild.lpr:794
0000003 0x00000000005ad6b9 in BUILDPROJECT (this=0x7ffff7806120,
    AFILENAME=0x7ffff7fcbf50 '/home/pch/skychart/build/skychart/cdc.lpi') at lazbuild.lpr:610
0000004 0x00000000005ac11a in BUILDFILE (this=0x7ffff7806120,
    FILENAME=0x7ffff7fcbf50 '/home/pch/skychart/build/skychart/cdc.lpi') at lazbuild.lpr:295
0000005 0x00000000005afa02 in RUN (this=0x7ffff7806120) at lazbuild.lpr:1039
0000006 0x00000000005b19b6 in main () at lazbuild.lpr:1273
(gdb)


$ grep Compiler .lazarus/environmentoptions.xml
    <CompilerFilename Value="/usr/local/bin/fpc">
    </CompilerFilename>
          <Name Value="TfrmCompilerOptions"/>
    <CompilerMessagesFilename Value=""/>

TagsNo tags attached.
Fixed in Revision28604
LazTarget0.9.30
WidgetsetGTK 2
Attached Files

Relationships

has duplicate 0018136 closedVincent Snijders EAccessViolation: make -C docs/html 

Activities

Ingo Steiniger

2010-12-01 23:32

reporter   ~0043868

I can confirm this. I tried building IDE with "lazbuild -B --build-ide=" on different Systems (Ubuntu x64 and WinXP i386) and with different compiler (fpc 2.4.2 and 2.5.1). I always do a "make clean all" before building with lazbuild.
It crashes since r28575 (r28574 works).
Hope this informations are useful.

Paul Ishenin

2010-12-03 05:04

manager   ~0043909

Please test and close if ok.

Patrick Chevalley

2010-12-03 08:40

reporter   ~0043913

It work fine, thank you.

Issue History

Date Modified Username Field Change
2010-12-01 11:23 Patrick Chevalley New Issue
2010-12-01 11:23 Patrick Chevalley Widgetset => GTK 2
2010-12-01 11:29 Vincent Snijders LazTarget => 0.9.30
2010-12-01 11:29 Vincent Snijders Assigned To => Mattias Gaertner
2010-12-01 11:29 Vincent Snijders Status new => assigned
2010-12-01 11:29 Vincent Snijders Target Version => 0.9.30
2010-12-01 23:32 Ingo Steiniger Note Added: 0043868
2010-12-02 11:16 Vincent Snijders Relationship added has duplicate 0018136
2010-12-03 05:04 Paul Ishenin Fixed in Revision => 28604
2010-12-03 05:04 Paul Ishenin Status assigned => resolved
2010-12-03 05:04 Paul Ishenin Fixed in Version => 0.9.29 (SVN)
2010-12-03 05:04 Paul Ishenin Resolution open => fixed
2010-12-03 05:04 Paul Ishenin Note Added: 0043909
2010-12-03 08:40 Patrick Chevalley Status resolved => closed
2010-12-03 08:40 Patrick Chevalley Note Added: 0043913