View Issue Details

IDProjectCategoryView StatusLast Update
0018136LazarusIDEpublic2010-12-26 17:53
ReporterMarelisAssigned ToVincent Snijders 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionduplicate 
Platformi386OSUbuntuOS Version10.04
Product Version0.9.29 (SVN)Product Build28588 
Target VersionFixed in Version 
Summary0018136: EAccessViolation: make -C docs/html
Description---8<---
cd /media/Marelis/build/lazarus/build/build_lazarus-ide && make -C docs/html htmldocs
make[1]: Entering directory `/media/Marelis/build/lazarus/build/build_lazarus-ide/docs/html'
../../lazbuild build_lcl_docs.lpi
An unhandled exception occurred at $0815067C :
EAccessViolation : Access violation
  $0815067C TENVIRONMENTOPTIONS__GETCOMPILERFILENAME, line 1546 of environmentopts.pp
  $08130ED3 SETUPCOMPILERFILENAME, line 61 of initialsetupdlgs.pas
  $0804A96C TLAZBUILDAPPLICATION__INIT, line 794 of lazbuild.lpr
  $08049F04 TLAZBUILDAPPLICATION__BUILDPROJECT, line 610 of lazbuild.lpr
  $08048F30 TLAZBUILDAPPLICATION__BUILDFILE, line 295 of lazbuild.lpr
  $0804B8EA TLAZBUILDAPPLICATION__RUN, line 1039 of lazbNote: environment config file not found - using defaults
NOTE: miscellaneous options file not found - using defaults
uild.lpr
  $0804D161 main, line 1273 of lazbuild.lpr
  $4005BBD6

make[1]: *** [build_lcl_docs] Error 217
make[1]: Leaving directory `/media/Marelis/build/lazarus/build/build_lazarus-ide/docs/html'
make: *** [build/lazarus-ide] Error 2
---8<---
Steps To Reproduce1. install FPC 2.4.2
2. checkout svn Lazarus IDE -> revision 28588
3. bash command: make -C docs/html htmldocs
TagsNo tags attached.
Fixed in Revision
LazTarget-
Widgetset
Attached Files

Relationships

duplicate of 0018122 closedMattias Gaertner Lazbuild crash 

Activities

Marelis

2010-12-02 11:15

reporter   ~0043881

I'm sorry, I forgot to write the previous bash commands:

make lcl packager/registration ideintf bigidecomponents
make bigide USESVN2REVISIONINC=0
make lazbuilder
make tools
make -C docs/html htmldocs

Thx.

Marelis

2010-12-26 17:53

reporter   ~0044602

Thanks

Issue History

Date Modified Username Field Change
2010-12-02 11:12 Marelis New Issue
2010-12-02 11:15 Marelis Note Added: 0043881
2010-12-02 11:16 Vincent Snijders LazTarget => -
2010-12-02 11:16 Vincent Snijders Relationship added duplicate of 0018122
2010-12-02 11:16 Vincent Snijders Duplicate ID 0 => 18122
2010-12-02 11:16 Vincent Snijders Status new => resolved
2010-12-02 11:16 Vincent Snijders Resolution open => duplicate
2010-12-02 11:16 Vincent Snijders Assigned To => Vincent Snijders
2010-12-26 17:53 Marelis Status resolved => closed
2010-12-26 17:53 Marelis Note Added: 0044602