View Issue Details

IDProjectCategoryView StatusLast Update
0018140FPCCompilerpublic2010-12-02 23:58
ReporterLuis Del Aguila Assigned ToJonas Maebe  
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionduplicate 
OSWindows and Linux 
Product Version2.4.2 
Summary0018140: Initialized variables string with utf8
DescriptionIn Windos (cp1252), when initializing variables of type string with utf8 characters, do not put question marks. In Linux, with the unit cwstring, does not place the utf8 characters.
TagsNo tags attached.
Fixed in Revision
FPCOldBugId
FPCTarget
Attached Files

Relationships

duplicate of 0016219 closedJonas Maebe String in const array of string does not compile 

Activities

2010-12-02 23:50

 

test.pp (279 bytes)

Jonas Maebe

2010-12-02 23:58

manager   ~0043906

The fact that it worked for you under Windows was pure coincidence. FPC 2.5.1 gives the following compile time error (on all platforms):


tw18140.pp(3,88) Error: Unicodechar/string constants cannot be converted to ansi/shortstring at compile-time

Issue History

Date Modified Username Field Change
2010-12-02 23:50 Luis Del Aguila New Issue
2010-12-02 23:50 Luis Del Aguila File Added: test.pp
2010-12-02 23:58 Jonas Maebe Relationship added duplicate of 0016219
2010-12-02 23:58 Jonas Maebe Duplicate ID 0 => 16219
2010-12-02 23:58 Jonas Maebe Status new => resolved
2010-12-02 23:58 Jonas Maebe Resolution open => duplicate
2010-12-02 23:58 Jonas Maebe Assigned To => Jonas Maebe
2010-12-02 23:58 Jonas Maebe Note Added: 0043906