View Issue Details

IDProjectCategoryView StatusLast Update
0018170FPCTextmode IDEpublic2010-12-17 13:00
ReporterRichard Blows Assigned ToJonas Maebe  
PrioritynormalSeveritymajorReproducibilitysometimes
Status resolvedResolutionunable to reproduce 
PlatformPCOSWindows XP 
Product Version2.4.2 
Summary0018170: Incorrect operation of Undo.
DescriptionRepeated (sequential) use of Alt+backspace, to undo program changes in the Editor, has unintended results.

The "unintended results" are the insertion of unwanted text at the site 'undone' changes.

The "unwanted text" appears to originate from the clipboard and may be previously deleted text, or it may be that some 'undos' are duplicated, resulting in a piece of text being inserted twice. I think I have seen both variants, but I cannot be sure.
Steps To ReproduceMake a series of changes to a program file and then 'undo' them by holding down 'Alt' and repeatedly pressing 'backspace'.
Additional InformationI have not tried this using the 'Undo' in the 'Edit' menu.
TagsNo tags attached.
Fixed in Revision
FPCOldBugId
FPCTarget
Attached Files

Activities

Jonas Maebe

2010-12-09 13:04

manager   ~0044123

Please describe an exact sequence of commands that reproduces this problem.

Jonas Maebe

2010-12-17 13:00

manager   ~0044294

Please reopen when you can specify the steps necessary to reproduce the problem.

Issue History

Date Modified Username Field Change
2010-12-09 12:30 Richard Blows New Issue
2010-12-09 13:04 Jonas Maebe Note Added: 0044123
2010-12-09 13:04 Jonas Maebe Status new => feedback
2010-12-17 13:00 Jonas Maebe Status feedback => resolved
2010-12-17 13:00 Jonas Maebe Resolution open => unable to reproduce
2010-12-17 13:00 Jonas Maebe Assigned To => Jonas Maebe
2010-12-17 13:00 Jonas Maebe Note Added: 0044294