View Issue Details

IDProjectCategoryView StatusLast Update
0018172LazarusLCLpublic2011-03-18 23:47
ReporterlainzAssigned ToPaul Ishenin 
PrioritynormalSeverityfeatureReproducibilityalways
Status closedResolutionfixed 
Product Version0.9.29 (SVN)Product Build 
Target Version1.0.0Fixed in Version0.9.30 
Summary0018172: TToolBar and his buttons can't set color transparent
DescriptionPlease set TToolBar and TToolButton option to set transparent color, clNone doesn't works.

The transparent option must be for TToolBar and TToolButton.

Tested bug using Themes.
TagsNo tags attached.
Fixed in Revision
LazTarget1.0
WidgetsetWin32/Win64
Attached Files

Relationships

related to 0018168 closedZeljan Rikalo TToolBar - button text color is always gray 

Activities

Vincent Snijders

2010-12-09 16:03

manager   ~0044127

Issue 18168 is for gtk2, this one for win32.

Paul Ishenin

2011-03-18 08:36

manager   ~0046657

Since 0.9.30 TToolBar has Transparent property. Please test if it is the thing you asked and close if it works for you.

lainz

2011-03-18 23:46

reporter   ~0046671

Yes this is the thing, thankyou!

Issue History

Date Modified Username Field Change
2010-12-09 14:58 lainz New Issue
2010-12-09 14:58 lainz Widgetset => Win32/Win64
2010-12-09 15:12 Zeljan Rikalo Relationship added related to 0018168
2010-12-09 16:03 Vincent Snijders Note Added: 0044127
2010-12-09 19:17 Vincent Snijders LazTarget => 1.0
2010-12-09 19:17 Vincent Snijders Status new => acknowledged
2010-12-09 19:17 Vincent Snijders Target Version => 1.0.0
2011-03-18 08:36 Paul Ishenin Status acknowledged => resolved
2011-03-18 08:36 Paul Ishenin Fixed in Version => 0.9.30
2011-03-18 08:36 Paul Ishenin Resolution open => fixed
2011-03-18 08:36 Paul Ishenin Assigned To => Paul Ishenin
2011-03-18 08:36 Paul Ishenin Note Added: 0046657
2011-03-18 23:46 lainz Note Added: 0046671
2011-03-18 23:47 lainz Status resolved => closed