View Issue Details

IDProjectCategoryView StatusLast Update
0018186LazarusConverterpublic2011-01-24 10:21
ReporterJuha ManninenAssigned ToJuha Manninen 
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
Product Version0.9.29 (SVN)Product Build 
Target VersionFixed in Version0.9.29 (SVN) 
Summary0018186: German translation for converter settings is wrong
DescriptionThe resource string names were changed a while ago but the translation is still wrong.
A patch is attached but it may be wrong, too, because of my poor German knowledge.
TagsNo tags attached.
Fixed in Revision28807
LazTarget-
Widgetset
Attached Files
  • GermanTranslation.patch (1,095 bytes)
    diff --git a/languages/lazaruside.de.po b/languages/lazaruside.de.po
    index f074315..3b80ef3 100644
    --- a/languages/lazaruside.de.po
    +++ b/languages/lazaruside.de.po
    @@ -5727,14 +5727,14 @@ msgstr ""
     #| msgid "Lazarus / LCL"
     msgctxt "lazarusidestrconsts.lisconverttargetlaz"
     msgid "Lazarus"
    -msgstr "Lazarus/LCLs"
    +msgstr "Lazarus"
     
     #: lazarusidestrconsts.lisconverttargetlazanddelphi
     #, fuzzy
     #| msgid "Lazarus / LCL for Windows only"
     msgctxt "lazarusidestrconsts.lisconverttargetlazanddelphi"
     msgid "Lazarus and Delphi"
    -msgstr "Lazarus/LCL (Windows-spezifisch)"
    +msgstr "Lazarus und Delphi"
     
     #: lazarusidestrconsts.lisconverttargetlazanddelphisamedfm
     msgctxt "lazarusidestrconsts.lisconverttargetlazanddelphisamedfm"
    @@ -5746,7 +5746,7 @@ msgstr "Lazarus und Delphi mit derselben DFM-Datei"
     #| msgid "Both Lazarus / LCL and Delphi"
     msgctxt "lazarusidestrconsts.lisconverttargetlazwinonly"
     msgid "Lazarus for Windows only"
    -msgstr "Für Lazarus/LCL und Delphi"
    +msgstr "Lazarus für bloß Windows"
     
     #: lazarusidestrconsts.lisconvfuncreplacements
     msgid "Function Replacements"
    
    GermanTranslation.patch (1,095 bytes)

Relationships

related to 0018023 closedJuha Manninen The converted fails to convert the dpr file properly if the target is LCL/Delphi 
related to 0018022 closedJuha Manninen IDE converter does not IFDEF LCLIntf, LCLType, LMessages 

Activities

2010-12-11 11:22

 

GermanTranslation.patch (1,095 bytes)
diff --git a/languages/lazaruside.de.po b/languages/lazaruside.de.po
index f074315..3b80ef3 100644
--- a/languages/lazaruside.de.po
+++ b/languages/lazaruside.de.po
@@ -5727,14 +5727,14 @@ msgstr ""
 #| msgid "Lazarus / LCL"
 msgctxt "lazarusidestrconsts.lisconverttargetlaz"
 msgid "Lazarus"
-msgstr "Lazarus/LCLs"
+msgstr "Lazarus"
 
 #: lazarusidestrconsts.lisconverttargetlazanddelphi
 #, fuzzy
 #| msgid "Lazarus / LCL for Windows only"
 msgctxt "lazarusidestrconsts.lisconverttargetlazanddelphi"
 msgid "Lazarus and Delphi"
-msgstr "Lazarus/LCL (Windows-spezifisch)"
+msgstr "Lazarus und Delphi"
 
 #: lazarusidestrconsts.lisconverttargetlazanddelphisamedfm
 msgctxt "lazarusidestrconsts.lisconverttargetlazanddelphisamedfm"
@@ -5746,7 +5746,7 @@ msgstr "Lazarus und Delphi mit derselben DFM-Datei"
 #| msgid "Both Lazarus / LCL and Delphi"
 msgctxt "lazarusidestrconsts.lisconverttargetlazwinonly"
 msgid "Lazarus for Windows only"
-msgstr "Für Lazarus/LCL und Delphi"
+msgstr "Lazarus für bloß Windows"
 
 #: lazarusidestrconsts.lisconvfuncreplacements
 msgid "Function Replacements"
GermanTranslation.patch (1,095 bytes)

Mattias Gaertner

2010-12-11 11:57

manager   ~0044167

What about the other translations?

Swen Heinig

2010-12-11 12:43

developer   ~0044169

The third modification doesn't sound good. If you could give a short description, what the 3 items stand for, I can try to find a better translation.

Juha Manninen

2010-12-11 13:13

developer   ~0044171

> The third modification doesn't sound good. If you could give a short description,
> what the 3 items stand for, I can try to find a better translation.

They are conversion targets:

'Lazarus' - The resulting code will be cross-platform Lazarus code. Delphi is not supported.
'Lazarus for Windows only' - Lazarus code again but compiles only under Windows. Windows specific unit dependencies are not touched.
'Lazarus and Delphi' - Also Delphi is supported by conditional compilation (IFDEFs).
'Lazarus and Delphi with same DFM file' - Same as above but the .DFM form file is shared between Lazarus and Delphi.


The items 2. and 3. were in a different order in LazarusIDEStrConsts.pas for technical reasons (multi-line radiogroup item order). I will change the order...

Juha Manninen

2010-12-11 13:44

developer   ~0044172

> What about the other translations?

These translations have the same problem: French (.fr.po), and .lt.po (is it Lithuania?)

I knew some languages and guessed the rest from the known words 'Lazarus' and 'Windows'.
I think I messed the strings myself when changing the meaning of 2 identifiers. Sorry for the confusion.

Mattias Gaertner

2010-12-11 13:49

manager   ~0044173

I guess, it is better to rename the identifiers.

Swen Heinig

2010-12-23 15:24

developer   ~0044523

The translation problem should be solved with revision 28807.

Juha Manninen

2010-12-23 16:13

developer   ~0044527

German translation is ok.

> I guess, it is better to rename the identifiers.

Mattias, I had renamed the original numbered string names already long ago. It seems I will later change the GUI once more because the current radiogroup can't handle all target combinations. There will be few separate controls.
The change happens sometime after the release, the current GUI is good enough for now.

Maxim Ganetsky

2010-12-27 21:34

developer   ~0044635

Shouldn't this bug be resolved? As far as I understand, it is fixed now?

Juha Manninen

2010-12-27 23:31

developer   ~0044636

I mark this as resolved now.
The 2 other languages may still have the problem but the future GUI changes will require new translations anyway.

Maxim Ganetsky

2010-12-28 01:19

developer   ~0044637

Last edited: 2010-12-28 01:19

I removed incorrect strings from French and Lithuanian translations in r28828.

Issue History

Date Modified Username Field Change
2010-12-11 11:22 Juha Manninen New Issue
2010-12-11 11:22 Juha Manninen Status new => assigned
2010-12-11 11:22 Juha Manninen Assigned To => Juha Manninen
2010-12-11 11:22 Juha Manninen File Added: GermanTranslation.patch
2010-12-11 11:22 Juha Manninen LazTarget => -
2010-12-11 11:28 Juha Manninen Assigned To Juha Manninen =>
2010-12-11 11:32 Juha Manninen Relationship added related to 0018023
2010-12-11 11:32 Juha Manninen Relationship added related to 0017925
2010-12-11 11:33 Juha Manninen Relationship deleted related to 0017925
2010-12-11 11:41 Juha Manninen Relationship added related to 0018022
2010-12-11 11:57 Mattias Gaertner Note Added: 0044167
2010-12-11 12:43 Swen Heinig Note Added: 0044169
2010-12-11 13:13 Juha Manninen Note Added: 0044171
2010-12-11 13:44 Juha Manninen Note Added: 0044172
2010-12-11 13:49 Mattias Gaertner Note Added: 0044173
2010-12-23 15:24 Swen Heinig Note Added: 0044523
2010-12-23 16:13 Juha Manninen Note Added: 0044527
2010-12-27 21:34 Maxim Ganetsky Note Added: 0044635
2010-12-27 21:34 Maxim Ganetsky Status assigned => feedback
2010-12-27 23:31 Juha Manninen Fixed in Revision => 28807
2010-12-27 23:31 Juha Manninen Status feedback => resolved
2010-12-27 23:31 Juha Manninen Resolution open => fixed
2010-12-27 23:31 Juha Manninen Assigned To => Juha Manninen
2010-12-27 23:31 Juha Manninen Note Added: 0044636
2010-12-28 01:19 Maxim Ganetsky Note Added: 0044637
2010-12-28 01:19 Maxim Ganetsky Note Edited: 0044637
2011-01-08 09:06 Juha Manninen Status resolved => closed
2011-01-24 10:21 Vincent Snijders Fixed in Version => 0.9.29 (SVN)