View Issue Details

IDProjectCategoryView StatusLast Update
0018254LazarusLCLpublic2011-04-15 10:07
ReporterJosé MejutoAssigned ToPaul Ishenin 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Platformi386OSWindowsOS VersionXP SP3
Product Version0.9.29 (SVN)Product Build28704 
Target VersionFixed in Version0.9.31 (SVN) 
Summary0018254: TSplitter erratic behaviour in horizontal
DescriptionTrying to set a TSplitter in horizontal exhibits an erratic behaviour. Setting resize anchor to "top" does nothing, unless aligning to altop, once done the split grip is painted vertically, instead horizontally. To paint it horizontally it must be "Resize anchor" to "akLeft" but Align is changed to alNone :-?
Steps To ReproduceDrop two panels in a form, Panel1 align to alTop and panel2 align to alClient and try to put an TSplitter in horizontal to split both panels.
Additional InformationLooks like a wrong alignment selection in response to changing "ResizeAnchor". Only tested in Win32 but due the error behavior it should be wrong in all platforms.
TagsNo tags attached.
Fixed in Revision30167
LazTarget0.99.0
WidgetsetWin32/Win64
Attached Files

Activities

Paul Ishenin

2011-04-04 08:18

manager   ~0047162

Tested what you wrote.

If you put splitter between 2 panels (alTop + alClient) then set splitter align to alTop too. When you set resize anchor align will change alNone - this is by design. Use either align for aligned splitter or resize anchor for anchored splitter.

I only noticed that gripper does not redraw on resize anchor change.

Please close if ok. If not then please attach an example which demostrates the problem.

Issue History

Date Modified Username Field Change
2010-12-18 14:01 José Mejuto New Issue
2010-12-18 14:01 José Mejuto Widgetset => Win32/Win64
2010-12-18 22:17 Vincent Snijders LazTarget => 1.0
2010-12-18 22:17 Vincent Snijders Status new => acknowledged
2010-12-18 22:17 Vincent Snijders Target Version => 1.0.0
2011-04-04 05:35 Paul Ishenin LazTarget 1.0 => 0.99.0
2011-04-04 05:38 Paul Ishenin Target Version 1.0.0 => 0.99.0
2011-04-04 08:18 Paul Ishenin Fixed in Revision => 30167
2011-04-04 08:18 Paul Ishenin Status acknowledged => resolved
2011-04-04 08:18 Paul Ishenin Fixed in Version => 0.9.31 (SVN)
2011-04-04 08:18 Paul Ishenin Resolution open => fixed
2011-04-04 08:18 Paul Ishenin Assigned To => Paul Ishenin
2011-04-04 08:18 Paul Ishenin Note Added: 0047162
2011-04-15 10:07 José Mejuto Status resolved => closed