View Issue Details

IDProjectCategoryView StatusLast Update
0018273LazarusIDEpublic2011-12-01 11:25
ReporterPhilAssigned ToDmitry Boyarintsev 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionfixed 
PlatformMacOSOS XOS Version10.6
Product Version0.9.29 (SVN)Product Build28764 
Target Version0.9.30Fixed in Version0.9.29 (SVN) 
Summary0018273: Missing fonts on Carbon, etc.
DescriptionFont Name property list is missing important fonts like Arial, Courier New, Times New Roman. Instead "font" names "A", "C", "T" appear in the list. Bringing up the Fonts dialog and selecting one of these missing fonts then selects the corresponding "A", etc. font but does not set it in form designer ("A", etc. is not a valid font name).

Laz 0.9.28.3 does not have this problem so it's an obvious regression.

Also, even when valid fonts are selected from Name list (Times), I see errors in the Console:

FindCarbonFontID Error: ATSUFindFontFromName failed with result -8796


Also, please change FindCarbonFontID OSError call so last line looks like this:

      'FindCarbonFontID', 'ATSUFindFontFromName', fn);

That way we can actually see the name of the font that failed. This is important because font names are case sensitive on Mac, etc.

That's how I discovered that even valid font names are sometimes failing in IDE:

FindCarbonFontID Error: ATSUFindFontFromName Times failed with result -8796


Also, when property editor first comes up, drop down arrows and buttons at right side of property is not visible - requires resizing of property editor to see them. I believe this is a fairly recent regression.

Thanks.

-Phil
TagsNo tags attached.
Fixed in Revision28824
LazTarget0.9.30
WidgetsetCarbon
Attached Files

Relationships

related to 0017485 closedDmitry Boyarintsev Changing Font.size as no effect on Mac OS X 

Activities

Dmitry Boyarintsev

2010-12-27 02:55

developer   ~0044613

please test and close if ok

Issue History

Date Modified Username Field Change
2010-12-20 00:04 Phil New Issue
2010-12-20 00:04 Phil Widgetset => Carbon
2010-12-20 10:03 Vincent Snijders LazTarget => 0.9.30
2010-12-20 10:03 Vincent Snijders Assigned To => Dmitry Boyarintsev
2010-12-20 10:03 Vincent Snijders Status new => assigned
2010-12-20 10:03 Vincent Snijders Target Version => 0.9.30
2010-12-27 02:55 Dmitry Boyarintsev Fixed in Revision => 28824
2010-12-27 02:55 Dmitry Boyarintsev Status assigned => resolved
2010-12-27 02:55 Dmitry Boyarintsev Resolution open => fixed
2010-12-27 02:55 Dmitry Boyarintsev Note Added: 0044613
2010-12-27 13:40 Vincent Snijders Fixed in Version => 0.9.29 (SVN)
2010-12-29 20:48 Vincent Snijders Relationship added related to 0017485
2011-12-01 11:25 Marc Weustink Status resolved => closed