View Issue Details

IDProjectCategoryView StatusLast Update
0018301FPCCompilerpublic2010-12-23 16:31
ReporterJeppe Johansen Assigned ToJonas Maebe  
PrioritynormalSeverityfeatureReproducibilitysometimes
Status resolvedResolutionno change required 
PlatformARMOSLinux 
Product Version2.5.1 
Summary0018301: Adding a way to specify the EABI version when compiling for ARM-Linux
DescriptionWhen compiling anything for ARM-Linux with ABI set to EABI it automatically defaults to version 0, whereas some versions of Linux use version 4 or 5

A workaround is to make a hardcoded shellscript or program replacement for as, that adds a -meabi=5 to the commandline passed to AS

It would be easier if you could supply the target eabi version by the commandline in fpc. Either by adding new ABI targets(eabi4, eabi5, etc), or a new commandline option
TagsNo tags attached.
Fixed in Revision
FPCOldBugId
FPCTarget
Attached Files

Activities

Jonas Maebe

2010-12-23 12:04

manager   ~0044518

On our Tegra board, object files binaries compiled with FPC automatically get eabi version 4 without specifying any options to the assembler or linker. Are you using a self-compiled toolchain whose default eabi version is 0 or so?

Jeppe Johansen

2010-12-23 12:12

developer   ~0044519

I have indeed built it myself, from binutils 2.20 for target "arm-linux"

Jonas Maebe

2010-12-23 12:54

manager   ~0044520

You should then probably configure it so that it uses the correct default eabi version for your target platform.

Jonas Maebe

2010-12-23 12:55

manager   ~0044521

PS: I don't know myself how to do that.

Marco van de Voort

2010-12-23 16:31

manager   ~0044528

Last edited: 2010-12-23 16:33

Afaik target arm-none-linux-gnueabi is meabi 5, and arm-none-linux-eabi is 4, but I haven't had time to verify this.

Since a binutils snapshot under mingw builds for more than an hour, an option for this would not be bad. (since making 3-5 versions is a bit painful this way)

Issue History

Date Modified Username Field Change
2010-12-23 11:56 Jeppe Johansen New Issue
2010-12-23 12:04 Jonas Maebe Note Added: 0044518
2010-12-23 12:12 Jeppe Johansen Note Added: 0044519
2010-12-23 12:54 Jonas Maebe Status new => resolved
2010-12-23 12:54 Jonas Maebe Resolution open => no change required
2010-12-23 12:54 Jonas Maebe Assigned To => Jonas Maebe
2010-12-23 12:54 Jonas Maebe Note Added: 0044520
2010-12-23 12:55 Jonas Maebe Note Added: 0044521
2010-12-23 16:31 Marco van de Voort Note Added: 0044528
2010-12-23 16:32 Marco van de Voort Note Edited: 0044528
2010-12-23 16:33 Marco van de Voort Note Edited: 0044528