View Issue Details

IDProjectCategoryView StatusLast Update
0018341LazarusOtherpublic2011-02-28 22:05
ReporterMario BonatiAssigned ToVincent Snijders 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionfixed 
PlatformLinuxOSUbuntuOS Version10.10
Product Version0.9.29 (SVN)Product BuildLazarus 0.9.29 r28730M FPC 2.4.2 
Target Version1.0.0Fixed in Version0.9.31 (SVN) 
Summary0018341: lazbuild loses "../" in "(-Fu) parameters"
DescriptionHi,
in a project, i have iin "-Fu" option this:

..;../____Componenti/Ftp/Synapse/source/lib;../____Componenti/ZVDateTimeCtrls


Compiling this project with "lazbuild", this is the output:

bonmario@bonmario-desktop:/tmp$ /usr/lib/lazarus/lazbuild /media/sda1/Pascal/LazarusLavoro/CercaInOoo_Pdf/CercaInOoo_Pdf.lpiTCompiler.Compile WorkingDir="/media/sda1/Pascal/LazarusLavoro/CercaInOoo_Pdf/" CompilerFilename="/usr/bin/fpc" CompilerParams=" -MObjFPC -Scgi -O1 -gl -WG -vewnhi -l -Fu. -Fu../____Componenti/fparchive-0.1 -Fu../____Componenti/Ftp/Synapse/source/lib -Fu../____Componenti/ZVDateTimeCtrls -Fu/usr/lib/lazarus/components/printers/lib/i386-linux/gtk2 -Fu/usr/lib/lazarus/lcl/units/i386-linux -Fu/usr/lib/lazarus/lcl/units/i386-linux/gtk2 -Fu/usr/lib/lazarus/packager/units/i386-linux -oCercaInOoo_Pdf -dLCL -dLCLgtk2 CercaInOoo_Pdf.lpr"
[TCompiler.Compile] CmdLine="/usr/bin/fpc -MObjFPC -Scgi -O1 -gl -WG -vewnhi -l -Fu. -Fu../____Componenti/fparchive-0.1 -Fu../____Componenti/Ftp/Synapse/source/lib -Fu../____Componenti/ZVDateTimeCtrls -Fu/usr/lib/lazarus/components/printers/lib/i386-linux/gtk2 -Fu/usr/lib/lazarus/lcl/units/i386-linux -Fu/usr/lib/lazarus/lcl/units/i386-linux/gtk2 -Fu/usr/lib/lazarus/packager/units/i386-linux -oCercaInOoo_Pdf -dLCL -dLCLgtk2 CercaInOoo_Pdf.lpr"
Hint: Start of reading config file /etc/fpc.cfg
Hint: End of reading config file /etc/fpc.cfg
Free Pascal Compiler version 2.4.2-0 [2010/11/11] for i386
Copyright (c) 1993-2010 by Florian Klaempfl
Target OS: Linux for i386
Compiling CercaInOoo_Pdf.lpr
Compiling CercaInOoo_Pdf_Unit.pas
Fatal: Can't find unit BonMarZip used by CercaInOoo_Pdf_Unit
ERROR: failed compiling of project /media/sda1/Pascal/LazarusLavoro/CercaInOoo_Pdf/CercaInOoo_Pdf.lpi
bonmario@bonmario-desktop:/tmp$


The problem is that lazbuild loses the ".." at the begin of mine parameters
TagsNo tags attached.
Fixed in Revision
LazTarget1.0
WidgetsetGTK 2
Attached Files

Activities

Vincent Snijders

2010-12-30 08:52

manager   ~0044700

Please, attach an example project (with sources) that demonstrates this project.

2010-12-30 20:48

 

Prova1.tar.bz2 (79,602 bytes)

Mario Bonati

2010-12-30 20:49

reporter   ~0044736

I've uploaded it.
I compile the project form ide.
With the command "lazbuild" i have this error:

bonmario@bonmario-desktop:~$ cd /media/sda1/Pascal/LazarusCasa/Prove/Prova1/Prova2
bonmario@bonmario-desktop:/media/sda1/Pascal/LazarusCasa/Prove/Prova1/Prova2$ /usr/lib/lazarus/lazbuild project1.lpi
TCompiler.Compile WorkingDir="/media/sda1/Pascal/LazarusCasa/Prove/Prova1/Prova2/" CompilerFilename="/usr/bin/fpc" CompilerParams=" -MObjFPC -Scghi -O1 -gl -WG -vewnhi -l -Filib/i386-linux -Fu. -Fu/usr/lib/lazarus/lcl/units/i386-linux -Fu/usr/lib/lazarus/lcl/units/i386-linux/gtk2 -Fu/usr/lib/lazarus/packager/units/i386-linux -FUlib/i386-linux/ -oproject1 -dLCL -dLCLgtk2 project1.lpr"
[TCompiler.Compile] CmdLine="/usr/bin/fpc -MObjFPC -Scghi -O1 -gl -WG -vewnhi -l -Filib/i386-linux -Fu. -Fu/usr/lib/lazarus/lcl/units/i386-linux -Fu/usr/lib/lazarus/lcl/units/i386-linux/gtk2 -Fu/usr/lib/lazarus/packager/units/i386-linux -FUlib/i386-linux/ -oproject1 -dLCL -dLCLgtk2 project1.lpr"
Hint: Start of reading config file /etc/fpc.cfg
Hint: End of reading config file /etc/fpc.cfg
Free Pascal Compiler version 2.4.2-0 [2010/11/11] for i386
Copyright (c) 1993-2010 by Florian Klaempfl
Target OS: Linux for i386
Compiling project1.lpr
Compiling Unit1.pas
Fatal: Can't find unit Unit2 used by Unit1
ERROR: failed compiling of project /media/sda1/Pascal/LazarusCasa/Prove/Prova1/Prova2/project1.lpi
bonmario@bonmario-desktop:/media/sda1/Pascal/LazarusCasa/Prove/Prova1/Prova2$



Thanks, Mario

Mario Bonati

2011-02-28 20:48

reporter   ~0046315

Seem fixed in meantime.
Now i have Lazarus 0.9.31 r29692 FPC 2.4.2 x86_64-linux-gtk 2 and it works fine.

Hi, Mario

Issue History

Date Modified Username Field Change
2010-12-29 22:23 Mario Bonati New Issue
2010-12-29 22:23 Mario Bonati Widgetset => GTK 2
2010-12-30 08:52 Vincent Snijders LazTarget => -
2010-12-30 08:52 Vincent Snijders Note Added: 0044700
2010-12-30 08:52 Vincent Snijders Status new => feedback
2010-12-30 20:48 Mario Bonati File Added: Prova1.tar.bz2
2010-12-30 20:49 Mario Bonati Note Added: 0044736
2010-12-31 12:28 Vincent Snijders LazTarget - => 1.0
2010-12-31 12:28 Vincent Snijders Status feedback => acknowledged
2010-12-31 12:28 Vincent Snijders Target Version => 1.0.0
2011-02-28 20:48 Mario Bonati Note Added: 0046315
2011-02-28 21:10 Vincent Snijders Status acknowledged => resolved
2011-02-28 21:10 Vincent Snijders Fixed in Version => 0.9.31 (SVN)
2011-02-28 21:10 Vincent Snijders Resolution open => fixed
2011-02-28 21:10 Vincent Snijders Assigned To => Vincent Snijders
2011-02-28 22:05 Mario Bonati Status resolved => closed