View Issue Details

IDProjectCategoryView StatusLast Update
0018375LazarusLCLpublic2011-12-01 11:25
ReporterKjowAssigned ToFelipe Monteiro de Carvalho 
PriorityhighSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Product Version0.9.31 (SVN)Product Build 
Target VersionFixed in Version0.9.31 (SVN) 
Summary0018375: Compiling error on "Clean Up + Build all"
DescriptionI noticed that this problem is present only when I do a "Clean Up Buils all".
With "Build all" only, everything works fine.

Revisions.

Lazarus: 28857M
FPC 2.5.1: 16691

...
...
...
Compiling messagedialogs.pp
Compiling resource units\i386-win32\messagedialogs.or
Linking .\messagedialogs.exe
85 lines compiled, 0.7 sec , 1200960 bytes code, 287208 bytes data
C:/Develop/fpc/2.4.2/bin/i386-Win32/fpc.exe -gl
-Fu../lcl/units/i386-win32 -Fu../lcl/units/i386-win32/win32
-Fu../components/synedit/units/i386-win32
-Fu../components/codetools/units/i386-win32 -Fu. -FE.
-FUunits/i386-win32 -di386 notebk.pp
Free Pascal Compiler version 2.5.1 [2011/01/02] for i386
Copyright (c) 1993-2010 by Florian Klaempfl
Target OS: Win32 for i386
Compiling notebk.pp
Compiling notebku.pp
C:\Develop\lazarus\examples\notebku.pp(87,19) Error: Identifier not
found "PageCount"
C:\Develop\lazarus\examples\notebku.pp(104,19) Error: Identifier not
found "PageCount"
C:\Develop\lazarus\examples\notebku.pp(304,13) Error: identifier
idents no member "ShowTabs"
C:\Develop\lazarus\examples\notebku.pp(304,39) Error: identifier
idents no member "ShowTabs"
C:\Develop\lazarus\examples\notebku.pp(305,17) Error: identifier
idents no member "ShowTabs"
C:\Develop\lazarus\examples\notebku.pp(330,16) Error: identifier
idents no member "TabPosition"
C:\Develop\lazarus\examples\notebku.pp(331,16) Error: identifier
idents no member "TabPosition"
C:\Develop\lazarus\examples\notebku.pp(332,21) Error: identifier
idents no member "TabPosition"
C:\Develop\lazarus\examples\notebku.pp(333,16) Error: identifier
idents no member "TabPosition"
C:\Develop\lazarus\examples\notebku.pp(334,21) Error: identifier
idents no member "TabPosition"
C:\Develop\lazarus\examples\notebku.pp(335,16) Error: identifier
idents no member "TabPosition"
C:\Develop\lazarus\examples\notebku.pp(336,21) Error: identifier
idents no member "TabPosition"
C:\Develop\lazarus\examples\notebku.pp(337,16) Error: identifier
idents no member "TabPosition"
C:\Develop\lazarus\examples\notebku.pp(343) Fatal: There were 13
errors compiling module, stopping
Additional InformationDon't care about path / FPC version mismatch, it's a misprint.
TagsNo tags attached.
Fixed in Revision28916
LazTarget0.99.0
WidgetsetWin32/Win64
Attached Files

Activities

Vincent Snijders

2011-01-03 12:27

manager   ~0044824

Probably introduced by http://svn.freepascal.org/cgi-bin/viewvc.cgi?view=rev&root=lazarus&revision=28850

The example needs to be adapted to the new situation.

Martin Friebe

2011-01-03 16:53

manager   ~0044839

This also affect the SynUni package. Install SynUni and rebuild IDE and packages

Vincent Snijders

2011-01-04 08:37

manager   ~0044854

Raised priority to high, because it blocks the building of deb snapshots.

Issue History

Date Modified Username Field Change
2011-01-03 12:12 Kjow New Issue
2011-01-03 12:12 Kjow Widgetset => Win32/Win64
2011-01-03 12:27 Vincent Snijders LazTarget => 0.99.0
2011-01-03 12:27 Vincent Snijders Note Added: 0044824
2011-01-03 12:27 Vincent Snijders Assigned To => Felipe Monteiro de Carvalho
2011-01-03 12:27 Vincent Snijders Status new => assigned
2011-01-03 12:27 Vincent Snijders Target Version => 0.99.0
2011-01-03 16:53 Martin Friebe Note Added: 0044839
2011-01-04 08:37 Vincent Snijders Note Added: 0044854
2011-01-04 08:37 Vincent Snijders Priority normal => high
2011-01-09 12:05 Felipe Monteiro de Carvalho Fixed in Revision => 28916
2011-01-09 12:05 Felipe Monteiro de Carvalho Status assigned => resolved
2011-01-09 12:05 Felipe Monteiro de Carvalho Fixed in Version => 0.9.31 (SVN)
2011-01-09 12:05 Felipe Monteiro de Carvalho Resolution open => fixed
2011-12-01 11:25 Marc Weustink Status resolved => closed