View Issue Details

IDProjectCategoryView StatusLast Update
0018396LazarusIDEpublic2011-12-01 11:26
ReporterGraeme GeldenhuysAssigned ToVincent Snijders 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Platformx86_64OSUbuntu LinuxOS Version10.04
Product Version0.9.31 (SVN)Product Build 
Target Version0.9.30Fixed in Version0.9.29 (SVN) 
Summary0018396: Lazarus IDE creates lots of empty config dirs
DescriptionWanting to test the 0.9.30 branch, I wanted to make a copy of my current
~/.config/lazarus/ directory. That's when I noticed lots and lots of
directories similar to what is shown below. All these directories are empty.

 $ ls -l ~/.config/

---8<-----------8<-----------8<-----------8<-----------8<-----------
drwxr-xr-x 2 2010-11-08 14:55 Lazarus IDE v0.9.29
drwxr-xr-x 2 2010-11-24 09:23 Lazarus IDE v0.9.29 - dunit2_fpc_textrunner.lpi
drwxr-xr-x 2 2011-01-03 12:11 Lazarus IDE v0.9.29 - project1.lpi
drwxr-xr-x 2 2010-11-11 11:51 Lazarus IDE v0.9.29 - tutoradmin.lpi
drwxr-xr-x 2 2010-11-09 15:31 project1.lpi - Lazarus IDE v0.9.29
drwxr-xr-x 2 2010-11-11 10:03 tutoradmin.lpi - Lazarus IDE v0.9.29
...
---8<-----------8<-----------8<-----------8<-----------8<-----------


* Why are they there?
* Why are they empty?
* Why the ugly directory names? (using project filenames as directory names)

I'm using Lazarus under 64-bit Ubuntu 10.04.

TagsNo tags attached.
Fixed in Revision28874,29096
LazTarget0.9.30
Widgetset
Attached Files

Activities

Vincent Snijders

2011-01-05 15:30

manager   ~0044910

I have some idea where to look.

The directory names look like Main bar caption. Application.Title of Lazarus is set to the main bar caption in main.pp, maybe so that task bar buttons can show it as hint.

The LCL uses Application.Title as input for OnGetApplicationName callback. This callback is used by GetAppConfigDir to get the last part of that path.

GetAppConfigDir is used in THelpForm.GetPreferences, and probably in other places in the IDE too.

Vincent Snijders

2011-01-05 15:48

manager   ~0044911

Last edited: 2011-01-05 15:49

Caused by http://svn.freepascal.org/cgi-bin/viewvc.cgi?diff_format=l&view=rev&root=lazarus&revision=23189, so a regression.

Issue History

Date Modified Username Field Change
2011-01-05 09:33 Graeme Geldenhuys New Issue
2011-01-05 09:45 Vincent Snijders LazTarget => 0.99.0
2011-01-05 09:45 Vincent Snijders Status new => acknowledged
2011-01-05 09:45 Vincent Snijders Target Version => 0.99.0
2011-01-05 15:30 Vincent Snijders Note Added: 0044910
2011-01-05 15:48 Vincent Snijders Note Added: 0044911
2011-01-05 15:49 Vincent Snijders Note Edited: 0044911
2011-01-05 15:49 Vincent Snijders LazTarget 0.99.0 => 0.9.30
2011-01-05 15:49 Vincent Snijders Target Version 0.99.0 => 0.9.30
2011-01-06 15:18 Vincent Snijders Status acknowledged => assigned
2011-01-06 15:18 Vincent Snijders Assigned To => Vincent Snijders
2011-01-06 16:43 Vincent Snijders Fixed in Revision => 28874
2011-01-06 16:43 Vincent Snijders Status assigned => resolved
2011-01-06 16:43 Vincent Snijders Fixed in Version => 0.9.31 (SVN)
2011-01-06 16:43 Vincent Snijders Resolution open => fixed
2011-01-23 21:29 Vincent Snijders Fixed in Revision 28874 => 28874,29096
2011-01-23 21:29 Vincent Snijders Fixed in Version 0.9.31 (SVN) => 0.9.29 (SVN)
2011-12-01 11:26 Marc Weustink Status resolved => closed