View Issue Details

IDProjectCategoryView StatusLast Update
0018406LazarusIDEpublic2011-10-20 19:12
ReporterJosé Luís B. M. da Cruz Assigned ToJuha Manninen  
PrioritynormalSeveritycrashReproducibilityalways
Status resolvedResolutionunable to reproduce 
Product Version0.9.31 (SVN) 
Target Version1.0.0 
Summary0018406: IDE crashes with package AnchorDockingDsgn installed
DescriptionThe IDE becames unusable at start and crashes. Terminal log:

joseluis@cruz-notebook:~/lazarus$ ./startlazarus
TLazarusManager.Run starting /home/joseluis/lazarus/lazarus ...
TMainIDE.ParseCmdLineOptions:
  PrimaryConfigPath="/home/joseluis/.lazarus"
  SecondaryConfigPath="/etc/lazarus"
TIDEAnchorDockMaster.MakeIDEWindowDockSite MainIDE:TMainIDEBar
TIDEAnchorDockMaster.LoadUserLayout anchordocklayout.xml
TIDEAnchorDockMaster.LoadUserLayout loading default layout ...
TMainIDE.DoNewProject A
TIDEAnchorDockMaster.ShowForm AControl=ObjectInspectorDlg:TObjectInspectorDlg NeedPlacing=True Floating=True
TIDEAnchorDockMaster.ShowForm placing ObjectInspectorDlg:TObjectInspectorDlg ...
TIDEAnchorDockMaster.ShowForm creator for ObjectInspectorDlg:TObjectInspectorDlg found: Left=0 Top=120 Right=+230 Bottom=-120 DockSiblingName= DockAlign=alNone l=0,t=26,r=230,b=650
TIDEAnchorDockMaster.ShowForm MakeVisible ObjectInspectorDlg:TObjectInspectorDlg l=0,t=0,r=275,b=669 Floating=True
TApplication.HandleException TControl.ChangeBounds loop detected AnchorDockSplitter2:TAnchorDockSplitter Left=0,Top=10873,Width=1025,Height=4 NewLeft=0,NewTop=76409,NewWidth=1025,NewHeight=4
  Stack trace:
  $00000000008B4E38 line 343 of include/control.inc
  $00000000008B4829 line 368 of include/control.inc
  $00000000008BB532 line 3207 of include/control.inc
  $00000000008B22FD line 7829 of include/wincontrol.inc
  $00000000011ABFCF line 5168 of anchordocking.pas
  $00000000011A4006 line 3532 of anchordocking.pas
  $00000000008AE22F line 6195 of include/wincontrol.inc
  $00000000008B9593 line 2407 of include/control.inc
  $00000000008B95CF line 2409 of include/control.inc
  $00000000008B92E4 line 2452 of include/control.inc
  $00000000008A8121 line 3476 of include/wincontrol.inc
  $00000000008C030C line 4842 of include/control.inc
  $00000000008B230B line 7832 of include/wincontrol.inc
  $00000000008AF618 line 6810 of include/wincontrol.inc
  $0000000000701B00 line 678 of include/customform.inc
  $00000000006E7625
  $00000000008AC118 line 5241 of include/wincontrol.inc
TWinControl.DoRemoveDockClient MainIDE:TMainIDEBar AnchorDockSite4:TAnchorDockHostSite
TApplication.HandleException: there was another exception during showing the first exception
  Stack trace:
  $00000000008B4E38 line 343 of include/control.inc
  $00000000008B4829 line 368 of include/control.inc
  $00000000008BB532 line 3207 of include/control.inc
  $00000000008B22FD line 7829 of include/wincontrol.inc
  $00000000011ABFCF line 5168 of anchordocking.pas
  $00000000011A4006 line 3532 of anchordocking.pas
  $00000000008AE22F line 6195 of include/wincontrol.inc
  $00000000008B9593 line 2407 of include/control.inc
  $00000000008B92E4 line 2452 of include/control.inc
  $00000000008A8121 line 3476 of include/wincontrol.inc
  $00000000008C030C line 4842 of include/control.inc
  $00000000008BD3C2 line 3879 of include/control.inc
  $00000000007077F5 line 2764 of include/customform.inc
  $00000000008BC58B line 3504 of include/control.inc
  $00000000008AE877 line 6367 of include/wincontrol.inc
  $00000000008C0D68 line 60 of include/customcontrol.inc
  $00000000006FF850 line 260 of include/scrollingwincontrol.inc
TAnchorDockMaster.Destroy: still in list: ObjectInspectorDlg:TObjectInspectorDlg Caption="Object Inspector"
TAnchorDockMaster.Destroy: still in list: CodeExplorerView:TCodeExplorerView Caption="Code Explorer"
TAnchorDockMaster.Destroy: still in list: MessagesView:TMessagesView Caption="Messages"
TAnchorDockMaster.Destroy: still in list: SourceNotebook:TSourceNotebook Caption="Source Editor"
TAnchorDockMaster.Destroy: still in list: MainIDE:TMainIDEBar Caption="Lazarus IDE v0.9.31 - project1"
TAnchorDockMaster.Destroy 0/8 AnchorDockSite1:TAnchorDockHostSite
TAnchorDockMaster.Destroy 1/8 AnchorDockSite2:TAnchorDockHostSite
TAnchorDockMaster.Destroy 2/8 AnchorDockSite3:TAnchorDockHostSite
TAnchorDockMaster.Destroy 3/8 AnchorDockSite4:TAnchorDockHostSite
TAnchorDockMaster.Destroy 4/8 AnchorDockSplitter1:TAnchorDockSplitter
TAnchorDockMaster.Destroy 5/8 AnchorDockSplitter2:TAnchorDockSplitter
TAnchorDockMaster.Destroy 6/8 AnchorDockSplitter3:TAnchorDockSplitter
TAnchorDockMaster.Destroy 7/8 AnchorDockSite5:TAnchorDockHostSite
[TMainIDE.Destroy] A
lazarus.pp - unhandled exception
joseluis@cruz-notebook:~/lazarus$

This only happens on my notebook. Error picture attached.
TagsNo tags attached.
Fixed in Revision
LazTarget1.0
WidgetsetGTK 2
Attached Files

Relationships

related to 0018977 closedJuha Manninen The form position in Delphi2006 style Lazarus IDE is not right. 

Activities

2011-01-06 00:21

 

erro_lazarus.png (191,508 bytes)   
erro_lazarus.png (191,508 bytes)   

thierrybo

2011-04-26 23:08

reporter   ~0047818

Same error with 0.9.30.1 (branch 0.9.30_fixes)
Ubuntu 10.10 64 bits

Flávio Etrusco

2011-08-09 01:07

developer   ~0050626

I guess it would be important to have the layout file, please attach it.
It's in ~/.lazarus/anchordocklayout.xml.

Juha Manninen

2011-10-08 16:59

developer   ~0052780

Is this still valid? I can't reproduce.

José Luís B. M. da Cruz

2011-10-20 17:15

reporter   ~0053212

The problem is not happening anymore. Tested SVN 32987.

Juha Manninen

2011-10-20 19:11

developer   ~0053214

Fixed in meanwhile.

Issue History

Date Modified Username Field Change
2011-01-06 00:21 José Luís B. M. da Cruz New Issue
2011-01-06 00:21 José Luís B. M. da Cruz File Added: erro_lazarus.png
2011-01-06 00:21 José Luís B. M. da Cruz Widgetset => GTK 2
2011-01-10 11:09 Vincent Snijders LazTarget => 1.0
2011-01-10 11:09 Vincent Snijders Assigned To => Mattias Gaertner
2011-01-10 11:09 Vincent Snijders Status new => acknowledged
2011-01-10 11:09 Vincent Snijders Target Version => 1.0.0
2011-03-24 11:28 Juha Manninen Relationship added related to 0018977
2011-04-26 23:08 thierrybo Note Added: 0047818
2011-08-09 01:07 Flávio Etrusco Note Added: 0050626
2011-10-08 16:58 Juha Manninen Status acknowledged => assigned
2011-10-08 16:58 Juha Manninen Assigned To Mattias Gaertner => Juha Manninen
2011-10-08 16:59 Juha Manninen Note Added: 0052780
2011-10-08 16:59 Juha Manninen Status assigned => feedback
2011-10-20 17:15 José Luís B. M. da Cruz Note Added: 0053212
2011-10-20 19:11 Juha Manninen Status feedback => resolved
2011-10-20 19:11 Juha Manninen Resolution open => unable to reproduce
2011-10-20 19:11 Juha Manninen Note Added: 0053214