View Issue Details

IDProjectCategoryView StatusLast Update
0018433FPCCompilerpublic2011-01-08 13:14
ReporterDelphi-Laie Assigned ToJonas Maebe  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionduplicate 
Platform64 BitOSWindows 
Product Version2.4.3 
Summary0018433: function GetProcessAffinityMask hasn got not real correct type declarations
DescriptionFirstly, is it not the here offered highest product version number 2.4.3 but 2.5.1 of fpc. This compiler doesn't know the real correct types of function GetProcessAffinityMask namly ProcessAffinityMask,SystemAffinityMask:DWORD_PTR but only longword.

With my 32 bit lazarus with fpc version number 2.2.4 I haven't got this problem, this fp compiler knows the correct DWORD_PTR declarations of this function.

But I can help myself temporarly with a "manual" external function call in the source code. This does function in lazarus/fpc 64 bit for windows.

Greetings and regards

Delphi-Laie
TagsNo tags attached.
Fixed in Revision
FPCOldBugId
FPCTarget
Attached Files

Relationships

duplicate of 0018434 closedMarco van de Voort function GetProcessAffinityMask hasn't got real correct type declarations 

Activities

There are no notes attached to this issue.

Issue History

Date Modified Username Field Change
2011-01-08 12:52 Delphi-Laie New Issue
2011-01-08 13:14 Jonas Maebe Relationship added duplicate of 0018434
2011-01-08 13:14 Jonas Maebe Duplicate ID 0 => 18434
2011-01-08 13:14 Jonas Maebe Status new => resolved
2011-01-08 13:14 Jonas Maebe Resolution open => duplicate
2011-01-08 13:14 Jonas Maebe Assigned To => Jonas Maebe