View Issue Details

IDProjectCategoryView StatusLast Update
0001845LazarusWidgetsetpublic2017-10-23 10:04
ReporterPhil Assigned ToLuiz Americo  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformMacOSOS X 
Product Version0.9.13 (SVN) 
Summary0001845: GTK doesn't handle Spacing = -1 with buttons
DescriptionDelphi and Laz IDE's allow -1 for Spacing property of TBitBtn.

GTK widgetset doesn't handle this value properly.

Get warning:

gtk_widget_size_allocate attempt to allocate widget ht 65535

Top half of button text is missing.

TagsNo tags attached.
Fixed in Revision
LazTarget-
WidgetsetGTK
Attached Files

Relationships

related to 0016071 closedLuiz Americo TBitBtn: 'Margin' from 1 to -1 will not refresh button with glyph immediately. 

Activities

Matthijs Willemstein

2006-03-10 09:07

reporter   ~0002371

Warning not noticed. Bottom half of caption is missing.

Marelis

2010-12-08 14:32

reporter   ~0044097

It's a bit off, but maybe it could be taken at one go:

http://bugs.freepascal.org/view.php?id=16071

This does not work in SVN revision 28588.

Thanks.

Luiz Americo

2010-12-08 14:39

developer   ~0044098

The half caption issue is fixed in 28647.
The bug should be kept open because still does not handle Spacing = -1 like in Delphi

Juha Manninen

2017-10-23 10:04

developer   ~0103711

I don't get any warnings when I get Spacing = -1 for a TBitBtn.
I guess it was fixed in GTK2 at some point.
Please test.

Issue History

Date Modified Username Field Change
2006-03-07 09:58 Phil New Issue
2006-03-07 09:58 Phil Widgetset => GTK
2006-03-10 09:07 Matthijs Willemstein Target => post 1.0
2006-03-10 09:07 Matthijs Willemstein Note Added: 0002371
2006-03-10 09:07 Matthijs Willemstein Status new => acknowledged
2010-12-08 14:12 Luiz Americo Status acknowledged => assigned
2010-12-08 14:12 Luiz Americo Assigned To => Luiz Americo
2010-12-08 14:32 Marelis Note Added: 0044097
2010-12-08 14:39 Luiz Americo Note Added: 0044098
2012-02-04 12:08 Zeljan Rikalo LazTarget post 1.0 => 1.2
2014-01-14 15:16 Martin Friebe LazTarget 1.2 => 1.4
2014-09-10 01:07 Juha Manninen LazTarget 1.4 => -
2017-10-23 01:14 Juha Manninen Relationship added related to 0016071
2017-10-23 10:04 Juha Manninen Note Added: 0103711
2017-10-23 10:04 Juha Manninen Status assigned => resolved
2017-10-23 10:04 Juha Manninen Resolution open => fixed