View Issue Details

IDProjectCategoryView StatusLast Update
0018457LazarusDebuggerpublic2015-05-03 21:58
ReporterHans LuijtenAssigned ToMartin Friebe 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
PlatformOSMacOS XOS Version10.6.5/10.6.6
Product Version0.9.31 (SVN)Product Build2011-01-08 
Target VersionFixed in Version0.9.31 (SVN) 
Summary0018457: Debugger issues with NTFS Volume
DescriptionWhen a project is stored on a NTFS volume (I'm using "Paragon NTFS for Mac v8" - which works perfectly fine for other applications) the following things happen:

You will need to click the "Run" button (or menu option) twice.

The first click the application is being compiled but never runs.
The second click it compiles again and runs just fine.
(see attached log files)

However the second run starts with the debugger window opening with a notification of an error state ("oops, the debugger entered the error state").
After closing the window, the compiled application runs just fine (incl. reporting crashes, breakpoints, etc).

The debug output shows that the gdb does not seem to recognize the volume:

<-environment-cd "/Volumes/Shared Data/Projects/Lazarus/test/">
^error,msg="/Volumes/Shared: No such file or directory"
(gdb)

(the volume obviously does exist)
Steps To Reproduce1. Install Lazarus/FPC as usual

2. Create a project on a NTFS volume
(might require "Paragon NTFS for Mac v8" for that)

3. Click run.

4. Click run again.
Additional InformationWork around:

Save your project on a MacOS volume instead.
TagsNo tags attached.
Fixed in Revision31831
LazTarget1.0
WidgetsetCarbon
Attached Files

Relationships

related to 0017528 resolvedMartin Friebe Gdb does not work if a project is saved in a subdirectory of Desktop or Documents (on Windows XP) 
related to 0018238 resolvedMartin Friebe Debugger crashes after the project is saved 

Activities

2011-01-10 00:00

 

Archive.zip (24,803 bytes)

Hans Luijten

2011-01-24 03:16

reporter   ~0045435

After some more experiments I found that the problem is probably not NTSF (or Paragon NTSF for Mac OS). It appears to happen when the source code of my project is NOT on the primary hard-disk.

My Mac OS (what I call the primary hard-disk) is on a SSD drive.
My second drive is a 1Tb SATA drive which is use for data and have split that disk into a few partitions. One of those partitions is NTFS, the other one Mac OS Extended (Journaled). If I work with my project from either drives this problem occurs.

If I run my project from my "primary" drive (tried Desktop, my user folder, my Documents folder) this problem does NOT occur.

Marc Weustink

2011-06-19 01:24

administrator   ~0049192

Not all tools in the toolchain lazarus uses can handle spaces in the project path.

this is exactly what te error says: "/Volumes/Shared: No such file or directory"
It breaks at the space. Nothing we can do about.
Save your project on a location without spaces in the path

Marc Weustink

2011-06-19 01:29

administrator   ~0049193

@Martin: can we escape spaces ?

Martin Friebe

2011-06-20 13:58

manager   ~0049227

please start gdb from a shell (outside lazarus), with either:
  gdb -i mi
  /usr/bin/gdb -i mi

then try and execute (please note the "\" in front of the space)

-environment-cd "/Volumes/Shared\ Data/Projects/Lazarus/test/"

Martin Friebe

2011-07-30 19:52

manager   ~0050293

Please test with rev 31831 or up

Close if ok.

Issue History

Date Modified Username Field Change
2011-01-10 00:00 Hans Luijten New Issue
2011-01-10 00:00 Hans Luijten Status new => assigned
2011-01-10 00:00 Hans Luijten Assigned To => Marc Weustink
2011-01-10 00:00 Hans Luijten File Added: Archive.zip
2011-01-10 00:00 Hans Luijten Widgetset => Carbon
2011-01-24 03:16 Hans Luijten Note Added: 0045435
2011-06-19 01:24 Marc Weustink Note Added: 0049192
2011-06-19 01:29 Marc Weustink Note Added: 0049193
2011-06-20 13:55 Martin Friebe Assigned To Marc Weustink => Martin Friebe
2011-06-20 13:58 Martin Friebe LazTarget => -
2011-06-20 13:58 Martin Friebe Note Added: 0049227
2011-06-20 13:58 Martin Friebe Status assigned => feedback
2011-06-20 13:58 Martin Friebe Relationship added related to 0017528
2011-06-20 13:58 Martin Friebe Relationship added related to 0018238
2011-07-30 19:52 Martin Friebe Fixed in Revision => 31831
2011-07-30 19:52 Martin Friebe LazTarget - => 1.0
2011-07-30 19:52 Martin Friebe Status feedback => resolved
2011-07-30 19:52 Martin Friebe Fixed in Version => 0.9.31 (SVN)
2011-07-30 19:52 Martin Friebe Resolution open => fixed
2011-07-30 19:52 Martin Friebe Note Added: 0050293
2011-07-30 19:53 Martin Friebe Target Version => 0.99.0
2015-05-03 21:58 Hans Luijten Status resolved => closed