View Issue Details

IDProjectCategoryView StatusLast Update
0018498LazarusLCLpublic2011-12-01 11:26
ReporterTeemu ValoAssigned ToJesus Reyes 
PrioritynormalSeveritycrashReproducibilityalways
Status closedResolutionfixed 
Product Version0.9.31 (SVN)Product Build 
Target Version1.0.0Fixed in Version0.9.31 (SVN) 
Summary0018498: Removing last line from TStringGrid crashes application
DescriptionI have a TStringGrid on application and:

procedure TForm1.eListDblClick(Sender: TObject);
begin
  eList.RowCount:=eList.RowCount-1;
end;

When i doubleclick last line and wait or click somewhere again it gives crash dialog and some info about index out of bounds. It's interesting to note that it doesn't crash directly on doubleclick but only afterwards, like triggered by some internal event.
Additional InformationThis error doesn't happen with clean application, there are a few properties set with this specific TStringGrid. I have yet been unable to locate which property exactly, and debugger doesn't give me enough help either.
Debug stops at TCustomGrid.CellRect().

Included simple empty project with just this component and it crashes aswell.

Updated to SVN 29002.
TagsNo tags attached.
Fixed in Revision29577
LazTarget0.99.0
WidgetsetWin32/Win64
Attached Files

Activities

2011-01-14 03:20

 

Gridproject.zip (2,444 bytes)

Teemu Valo

2011-01-14 13:00

reporter   ~0045169

UPDATE: I found the property and replicated the bug with clean application. It is
Options.goHeaderHotTracking

Something may finally be found after TCustomGrid.HeadersMouseMove() which seems to be the only function using it.

Jesus Reyes

2011-02-16 22:19

developer   ~0046102

please test

Issue History

Date Modified Username Field Change
2011-01-14 03:20 Teemu Valo New Issue
2011-01-14 03:20 Teemu Valo File Added: Gridproject.zip
2011-01-14 03:20 Teemu Valo Widgetset => Win32/Win64
2011-01-14 13:00 Teemu Valo Note Added: 0045169
2011-01-14 16:23 Paul Ishenin Status new => assigned
2011-01-14 16:23 Paul Ishenin Assigned To => Jesus Reyes
2011-02-16 22:19 Jesus Reyes Fixed in Revision => 29577
2011-02-16 22:19 Jesus Reyes LazTarget => 0.99.0
2011-02-16 22:19 Jesus Reyes Status assigned => resolved
2011-02-16 22:19 Jesus Reyes Fixed in Version => 0.9.31 (SVN)
2011-02-16 22:19 Jesus Reyes Resolution open => fixed
2011-02-16 22:19 Jesus Reyes Note Added: 0046102
2011-02-16 22:20 Jesus Reyes Target Version => 1.0.0
2011-12-01 11:26 Marc Weustink Status resolved => closed