View Issue Details

IDProjectCategoryView StatusLast Update
0018514LazarusLCLpublic2017-08-15 11:22
ReporterBenito van der Zander Assigned ToOndrej Pokorny  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionnot fixable 
Platformi386 on amd64OSWindows 
Product Version0.9.31 (SVN) 
Summary0018514: show on minimized form
DescriptionIf you call "show" on a minimized win32 form it stays minimized and invisible.
On contrast, if you call show on a minimized gtk2 form under linux, it becomes visible and the windowstate changes to the value it has before minimizing.

(This is an important issue if your application minimizes to an tray icon)
TagsNo tags attached.
Fixed in Revision
LazTarget-
WidgetsetWin32/Win64
Attached Files

Relationships

has duplicate 0021331 resolvedMattias Gaertner A hidden minimized form can't be shown again 
related to 0018511 assignedZeljan Rikalo windowstate chaos 
related to 0020670 closedPaul Ishenin Cannot restore/show hidden minimized form [regression] 

Activities

2011-01-15 13:15

 

example.tar.gz (2,659 bytes)

Zeljan Rikalo

2012-02-06 18:17

developer   ~0056587

@Benito, can you test with r >= 35169 ?

Benito van der Zander

2012-03-21 18:07

reporter   ~0057878

Nothing changed (with 35621 or 36191)

Juha Manninen

2017-04-24 21:30

developer   ~0099880

Ondrej, you fixed some similar issues. I think this one got fixed, too.

Ondrej Pokorny

2017-04-24 21:34

developer   ~0099881

Yes, I did :)

Benito, can you confirm that the issue is fixed in 1.8/1.9?

Ondrej Pokorny

2017-04-25 09:52

developer   ~0099898

If I understand correctly, there is a difference between Win32 and Gtk2 implementation.

Under Win32 you can show a minimized window - it means the taskbar button or minimized form bar is visible. So in terms of Win32 the current behavior is correct.

If you want to unminimize a minimized window, you have to change its state. If you want to restore a state that the form was in before minimizing, you have to store the state in some variable.

This behavior seems logical to me. My opinion is that Gtk2 should be fixed.

Issue History

Date Modified Username Field Change
2011-01-15 13:15 Benito van der Zander New Issue
2011-01-15 13:15 Benito van der Zander File Added: example.tar.gz
2011-01-15 13:15 Benito van der Zander Widgetset => Win32/Win64
2011-02-07 20:45 Vincent Snijders LazTarget => 1.2
2011-02-07 20:45 Vincent Snijders Status new => acknowledged
2011-02-07 20:45 Vincent Snijders Target Version => 1.2.0
2011-02-07 20:46 Vincent Snijders Relationship added related to 0018511
2011-11-18 17:33 Juha Manninen Relationship added related to 0020670
2012-02-06 18:17 Zeljan Rikalo Note Added: 0056587
2012-02-06 18:17 Zeljan Rikalo Status acknowledged => feedback
2012-03-13 00:57 Paul Ishenin Relationship added has duplicate 0021331
2012-03-13 00:58 Paul Ishenin Status feedback => assigned
2012-03-13 00:58 Paul Ishenin Assigned To => Mattias Gaertner
2012-03-21 18:07 Benito van der Zander Note Added: 0057878
2014-01-14 15:10 Martin Friebe LazTarget 1.2 => 1.4
2014-01-14 15:12 Martin Friebe Target Version 1.2.0 => 1.4
2015-05-07 06:45 Juha Manninen Target Version 1.4 =>
2015-05-07 06:46 Juha Manninen LazTarget 1.4 => -
2017-04-24 21:29 Juha Manninen Assigned To Mattias Gaertner => Ondrej Pokorny
2017-04-24 21:30 Juha Manninen Note Added: 0099880
2017-04-24 21:34 Ondrej Pokorny Note Added: 0099881
2017-04-25 09:52 Ondrej Pokorny Note Added: 0099898
2017-04-25 09:52 Ondrej Pokorny Status assigned => resolved
2017-04-25 09:52 Ondrej Pokorny Resolution open => not fixable