View Issue Details

IDProjectCategoryView StatusLast Update
0018519LazarusIDEpublic2011-02-09 21:45
ReporterSven BarthAssigned ToMattias Gaertner 
PrioritynormalSeverityminorReproducibilityN/A
Status closedResolutionfixed 
Product Version0.9.31 (SVN)Product Build 
Target VersionFixed in Version0.9.31 (SVN) 
Summary0018519: "Save as" in context menu of package window is confusing
DescriptionThe "Save as" entry in the context menu in a package window inside the tree which displays the used units is a bit confusing, because I personally would expect this entry to allow to save the selected(!) unit to a different location, but in reality it saves the package file to another location.

Please either change this to "Save Package as" (maybe adjust the "Save" and "Restore" options as well) or change the behavior to really save the selected unit (if no unit is selected this item should be disabled). Of course a combination of those two alternatives is also a possibility.
TagsNo tags attached.
Fixed in Revision29050
LazTarget-
Widgetset
Attached Files

Activities

Vincent Snijders

2011-02-07 21:17

manager   ~0045884

This seems to be fixed in the mean time, isn't it? Maybe r29050?

Sven Barth

2011-02-09 21:45

manager   ~0045922

I don't know in which revision, but it looks indeed much less confusing. :D

Regards,
Sven

Issue History

Date Modified Username Field Change
2011-01-15 15:55 Sven Barth New Issue
2011-02-07 21:17 Vincent Snijders LazTarget => -
2011-02-07 21:17 Vincent Snijders Note Added: 0045884
2011-02-07 21:17 Vincent Snijders Status new => feedback
2011-02-07 21:18 Vincent Snijders Assigned To => Mattias Gaertner
2011-02-07 21:18 Vincent Snijders Fixed in Revision => 29050
2011-02-07 21:18 Vincent Snijders Status feedback => resolved
2011-02-07 21:18 Vincent Snijders Fixed in Version => 0.9.31 (SVN)
2011-02-07 21:18 Vincent Snijders Resolution open => fixed
2011-02-09 21:45 Sven Barth Status resolved => closed
2011-02-09 21:45 Sven Barth Note Added: 0045922