View Issue Details

IDProjectCategoryView StatusLast Update
0018537LazarusLCLpublic2011-12-01 11:26
ReporterBobanAssigned ToPaul Ishenin 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Product Version0.9.31 (SVN)Product Build 
Target VersionFixed in Version0.9.31 (SVN) 
Summary0018537: Can't build LCL for WinCE
DescriptionIt hangs at various points in fileprocs.pas.



Additional InformationFirst, it does not respect {$IFDEF MSWindows} and thus reporting missing Unix unit.
After changing {$IFDEF MSWindows} to {$IFDEF Windows} it complaints about c:\lazarus\components\codetools\fileprocs.pas(363,10) Error: Forward declaration not solved "dbgMemRange(PByte,LongInt,LongInt="0"):AnsiString;"

SVN revision used is 29046 with FPC 2.4.3
TagsNo tags attached.
Fixed in Revision29121,29228
LazTarget-
WidgetsetWinCE
Attached Files

Activities

Vincent Snijders

2011-01-16 22:05

manager   ~0045242

Fileprocs is not LCL, but code tools.

Why do you build the code tools for WinCE?

Boban

2011-01-16 22:40

reporter   ~0045244

I apologize, but what am I doing wrong?

I have now installed same SVN revision, but for FPC 2.4.2
I've got LCL built for WinCE/arm, but I still have random problems:
- if I try to build my project (which worked fine with Fixes branch) I still got FileProcs errors.
After a couple of re-builds of LCL (for both WinCE and Win32) I got pass FileProcs error at building my app, but now I got "componentreg.pas(32,32) Fatal: Can't find unit LazarusPackageIntf used by ComponentReg"

It is like it tries to rebuild the IDE if I want to build my app.

Can you instruct me how to get more details needed to fix this bug?
Or to instruct me how to give more details on how to reproduce this bug?

Boban

2011-01-16 23:05

reporter   ~0045245

Got it!
One of the custom installed packages (KOL-CE) have had Codetools listed as dependency. After removing the dependency I got my project compiled.

Boban

2011-01-16 23:30

reporter   ~0045246

Argh... this still isn't OK.
As I removed CodeTools as dependency from KOL-CE, I can't rebuild Lazarus anymore (to add new components).

On other hand, if I try to build WinCE app that uses KOL-CE, I can't because of CodeTools (fileprocs.pas(485,19) Fatal: Can't find unit Unix used by FileProcs)

Paul Ishenin

2011-01-19 13:43

manager   ~0045308

Please update to r29121 and test if you can compile the codetools package for wince. If it works then close the issue.

Boban

2011-01-19 19:45

reporter   ~0045312

Issue is not solved.

I'll try to explain one more time what happens:
- I install Lazarus SVN version
- after that I install the crosscompiler
- building LCL for WinCE/arm works at this stage
- I install KOL-CE components, add missing unit in Uses section ( see http://lazarus.freepascal.org/index.php/topic,8963.0.html )
- I rebuild LCL - it works
- I rebuild LCL with checked Rebuild Packages option - it works
- I open a project which uses KOL-CE components, and try to compile it for WinCE/arm - here I got fileprocs.pas(485,19) Fatal: Can't find unit Unix used by FileProcs

Paul Ishenin

2011-01-20 00:08

manager   ~0045316

Check that your lazarus svn version is based on revision greater or equal than r29121.

Boban

2011-01-21 16:40

reporter   ~0045381

Tested today with r29154.
Still do not compile.
Now it stops with the following message:
C:\lazarus\components\codetools\fileprocs.pas(370,10) Error: Forward declaration not solved "dbgMemRange(PByte,LongInt,LongInt="0"):AnsiString;"

Paul Ishenin

2011-01-28 05:22

manager   ~0045521

Ok. This time I made a crosscompiler and checked the compilation. Yes, PByte was redeclared in the implemenation and this caused the problem.

Now codetools compiles for wince. Please test and close if ok.

Boban

2011-01-31 17:47

reporter   ~0045640

Sorry, I can't test because daily snapshots of crosscompiler are too old (buildbot seems not working), and if lazarus and crosscompiler versions mismatch I get some error message about compiler being older than ppu files (or something like that).

Issue History

Date Modified Username Field Change
2011-01-16 21:58 Boban New Issue
2011-01-16 21:58 Boban Widgetset => WinCE
2011-01-16 22:05 Vincent Snijders Note Added: 0045242
2011-01-16 22:40 Boban Note Added: 0045244
2011-01-16 23:05 Boban Note Added: 0045245
2011-01-16 23:30 Boban Note Added: 0045246
2011-01-19 13:43 Paul Ishenin Fixed in Revision => 29121
2011-01-19 13:43 Paul Ishenin LazTarget => -
2011-01-19 13:43 Paul Ishenin Status new => resolved
2011-01-19 13:43 Paul Ishenin Fixed in Version => 0.9.31 (SVN)
2011-01-19 13:43 Paul Ishenin Resolution open => fixed
2011-01-19 13:43 Paul Ishenin Assigned To => Paul Ishenin
2011-01-19 13:43 Paul Ishenin Note Added: 0045308
2011-01-19 19:45 Boban Note Added: 0045312
2011-01-20 00:08 Paul Ishenin Note Added: 0045316
2011-01-21 16:40 Boban Note Added: 0045381
2011-01-25 23:10 Boban Status resolved => assigned
2011-01-25 23:10 Boban Resolution fixed => reopened
2011-01-28 05:22 Paul Ishenin Fixed in Revision 29121 => 29121,29228
2011-01-28 05:22 Paul Ishenin Status assigned => resolved
2011-01-28 05:22 Paul Ishenin Resolution reopened => fixed
2011-01-28 05:22 Paul Ishenin Note Added: 0045521
2011-01-31 17:47 Boban Note Added: 0045640
2011-12-01 11:26 Marc Weustink Status resolved => closed