View Issue Details

IDProjectCategoryView StatusLast Update
0018581LazarusLCLpublic2013-02-12 20:36
ReporterMarkus MüllerAssigned ToJesus Reyes 
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionfixed 
Product Version0.9.31 (SVN)Product Build 
Target Version1.2.0Fixed in Version1.1 (SVN) 
Summary0018581: TGrid and TDBGrid with highlighting Row.
DescriptionTCustomGrid new option in TGridOption "goRowHighlight"
TGridDrawState new "gdRowHighlight"
TCustomDBGrid new option in TDBGridOption "dgRowHighlight"

- With this parameter the Grid Line with the selected Cell was hilighted.
- The event "OnDrawColumnCell" send in the "State" the "gdRowHighlight" if in the row is the cursor (selected).
-The highlighted cells becomes the Color := ColorToRGB(Color) XOr $1F1F1F;
Additional InformationSee here: http://www.lazarusforum.de/viewtopic.php?p=44356#p44356
Tested with FPC2.5.1 Lazarus 0.9.31 Build 29158
It works fine.

In Attachment ist a file with:
- diff
- the two .pas Files
- Picture with show the resolution

Thank you for including this features into Lazarus
TagsNo tags attached.
Fixed in Revision40276
LazTarget1.2
WidgetsetWin32/Win64
Attached Files
  • TGrid.zip (93,228 bytes)
  • Grid.zip (91,360 bytes)
  • grid.diff (2,194 bytes)
    diff lcl_New\dbgrids.pas lcl_Orig\dbgrids.pas
    69,70c69
    <     dgAutoSizeColumns,
    <     dgRowHighlight
    ---
    >     dgAutoSizeColumns
    964c963
    <     FOptions := FOptions - [dgEditing, dgAlwaysShowEditor, dgRowHighlight];
    ---
    >     FOptions := FOptions - [dgEditing, dgAlwaysShowEditor];
    1017,1021d1015
    < 
    <     if dgRowHighlight in FOptions then
    <       Include(OldOptions, goRowHighlight)
    <     else
    <       Exclude(OldOptions, goRowHighlight);
    diff lcl_New\grids.pas lcl_Orig\grids.pas
    48,49c48
    <   //GRIDFILEVERSION = 3; // Introduced Col/Row FixedAttr and NormalAttr
    <   GRIDFILEVERSION = 4; // Introduced Options goRowHighlight and gdRowHighlight
    ---
    >   GRIDFILEVERSION = 3; // Introduced Col/Row FixedAttr and NormalAttr
    107,108c106
    <     goFixedColSizing,
    <     goRowHighlight        // Highlight the current Row
    ---
    >     goFixedColSizing
    120c118
    <   TGridDrawState = set of (gdSelected, gdFocused, gdFixed, gdHot, gdPushed, gdRowHighlight);
    ---
    >   TGridDrawState = set of (gdSelected, gdFocused, gdFixed, gdHot, gdPushed);
    2143,2145d2140
    <   if (goRowHighlight In Options) Then
    <     OldRange := Rect(FFixedCols, OldRange.Top, Colcount-1, OldRange.Bottom);
    < 
    2174c2169
    <     if not ((goRowSelect in Options) Or (goRowHighlight in Options)) then begin
    ---
    >     if not (goRowSelect in Options) then begin
    2211c2206
    <     if ((goRowSelect in Options) Or (goRowHighlight in Options)) then
    ---
    >     if goRowSelect in Options then
    3408,3410c3403
    <       If (gdRowHighlight In aState) And Not (gdFixed in AState) Then
    <         Canvas.Brush.Color := ColorToRGB(AColor) XOr $1F1F1F
    <       Else Canvas.Brush.Color := AColor;
    ---
    >       Canvas.Brush.Color := AColor;
    3766,3767d3758
    <       If (aRow=FRow) And (goRowHighlight In FOptions) And Not (gdFixed In gds) then
    <         gds := gds + [gdRowHighlight];
    6575c6566
    <     if ((goRowSelect in Options) Or (goRowHighlight in Options)) then
    ---
    >     if goRowSelect in Options then
    7997d7987
    <     Cfg.SetValue(Path+'goRowHighlight/value', goRowHighlight in Options);
    8143,8145d8132
    <       end;
    <       if Version>=4 then begin
    <         GetValue('goRowHighlight',goRowHighlight);
    
    grid.diff (2,194 bytes)
  • grid_2.7.1_32237.diff (2,307 bytes)
    diff lcl_New\dbgrids.pas lcl_Orig\dbgrids.pas
    69,70c69
    <     dgAutoSizeColumns,
    <     dgRowHighlight
    ---
    >     dgAutoSizeColumns
    964c963
    <     FOptions := FOptions - [dgEditing, dgAlwaysShowEditor, dgRowHighlight];
    ---
    >     FOptions := FOptions - [dgEditing, dgAlwaysShowEditor];
    1017,1021d1015
    < 
    <     if dgRowHighlight in FOptions then
    <       Include(OldOptions, goRowHighlight)
    <     else
    <       Exclude(OldOptions, goRowHighlight);
    diff lcl_New\grids.pas lcl_Orig\grids.pas
    48,49c48
    <   //GRIDFILEVERSION = 3; // Introduced Col/Row FixedAttr and NormalAttr
    <   GRIDFILEVERSION = 4; // Introduced Options goRowHighlight and gdRowHighlight
    ---
    >   GRIDFILEVERSION = 3; // Introduced Col/Row FixedAttr and NormalAttr
    108,109c107
    <     goDontScrollPartCell, // clicking partially visible cells will not scroll
    <     goRowHighlight        // Highlight the current Row
    ---
    >     goDontScrollPartCell  // clicking partially visible cells will not scroll
    121c119
    <   TGridDrawState = set of (gdSelected, gdFocused, gdFixed, gdHot, gdPushed, gdRowHighlight);
    ---
    >   TGridDrawState = set of (gdSelected, gdFocused, gdFixed, gdHot, gdPushed);
    2153,2155d2150
    <   if (goRowHighlight In Options) Then
    <     OldRange := Rect(FFixedCols, OldRange.Top, Colcount-1, OldRange.Bottom);
    < 
    2184c2179
    <     if not ((goRowSelect in Options) Or (goRowHighlight in Options)) then begin
    ---
    >     if not (goRowSelect in Options) then begin
    2221c2216
    <     if ((goRowSelect in Options) Or (goRowHighlight in Options)) then
    ---
    >     if goRowSelect in Options then
    3401,3403c3396
    <       If (gdRowHighlight In aState) And Not (gdFixed in AState) Then
    <         Canvas.Brush.Color := ColorToRGB(AColor) XOr $1F1F1F
    <       Else Canvas.Brush.Color := AColor;
    ---
    >       Canvas.Brush.Color := AColor;
    3759,3760d3751
    <       If (aRow=FRow) And (goRowHighlight In FOptions) And Not (gdFixed In gds) then
    <         gds := gds + [gdRowHighlight];
    6586c6577
    <     if ((goRowSelect in Options) Or (goRowHighlight in Options)) then
    ---
    >     if goRowSelect in Options then
    8063d8053
    <     Cfg.SetValue(Path+'goRowHighlight/value', goRowHighlight in Options);
    8209,8211d8198
    <       end;
    <       if Version>=4 then begin
    <         GetValue('goRowHighlight',goRowHighlight);
    
    grid_2.7.1_32237.diff (2,307 bytes)
  • TGrid_39965.zip (103,689 bytes)
  • TGrid_40217.zip (102,943 bytes)
  • grid_2.6.0_40217.diff (2,213 bytes)
    diff lcl_New\dbgrids.pas lcl_Orig\dbgrids.pas
    79,80c79
    <     dgCellEllipsis,                     // show ... if cell text is truncated
    <     dgRowHighlight                      // Highlight current row
    ---
    >     dgCellEllipsis                      // show ... if cell text is truncated
    1012c1011
    <     FOptions := FOptions - [dgEditing, dgAlwaysShowEditor, dgRowHighlight];
    ---
    >     FOptions := FOptions - [dgEditing, dgAlwaysShowEditor];
    1080,1084d1078
    < 
    <     if dgRowHighlight in FOptions then
    <       Include(OldOptions, goRowHighlight)
    <     else
    <       Exclude(OldOptions, goRowHighlight);
    diff lcl_New\grids.pas lcl_Orig\grids.pas
    112,113c112
    <     goAutoAddRowsSkipContentCheck,//BB Also add a row (if AutoAddRows in Options) if last row is empty
    <     goRowHighlight        // Highlight the current Row
    ---
    >     goAutoAddRowsSkipContentCheck//BB Also add a row (if AutoAddRows in Options) if last row is empty
    125c124
    <   TGridDrawState = set of (gdSelected, gdFocused, gdFixed, gdHot, gdPushed, gdRowHighlight);
    ---
    >   TGridDrawState = set of (gdSelected, gdFocused, gdFixed, gdHot, gdPushed);
    2222,2223d2220
    <   if (goRowHighlight in Options) then
    <     OldRange := Rect(FFixedCols, OldRange.Top, Colcount-1, OldRange.Bottom);
    2252c2249
    <     if not ((goRowSelect in Options) or (goRowHighlight in Options)) then begin
    ---
    >     if not (goRowSelect in Options) then begin
    2289c2286
    <     if ((goRowSelect in Options) or (goRowHighlight in Options)) then
    ---
    >     if goRowSelect in Options then
    3480,3482c3477
    <       if (gdRowHighlight in aState) and not (gdFixed in AState) then
    <         Canvas.Brush.Color := ColorToRGB(AColor) xor $1F1F1F
    <       else Canvas.Brush.Color := AColor;
    ---
    >       Canvas.Brush.Color := AColor;
    6847c6842
    <     if ((goRowSelect in Options) or (goRowHighlight in Options)) then
    ---
    >     if goRowSelect in Options then
    8158,8159d8152
    <   if (aRow=FRow) and (goRowHighlight in FOptions) and not (gdFixed in Result) then
    <      Result := Result + [gdRowHighlight];
    8370d8362
    <     Cfg.SetValue(Path+'goRowHighlight/value', goRowHighlight in Options);
    8515d8506
    <       GetValue('goRowHighlight',goRowHighlight);
    
    grid_2.6.0_40217.diff (2,213 bytes)

Activities

2011-01-22 09:10

 

TGrid.zip (93,228 bytes)

Markus Müller

2011-01-25 20:12

reporter   ~0045473

Hello, I have test this now with FPC2.5.1_16812/Laz0.9.31_29193 with Linux and it works fine.

2011-06-22 22:58

 

Grid.zip (91,360 bytes)

Markus Müller

2011-06-22 23:00

reporter   ~0049315

Last edited: 2011-06-22 23:01

Hello, I have see, there was some changes in the newest Lazarus Version 0.9.31-31324. I have include my changes into this file. So you can better include it in the current sources. See the file from today.

Jesus Reyes

2011-06-23 23:00

developer   ~0049347

I tried the changes, it has problem on selecting ranges please check it, please use diff against current SVN revision.

2011-07-14 22:39

 

grid.diff (2,194 bytes)
diff lcl_New\dbgrids.pas lcl_Orig\dbgrids.pas
69,70c69
<     dgAutoSizeColumns,
<     dgRowHighlight
---
>     dgAutoSizeColumns
964c963
<     FOptions := FOptions - [dgEditing, dgAlwaysShowEditor, dgRowHighlight];
---
>     FOptions := FOptions - [dgEditing, dgAlwaysShowEditor];
1017,1021d1015
< 
<     if dgRowHighlight in FOptions then
<       Include(OldOptions, goRowHighlight)
<     else
<       Exclude(OldOptions, goRowHighlight);
diff lcl_New\grids.pas lcl_Orig\grids.pas
48,49c48
<   //GRIDFILEVERSION = 3; // Introduced Col/Row FixedAttr and NormalAttr
<   GRIDFILEVERSION = 4; // Introduced Options goRowHighlight and gdRowHighlight
---
>   GRIDFILEVERSION = 3; // Introduced Col/Row FixedAttr and NormalAttr
107,108c106
<     goFixedColSizing,
<     goRowHighlight        // Highlight the current Row
---
>     goFixedColSizing
120c118
<   TGridDrawState = set of (gdSelected, gdFocused, gdFixed, gdHot, gdPushed, gdRowHighlight);
---
>   TGridDrawState = set of (gdSelected, gdFocused, gdFixed, gdHot, gdPushed);
2143,2145d2140
<   if (goRowHighlight In Options) Then
<     OldRange := Rect(FFixedCols, OldRange.Top, Colcount-1, OldRange.Bottom);
< 
2174c2169
<     if not ((goRowSelect in Options) Or (goRowHighlight in Options)) then begin
---
>     if not (goRowSelect in Options) then begin
2211c2206
<     if ((goRowSelect in Options) Or (goRowHighlight in Options)) then
---
>     if goRowSelect in Options then
3408,3410c3403
<       If (gdRowHighlight In aState) And Not (gdFixed in AState) Then
<         Canvas.Brush.Color := ColorToRGB(AColor) XOr $1F1F1F
<       Else Canvas.Brush.Color := AColor;
---
>       Canvas.Brush.Color := AColor;
3766,3767d3758
<       If (aRow=FRow) And (goRowHighlight In FOptions) And Not (gdFixed In gds) then
<         gds := gds + [gdRowHighlight];
6575c6566
<     if ((goRowSelect in Options) Or (goRowHighlight in Options)) then
---
>     if goRowSelect in Options then
7997d7987
<     Cfg.SetValue(Path+'goRowHighlight/value', goRowHighlight in Options);
8143,8145d8132
<       end;
<       if Version>=4 then begin
<         GetValue('goRowHighlight',goRowHighlight);
grid.diff (2,194 bytes)

Markus Müller

2011-07-14 22:42

reporter   ~0049992

I have load the new Lazarus "Lazarus-0.9.31-31683-fpc-2.5.1-20110713-win32.exe" and insert in the files my changes.

I have found the "selecting ranges" problem and fix it. See it in the .diff file from 2011-07-14.

Sorry for my late answer, but I look not every day in this bugtracker.

2011-09-10 22:26

 

grid_2.7.1_32237.diff (2,307 bytes)
diff lcl_New\dbgrids.pas lcl_Orig\dbgrids.pas
69,70c69
<     dgAutoSizeColumns,
<     dgRowHighlight
---
>     dgAutoSizeColumns
964c963
<     FOptions := FOptions - [dgEditing, dgAlwaysShowEditor, dgRowHighlight];
---
>     FOptions := FOptions - [dgEditing, dgAlwaysShowEditor];
1017,1021d1015
< 
<     if dgRowHighlight in FOptions then
<       Include(OldOptions, goRowHighlight)
<     else
<       Exclude(OldOptions, goRowHighlight);
diff lcl_New\grids.pas lcl_Orig\grids.pas
48,49c48
<   //GRIDFILEVERSION = 3; // Introduced Col/Row FixedAttr and NormalAttr
<   GRIDFILEVERSION = 4; // Introduced Options goRowHighlight and gdRowHighlight
---
>   GRIDFILEVERSION = 3; // Introduced Col/Row FixedAttr and NormalAttr
108,109c107
<     goDontScrollPartCell, // clicking partially visible cells will not scroll
<     goRowHighlight        // Highlight the current Row
---
>     goDontScrollPartCell  // clicking partially visible cells will not scroll
121c119
<   TGridDrawState = set of (gdSelected, gdFocused, gdFixed, gdHot, gdPushed, gdRowHighlight);
---
>   TGridDrawState = set of (gdSelected, gdFocused, gdFixed, gdHot, gdPushed);
2153,2155d2150
<   if (goRowHighlight In Options) Then
<     OldRange := Rect(FFixedCols, OldRange.Top, Colcount-1, OldRange.Bottom);
< 
2184c2179
<     if not ((goRowSelect in Options) Or (goRowHighlight in Options)) then begin
---
>     if not (goRowSelect in Options) then begin
2221c2216
<     if ((goRowSelect in Options) Or (goRowHighlight in Options)) then
---
>     if goRowSelect in Options then
3401,3403c3396
<       If (gdRowHighlight In aState) And Not (gdFixed in AState) Then
<         Canvas.Brush.Color := ColorToRGB(AColor) XOr $1F1F1F
<       Else Canvas.Brush.Color := AColor;
---
>       Canvas.Brush.Color := AColor;
3759,3760d3751
<       If (aRow=FRow) And (goRowHighlight In FOptions) And Not (gdFixed In gds) then
<         gds := gds + [gdRowHighlight];
6586c6577
<     if ((goRowSelect in Options) Or (goRowHighlight in Options)) then
---
>     if goRowSelect in Options then
8063d8053
<     Cfg.SetValue(Path+'goRowHighlight/value', goRowHighlight in Options);
8209,8211d8198
<       end;
<       if Version>=4 then begin
<         GetValue('goRowHighlight',goRowHighlight);
grid_2.7.1_32237.diff (2,307 bytes)

Markus Müller

2011-09-10 22:30

reporter   ~0051710

Last edited: 2011-09-10 22:32

I have now download and install the new "Lazarus-0.9.31-32237-fpc-2.7.1-20110909-win32.exe".

Now see the DIFF "grid_2.7.1_32237.diff" (without changes, only a new diff about your new version).

I have reinclude my changes at x time again in this files.
I hope you finally have time to take this feature in, because I'm tired of you any more to share with the features.

Jesus Reyes

2011-09-10 23:22

developer   ~0051711

oh, I'm sorry I tried your changes from "2011-07-14 22:39" but it still had bugs, I thought in fixing the problems myself when I have time so we can have this function in grids, but still I have not time available for fixing the problems it causes.

I will try your new changes in grid_2.7.1_32237.diff if I find bugs again I will write you a personal note and if you want I can share my test app so you can try it.

Markus Müller

2011-09-11 07:49

reporter   ~0051714

OK, you can write me mails: "mmvisual et web.de".
I have find and change your reported bug and test it with a TGrid. I self use it only with TDBGrid.

Please look for:
I have change the "GRIDFILEVERSION", then I have include a new value (you see it). In the last month there where a lot of changes, but not change the "LoadContent" and "SaveContent" functions.

2013-01-26 13:56

 

TGrid_39965.zip (103,689 bytes)

Markus Müller

2013-01-26 14:02

reporter   ~0065183

Last edited: 2013-01-26 14:05

Hello Jesus Reyes,

Now I have attach the new DIFF files, see "TGrid_39965.zip".

I have see, your last change was make the TGridOptions komplett full with 32 options. Now, I have make a new "TGridOption2" with this new feature.

Please, please, please include this in the lazarus sources. I must every some days, when I test the new snapshot manually insert this changes and it is very ungly for me. This changes are working for more then two years without any problems. You can only include it. :-)

Thank you very much, Regards Markus.

Jesus Reyes

2013-01-29 09:49

developer   ~0065273

I tried your patches and didn't find the problem with selecting ranges I noted before, well to be honest I don't remember what tests I did :) but current tests it worked fine. In order to apply your patch I will ask you to make some changes, please don't use Options2 for this feature, use Option property, please don't use camel case on keywords or operators, use always lowercase (ej Or->or, Xor->xor, Then->then, etc.), that's all. Thanks.

Markus Müller

2013-02-07 12:34

reporter   ~0065540

Last edited: 2013-02-07 14:29

View 2 revisions

Thank you very much for testing, I think the selection range was a other problem, where you have fix in the last two years ;-)

The changes into lowercase can i do.

But in the Options "TGridOption" are now 32 options included. This is full an I cannot insert my new option in this existing TGridOption (FPC generate a Error!).
Only, I can include it into "OptionsExtra", but is it right?

I think in the future comes more options for more features for this grids. Please write how you want have it and I change it in the code.

Jesus Reyes

2013-02-07 19:42

developer   ~0065552

"The compiler stores small sets (less than 32 elements) in a Longint, if the type range allows it. This allows for faster processing and decreases program size. Otherwise, sets are stored in 32 bytes."

if more options are needed we can still use Options property but we will have to change the way is declared, probably we will have to introduce a "stored" section so FPC is happy again.

There is no problem with one more option because currently there are 31 elements, it accepts one more which is all what HighlightRow feature requires.

Markus Müller

2013-02-09 17:54

reporter  

TGrid_40217.zip (102,943 bytes)

Markus Müller

2013-02-09 17:58

reporter  

grid_2.6.0_40217.diff (2,213 bytes)
diff lcl_New\dbgrids.pas lcl_Orig\dbgrids.pas
79,80c79
<     dgCellEllipsis,                     // show ... if cell text is truncated
<     dgRowHighlight                      // Highlight current row
---
>     dgCellEllipsis                      // show ... if cell text is truncated
1012c1011
<     FOptions := FOptions - [dgEditing, dgAlwaysShowEditor, dgRowHighlight];
---
>     FOptions := FOptions - [dgEditing, dgAlwaysShowEditor];
1080,1084d1078
< 
<     if dgRowHighlight in FOptions then
<       Include(OldOptions, goRowHighlight)
<     else
<       Exclude(OldOptions, goRowHighlight);
diff lcl_New\grids.pas lcl_Orig\grids.pas
112,113c112
<     goAutoAddRowsSkipContentCheck,//BB Also add a row (if AutoAddRows in Options) if last row is empty
<     goRowHighlight        // Highlight the current Row
---
>     goAutoAddRowsSkipContentCheck//BB Also add a row (if AutoAddRows in Options) if last row is empty
125c124
<   TGridDrawState = set of (gdSelected, gdFocused, gdFixed, gdHot, gdPushed, gdRowHighlight);
---
>   TGridDrawState = set of (gdSelected, gdFocused, gdFixed, gdHot, gdPushed);
2222,2223d2220
<   if (goRowHighlight in Options) then
<     OldRange := Rect(FFixedCols, OldRange.Top, Colcount-1, OldRange.Bottom);
2252c2249
<     if not ((goRowSelect in Options) or (goRowHighlight in Options)) then begin
---
>     if not (goRowSelect in Options) then begin
2289c2286
<     if ((goRowSelect in Options) or (goRowHighlight in Options)) then
---
>     if goRowSelect in Options then
3480,3482c3477
<       if (gdRowHighlight in aState) and not (gdFixed in AState) then
<         Canvas.Brush.Color := ColorToRGB(AColor) xor $1F1F1F
<       else Canvas.Brush.Color := AColor;
---
>       Canvas.Brush.Color := AColor;
6847c6842
<     if ((goRowSelect in Options) or (goRowHighlight in Options)) then
---
>     if goRowSelect in Options then
8158,8159d8152
<   if (aRow=FRow) and (goRowHighlight in FOptions) and not (gdFixed in Result) then
<      Result := Result + [gdRowHighlight];
8370d8362
<     Cfg.SetValue(Path+'goRowHighlight/value', goRowHighlight in Options);
8515d8506
<       GetValue('goRowHighlight',goRowHighlight);
grid_2.6.0_40217.diff (2,213 bytes)

Markus Müller

2013-02-09 18:01

reporter   ~0065609

I have now load the new SVN 40217 and include it again and there is one option free for the Highlight Feature, thank you very much :-)

I have include it into the current sources into TGridOption and change to lowercase in the file "grid_2.6.0_40217.diff".

Jesus Reyes

2013-02-12 04:36

developer   ~0065640

applied, thank you.

Issue History

Date Modified Username Field Change
2011-01-22 09:10 Markus Müller New Issue
2011-01-22 09:10 Markus Müller File Added: TGrid.zip
2011-01-22 09:10 Markus Müller Widgetset => Win32/Win64
2011-01-22 13:49 Zeljan Rikalo Status new => assigned
2011-01-22 13:49 Zeljan Rikalo Assigned To => Jesus Reyes
2011-01-25 20:12 Markus Müller Note Added: 0045473
2011-06-22 22:58 Markus Müller File Added: Grid.zip
2011-06-22 23:00 Markus Müller Note Added: 0049315
2011-06-22 23:01 Markus Müller Note Edited: 0049315
2011-06-23 23:00 Jesus Reyes LazTarget => -
2011-06-23 23:00 Jesus Reyes Note Added: 0049347
2011-06-23 23:00 Jesus Reyes Status assigned => feedback
2011-07-14 22:39 Markus Müller File Added: grid.diff
2011-07-14 22:42 Markus Müller Note Added: 0049992
2011-09-10 22:26 Markus Müller File Added: grid_2.7.1_32237.diff
2011-09-10 22:30 Markus Müller Note Added: 0051710
2011-09-10 22:32 Markus Müller Note Edited: 0051710
2011-09-10 23:22 Jesus Reyes Note Added: 0051711
2011-09-11 07:49 Markus Müller Note Added: 0051714
2011-10-17 12:54 Vincent Snijders Status feedback => assigned
2011-10-30 14:02 Zeljan Rikalo LazTarget - => 1.2
2013-01-26 13:56 Markus Müller File Added: TGrid_39965.zip
2013-01-26 14:02 Markus Müller Note Added: 0065183
2013-01-26 14:04 Markus Müller Note Edited: 0065183
2013-01-26 14:05 Markus Müller Note Edited: 0065183
2013-01-29 09:49 Jesus Reyes Note Added: 0065273
2013-01-29 09:49 Jesus Reyes Status assigned => feedback
2013-02-07 12:34 Markus Müller Note Added: 0065540
2013-02-07 12:34 Markus Müller Status feedback => assigned
2013-02-07 14:29 Markus Müller Note Edited: 0065540 View Revisions
2013-02-07 19:42 Jesus Reyes Note Added: 0065552
2013-02-09 17:54 Markus Müller File Added: TGrid_40217.zip
2013-02-09 17:58 Markus Müller File Added: grid_2.6.0_40217.diff
2013-02-09 18:01 Markus Müller Note Added: 0065609
2013-02-12 04:36 Jesus Reyes Fixed in Revision => 40276
2013-02-12 04:36 Jesus Reyes Note Added: 0065640
2013-02-12 04:36 Jesus Reyes Status assigned => resolved
2013-02-12 04:36 Jesus Reyes Fixed in Version => 1.1 (SVN)
2013-02-12 04:36 Jesus Reyes Resolution open => fixed
2013-02-12 04:36 Jesus Reyes Target Version => 1.2.0